Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

8095 Posts

11-19-2007

United States of America

10101 Signins

400183 Page Views

  • Posts: 8095
  • Registered: ‎11-19-2007
  • Location: United States of America
  • Views: 400183
  • Message 1 of 42

T430 - T530 Wireless drops

2013-08-07, 21:25 PM

 

I'm starting this new thread to focus discussion on symptoms of wireless drops originally reported as 1 or 2 symtoms discussed in this thread.  The second symptom in that thread, the error 31 and yellow bang in device manager, we believe now has a solution covered in the thread.

 

I'm moving over all comments from the other thread which seem to relate to the wireless drops symptoms.  As you add comments on this thread, please help us keep focus on wireless dropping symptom, and let us know which system you have, which wireless card, wifi driver version, and OS that you are running.

 

This may be similar to the T430s discussion on Wifi found here, but we would like to keep that discussed focused on T430s which is a different system design than the standard T430 and T530, unless we can find a commonality between the two threads - perhaps a particular family of wifi cards, or other factor.

 

Daladai wrote:

 

 "My wifi suddenly turns off several times each day: PC disconnects from network, cannot see any other wifi network but the wifi light is still on. "Troubleshoot problem" solves the problem for a while but later it turns off again. I tried both "Resolving Power Management Scenario 1" and "Resolving Power Management Scenario 2" suggested by lenovo support but these do not solve my problem.

Network adapter: Intel(R) Centrino(R) Advanced-N 6205"

 

 

Reply
Options

2 Posts

12-01-2012

buffalo, new york

8 Signins

36 Page Views

  • Posts: 2
  • Registered: ‎12-01-2012
  • Location: buffalo, new york
  • Views: 36
  • Message 2 of 42

T430 - T530 Wireless drops

2012-12-01, 0:50 AM

I have the wifi sleeping on it's own terms as I have adjusted power maanagement plus currnetly showing WAN Minport (Network Monitor) #2 and "This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)"

 

Running Windows 8 Professional 64 bit.  New out of the box this is a major screwup!

Reply
Options

2 Posts

12-01-2012

buffalo, new york

8 Signins

36 Page Views

  • Posts: 2
  • Registered: ‎12-01-2012
  • Location: buffalo, new york
  • Views: 36
  • Message 3 of 42

RT430 - T530 Wireless drops

2012-12-05, 14:57 PM

MY T430 has the same issue - connectivity to network is lost and or corrupted - new out the box the week before thanksgiving - yet ot be resolved - this is an absolute nightmare!

Reply
Options

4 Posts

12-11-2012

canada

11 Signins

112 Page Views

  • Posts: 4
  • Registered: ‎12-11-2012
  • Location: canada
  • Views: 112
  • Message 4 of 42

T430 - T530 Wireless drops

2012-12-11, 23:19 PM

I have the same issue with my T430s and Windows 8 that I received a few days ago.  I also have an issue where my wifi connectivity dies repeatedly every few hours; probably not related, but thought I would mention it just in case.

Reply
Options

1 Posts

12-17-2012

United States of America

21 Signins

47 Page Views

  • Posts: 1
  • Registered: ‎12-17-2012
  • Location: United States of America
  • Views: 47
  • Message 5 of 42

T430 - T530 Wireless drops

2012-12-17, 17:05 PM

so does Lenovo not monitor this site?  There are many questions about this issue, but no answers to how to fix it.  Not sure if this is really of any use!  My Lenovo (second one now as first one had many problems).  This one now seems to lose WIFI all the time.  I used the technique suggested above and worked but not sure I'm prepared to do this several times a day!  This is only the 6th day with this newer Lenovo T530.  Probably the most I've ever spent on a laptop or PC!!!!!!!!!!!!

Reply
Options

7 Posts

12-19-2012

santa cruz, CA USA

51 Signins

245 Page Views

  • Posts: 7
  • Registered: ‎12-19-2012
  • Location: santa cruz, CA USA
  • Views: 245
  • Message 6 of 42

T430 - T530 Wireless drops

2012-12-19, 3:15 AM

Hi, i got the same problem

 

machine model: w530

machine model type: 2436CTO

machine serial number: xxxxxxx

os: win 8 pro

 

Does wifi work?

My wifi suddenly turns off several times each day: PC disconnects from network,
cannot see any other wifi network but the wifi light is still on.
"Troubleshoot problem" solves the problem for a while but later it turns off again

 

Does WAN Mininiport (Network monitor) #2 show yellow exclamation mark?

Yes,

In Device Manager under Network adapters "WAN Mininiport (Network monitor) #2" has a yellow mark. In the properties there is written: "This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

 

Moderator Note; s/n edited for member's own protection

Reply
Options

4 Posts

12-09-2012

new york

43 Signins

186 Page Views

  • Posts: 4
  • Registered: ‎12-09-2012
  • Location: new york
  • Views: 186
  • Message 7 of 42

T430 - T530 Wireless drops

2012-12-19, 13:37 PM

Hi,Administrator Cleo_Lenovo

 

Thank you for your concern about this issue. Hopeful you are able to get it fixed.

 

My machine: T530-2359

OS:win 8 64bit

 

Because I have the exact same problem as user "marioska" is , so what I really need to do is just copy and paste his /her problem describe(thanks here). Here it is.

 

Does wifi work?

My wifi suddenly turns off several times each day: PC disconnects from network,
cannot see any other wifi network but the wifi light is still on.
"Troubleshoot problem" solves the problem for a while but later it turns off again

 

Does WAN Mininiport (Network monitor) #2 show yellow exclamation mark?

Yes,

In Device Manager under Network adapters "WAN Mininiport (Network monitor) #2" has a yellow mark. In the properties there is written: "This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

 

 

Thanks again. Sure I could send you my personal imformation  if you need.

Reply
Options

12 Posts

12-23-2012

USA

25 Signins

251 Page Views

  • Posts: 12
  • Registered: ‎12-23-2012
  • Location: USA
  • Views: 251
  • Message 8 of 42

T430 - T530 Wireless drops

2012-12-23, 13:53 PM

Cleo: I just received my new T430 a few days ago and I too am having problems with Wi-Fi radio turning itself on and off whenever it feels like it.  But now it will not turn on at all ...no wireless communication, only cable connection works and I am beginning to wonder for how long that is going to work. 

 

I called Lenovo Tech support and was only able to speak to a service representative to get a case number.  No one ever called me back.  But I did receive a box in the mail with instructions on how to send the laptop back, with no other explanation???  I called Lenovo Tech support again to find out what the box was all about?  He told me that the box was the solution to my problem and the case number had been closed.  Supposedly Lenovo will fix the problem and send me back my machine before next school semester starts on January 7th.  Needless to say, this is a major inconvenience but looks like I'm stuck ...unless someone can come up with a solution to fix this issue on this forum.  It is sad when we have to rely on an internet forum to fix our own machines.  I'm seriously thinking of selling my shares of Lenovo stock! 

 

I hope someone can come up with a solution very soon, and/or at least an explanation why we have to send our laptops back to Lenovo.      

Reply
Options

12 Posts

12-23-2012

USA

25 Signins

251 Page Views

  • Posts: 12
  • Registered: ‎12-23-2012
  • Location: USA
  • Views: 251
  • Message 9 of 42

T430 - T530 Wireless drops

2012-12-24, 16:39 PM

I performed a restore system to a prior date and that seemed to do the trick.  Then, just as suspected, I go away from the machine for about 6 hours and when I try to connect wirelessly the Wi-Fi radio is off and system is only looking for a cable connection.  I tried the Lenovo troubleshoot option and nothing ...just looking for cable and no wireless.  

 

Rebooted the machine and wireless radio was on but not connecting.  Performed the Lenovo troubleshoot option again and wireless is up and running  ...go figure???  We'll see for how long this time...:smileyfrustrated:     

Reply
Options

3 Posts

12-27-2012

United States

25 Signins

73 Page Views

  • Posts: 3
  • Registered: ‎12-27-2012
  • Location: United States
  • Views: 73
  • Message 10 of 42

T430 - T530 Wireless drops

2012-12-27, 20:12 PM

I have a W530 (2436CTO) which came with Windows 7 Pro. Had no issues whatsoever with the setup. Wanted to try out Windows 8 for app development purposes but didnt want to risk my original setup. So I setup Windows 8 Pro to boot from a VHD (excellent how-to @ http://www.techrepublic.com/blog/window-on-windows/dual-boot-windows-7-and-windows-8-using-a-vhd/6537). However, I experienced same problems as @marioska and @daladai.

 

machine model: w530
machine model type: 2436CTO
machine serial number: xxxxxxx
os: win 8 pro
Does wifi work? Intermittently. Turns off/disconnects several times. Even troubleshoot doesnt help. Restart does.
Does WAN Mininiport (Network monitor) #2 show yellow exclamation mark? Yes, In Device Manager under Network adapters "WAN Mininiport (Network monitor) #2" has a yellow mark. In the properties there is written: "This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

 

Will await resolution from Lenovo.

Reply
Options

2 Posts

12-21-2012

Florida

2 Signins

21 Page Views

  • Posts: 2
  • Registered: ‎12-21-2012
  • Location: Florida
  • Views: 21
  • Message 11 of 42

T430 - T530 Wireless drops

2012-12-27, 23:27 PM

I seem to have finally fixed the problem with my wifi connectivity. Downloaded Intel(R) Centrino(R) Wireless-N
2200 Network Adapter  driver from Intel website, and manually updated the driver from the local folder where I downloaded it to. Doing an 'Update Driver' from the Network Adapter properties in control panel did not really update it to the most recent version of the driver available on Intel's website. 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms