Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

5 Posts

09-10-2013

Canada

9 Signins

38 Page Views

  • Posts: 5
  • Registered: ‎09-10-2013
  • Location: Canada
  • Views: 38
  • Message 11 of 33

Re: T430s - 2100: Detection error on HDD0 (Main HDD)

2013-09-23, 12:57 PM

I'll be picking my T430 up from the repair depot today and will update this with whatever they did to resolve.

Reply
Options

2651 Posts

03-21-2012

Malaysia

2405 Signins

55976 Page Views

  • Posts: 2651
  • Registered: ‎03-21-2012
  • Location: Malaysia
  • Views: 55976
  • Message 12 of 33

Re: T430s - 2100: Detection error on HDD0 (Main HDD)

2013-10-01, 9:16 AM
Hi GreenEnvy,

Thanks for posting. Was reading through this thread and wanted to check if your issue was resolved after sending it into the service. Hope to hear back.

Regards
Reply
Options

17 Posts

02-28-2013

Germany

21 Signins

110 Page Views

  • Posts: 17
  • Registered: ‎02-28-2013
  • Location: Germany
  • Views: 110
  • Message 13 of 33

Re: T430s - 2100: Detection error on HDD0 (Main HDD)

2013-10-01, 9:49 AM

Hello everybody,

 

I still have the same problems with my T430s laptops. There is no help from lenovo until now. meanwhile I figured out some more facts about the issue.

 

The current laptop I have with this error comes up with this sh** every few minutes after plugging battery off an on and rebooting again. There is a BSOD for a part of a seccond and if I saw it right it's a 0x000000f4.

 

At first I disabled BitLocker (not only suspended it. I disabled it and decrypted the drive completely). - without any effect.

 

So, I was forced to make a completely new installation of the device. I decided not to use our deployment tool with the whole company stuff cause I wanted to now if maybe some of our SW causes the error. (even if this seemed to be very unlikely regarding the time when the error occurs - very early in boot-process).

 

So I took a completely untouched and original Win7 Ultimate DVD and made a fresh installation.

This system is running without any problems since last Friday - having BitLocker enabled.

 

Now I make a new installation using our deployment-tool. Will see if the error occurs again and post the results.

 

My idea is to compare our installed SW with yours - to see if maybe there are some relations.

So here is our basical SW:

 

- Win7 ultimate x64 (eng or german)

- Symantec Endpoint Protection 12.1

- CheckPoint VPN Client 75.10

- Steelhead client - Ver. 49.2.20485.5 (WAN optimization by riverbed)

- Ultra VNC 1.0.8.2

Reply
Options

2651 Posts

03-21-2012

Malaysia

2405 Signins

55976 Page Views

  • Posts: 2651
  • Registered: ‎03-21-2012
  • Location: Malaysia
  • Views: 55976
  • Message 14 of 33

Re: T430s - 2100: Detection error on HDD0 (Main HDD)

2013-10-03, 6:43 AM
Hi zmdagworm,

thanks for posting. Just wanted to check with on how it is going with your test? do you see the same error? Do let me know.

Regards
Reply
Options

5 Posts

09-10-2013

Canada

9 Signins

38 Page Views

  • Posts: 5
  • Registered: ‎09-10-2013
  • Location: Canada
  • Views: 38
  • Message 15 of 33

Re: T430s - 2100: Detection error on HDD0 (Main HDD)

2013-10-03, 11:58 AM

Sorry forgot to reply last week.

The repair depot replaced the mainboard, and since then it's been rock solid.

 

 

Reply
Options

17 Posts

02-28-2013

Germany

21 Signins

110 Page Views

  • Posts: 17
  • Registered: ‎02-28-2013
  • Location: Germany
  • Views: 110
  • Message 16 of 33

Re: T430s - 2100: Detection error on HDD0 (Main HDD)

2013-10-10, 11:31 AM

So here is my test:

- Made the basic installation of OS and Drivers - no probs
- Enabled Bitlocker - no probs
- installed all our company SW-Stuff step by step - no probs for 3 days
- checked some BIOS-Settings without changeing anything but accidentally pressed "Exit saving changes"
=> BitLocker Recovery came up

- powered off the device without entering BitLocker-Recovery-Key cause I had no more time left
- powered the device on again 5 days later and unlocked BitLocker
- I suspended BitLocker security and rebooted the device
- installed some trivial softwareupdates via deploymenttool (pdf-reader) and then during installation:

- GOT THE BLUESCREEN AGAIN AND AFTERWARDS THE 2100-ERROR

Result: I know as much as I knew before I started the test.

I'm going to claim a mainboard replacement from our vendor now and afterwards - new installation again.

regards

Reply
Options

2651 Posts

03-21-2012

Malaysia

2405 Signins

55976 Page Views

  • Posts: 2651
  • Registered: ‎03-21-2012
  • Location: Malaysia
  • Views: 55976
  • Message 17 of 33

Re: T430s - 2100: Detection error on HDD0 (Main HDD)

2013-10-16, 9:25 AM
Hi zmdagworm,

Thanks for posting back your finding. this is really a great. Let bring this up with the teams and get to take a look at what you've manage to find.

Regards
Reply
Options

1 Posts

01-02-2014

United States

1 Signins

9 Page Views

  • Posts: 1
  • Registered: ‎01-02-2014
  • Location: United States
  • Views: 9
  • Message 18 of 33

Re: T430s - 2100: Detection error on HDD0 (Main HDD)

2014-01-02, 18:32 PM

Hi NDeavour,

    First of all, I want to say Happy New Year to you. You've save my day :-). Your solution is work great like champ. Once again, thank you so much. This thread is very helpful.

Reply
Options

13 Posts

03-01-2013

USA

26 Signins

148 Page Views

  • Posts: 13
  • Registered: ‎03-01-2013
  • Location: USA
  • Views: 148
  • Message 19 of 33

Fixed, 2100: Detection error on HDD0 (Main HDD)

2014-03-01, 19:47 PM

What seems to be common in all these "Detection Error" threads are SSDs, never HDDs, and a variety of Lenovo models.

 

Observations:

  • The "bad" SSD read just fine in Linux and other Windows boxes when configured as the non-boot device. Electrically it was functional.
  • Similarly, the connector is fine so it's mechanically sound.
  • I'm religious about Firmware/BIOS updates so I didmissed that as a cause. (Note below)
  • My failure actually occured during video remastering of a 20G file when disk writes occur at a furious pace.

Hm, large number of fast disk writes and SSD. What if garbage collection and TRIM got behind and the SSD wrote itself full?

 

My SSD is an OCZ Vector so out came the OCZ Toolbax and I forced a TRIM. Normally TRIM takes seconds but this one took over a minute. Inserted SSD back into Lenovo and voila. I've been up for days.

 

My humble opinion? Lenovo's BIOS doesn't deal well with a "no free space" SSD.

 

* Note: Some SSD firmware updates will force a TRIM so firmware updates may fix the problem on some SSDs. Personally, I'd be afraid of updating an SSD with live data.

 

 

 

Reply
Options

17 Posts

02-28-2013

Germany

21 Signins

110 Page Views

  • Posts: 17
  • Registered: ‎02-28-2013
  • Location: Germany
  • Views: 110
  • Message 20 of 33

Re: Fixed, 2100: Detection error on HDD0 (Main HDD)

2014-03-01, 20:59 PM

Hi woodp,

 

I can confirm that this problem only occures on ThinkPads with SSD. But I'm not sure about your opinion regarding the TRIM.

Which leads me to this result is the fact that all of our clean installations leave 10% discspace unused and the Error appeared during the first few days when the user got the device - some machines crashed after a few minutes of usage. There haven't been much write-activity on the devices at this time.

 

Most of the devices stopped having the crashes after updating BIOS, SSD-Firmware and SEP-Client (Symantec Endpoint Protection) to the latest versions (I guess it was 12.1.3 in these days).

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms