Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

28 Posts

08-13-2012

Singapore

29 Signins

281 Page Views

  • Posts: 28
  • Registered: ‎08-13-2012
  • Location: Singapore
  • Views: 281
  • Message 1 of 8

T430s bluetooth and wwan missing

2013-04-01, 13:44 PM

Hi,

 

When I pressed Fn-F5 previously, I had the option to enable/disable Wireless Lan, Bluetooth and Wireless Wan. However after running System Update recently, when the latest Access Connections (5.98) and BIOS (2.52) was installed, I have lost Bluetooth and Wireless Wan!

 

When I press Fn-F5 now, I only have the option of Wireless Lan.

 

I have checked the BIOS, and Wireless Lan, Bluetooth and Wireless Wan are Enabled. I have tried setting them to Disabled and then Enabled again but the problem remains.

 

I even did a factory reset. but I still cannot find Bluetooth and Wireless Wan.

 

The Wireless Wan adapter can be seen in Device Manager and Network Connections. Using "Diagnose this Connection", the suggestion is to "Turn on mobile broadband capability" & "Use the switch on the front or side of the computer, or use functions keys if available, to turn on mobile broadband capability on this computer."

 

The hardware wireless switch is turned on but Fn-F5 has no option for Wireless Wan.

 

Bluetooth is worse; the adapter cannot be found in Device Manager.

 

Please help!

Reply
Answer
Options

28 Posts

08-13-2012

Singapore

29 Signins

281 Page Views

  • Posts: 28
  • Registered: ‎08-13-2012
  • Location: Singapore
  • Views: 281

Re: T430s bluetooth and wwan missing

2013-04-04, 14:18 PM

rolled back from 2.52 to 2.51 (can't go further back because downgrade to versions below 2.5 is not permitted) but it didn't work.

 

I tried F9 to reload defaults.

I went through the various options. In desperation, I enabled WiMax (which I don't have installed) and Thunderbolt which were disabled.

Rebooted and now I have both Bluetooth and WWAN back.

 

I am not sure if it's the BIOS downgrade OR enabling WiMax and Thunderbolt. If the former, I hope Lenovo fixed the BIOS. If the latter, Lenovo should still fix the BIOS.

 

Hope this helps someone.

Reply

Replies(7)
Options

28 Posts

08-13-2012

Singapore

29 Signins

281 Page Views

  • Posts: 28
  • Registered: ‎08-13-2012
  • Location: Singapore
  • Views: 281
  • Message 2 of 8

Re: T430s bluetooth and wwan missing

2013-04-03, 13:01 PM

help? anyone?

Reply
Options

11963 Posts

01-02-2010

United States of America

40259 Signins

423794 Page Views

  • Posts: 11963
  • Registered: ‎01-02-2010
  • Location: United States of America
  • Views: 423794
  • Message 3 of 8

Re: T430s bluetooth and wwan missing

2013-04-03, 15:55 PM
I would try uninstalling Access Connections and see if anything changes? Also, after updating the BIOS, did you try hitting F9 to load defaults? I have seen the loading of default settings fix unexplained problems after a BIOS update. It is free to try.

Rich


I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo.
Reply
Options

987 Posts

06-03-2011

United States of America

591 Signins

14790 Page Views

  • Posts: 987
  • Registered: ‎06-03-2011
  • Location: United States of America
  • Views: 14790
  • Message 4 of 8

Re: T430s bluetooth and wwan missing

2013-04-03, 18:38 PM

What operating system are you using on you T430s?

X1 Carbon 3rd Gen Type 20BT i7-5500U, 2560x1440 (non-touch), Win 10 Pro, 8GB RAM, 512 SSD, Intel 7625 WiFi, BT 4.0 | ThinkVision P24q-10 monitor

------------------------------------------
When asking for help, post your question in the forum. Remember to include your system type, model number, and OS. Do not post your serial number.

Did someone help you today? Thank them with a Kudo!

If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help others with the same question in the future.
Reply
Options

28 Posts

08-13-2012

Singapore

29 Signins

281 Page Views

  • Posts: 28
  • Registered: ‎08-13-2012
  • Location: Singapore
  • Views: 281
  • Message 5 of 8

Re: T430s bluetooth and wwan missing

2013-04-04, 0:21 AM

thanks.

 

what I have done is:

1. go to BIOS, F9 to restore factory default settings.

2. check that Bluetooth and wan are both enabled in BIOS

3. restored windows to factory default (F11) - windows 7 pro x64

4. ran system update to bring all drivers up to date

5. checked that hardware switch is ON (which it is since I can use WiFi)

 

but still no joy!

 

device manager shows Gobi 3000 device. however, network diagnosis says that mobile broadband capability has to be turned on through function keys or hardware switch.

 

Bluetooth device does not show up in device manager. the hardware is definitely installed because I used to pair it with my phone plus Fn-F5 used to have 3 options - wifi, wwan, Bluetooth, airplane mode. now it only has wifi and airplane mode.

 

any other ideas?

Reply
Options

37 Posts

07-24-2009

Austin

69 Signins

784 Page Views

  • Posts: 37
  • Registered: ‎07-24-2009
  • Location: Austin
  • Views: 784
  • Message 6 of 8

Re: T430s bluetooth and wwan missing

2013-04-04, 1:05 AM

Since your bluetooth hardware isn't even showing up in Windows device manager, my guess is it's a BIOS issue. Which BIOS were you on before? If it's a recent one, you should be able to revert to the old version and isolate the problem.

Reply
Answer
Options

28 Posts

08-13-2012

Singapore

29 Signins

281 Page Views

  • Posts: 28
  • Registered: ‎08-13-2012
  • Location: Singapore
  • Views: 281
  • Message 7 of 8

Re: T430s bluetooth and wwan missing

2013-04-04, 14:18 PM

rolled back from 2.52 to 2.51 (can't go further back because downgrade to versions below 2.5 is not permitted) but it didn't work.

 

I tried F9 to reload defaults.

I went through the various options. In desperation, I enabled WiMax (which I don't have installed) and Thunderbolt which were disabled.

Rebooted and now I have both Bluetooth and WWAN back.

 

I am not sure if it's the BIOS downgrade OR enabling WiMax and Thunderbolt. If the former, I hope Lenovo fixed the BIOS. If the latter, Lenovo should still fix the BIOS.

 

Hope this helps someone.

0 person found this solution to be helpful.

This helped me too

Reply
Options

1 Posts

09-24-2013

Montréal, Québec

6 Signins

14 Page Views

  • Posts: 1
  • Registered: ‎09-24-2013
  • Location: Montréal, Québec
  • Views: 14
  • Message 8 of 8

Re: T430s bluetooth and wwan missing

2013-09-24, 13:21 PM

When I realized my BlueTooth card was not listed in Device Manager, I found your helpful post

That was after 2 BIOS updates through the ThinkVantage SystemUpdate tool...

I didn't need to roll-back from 2.52; just had to set defaults (F9) and disable WiMax and WWAN I/Os, which I don't have on my T430s.

Now that I've fixed this, I still can't create an "Access Connection" profile based on BlueTooth internet connection, but that's another topic I guess...

Thanks again

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms