Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

24 Posts

12-02-2013

Germany

167 Signins

749 Page Views

  • Posts: 24
  • Registered: ‎12-02-2013
  • Location: Germany
  • Views: 749
  • Message 1 of 8

T440s - UltraNav driver issues

2014-03-21, 23:35 PM

Hi!

 

Apart from the fact that the new TrackPoint/TrackPad doesn't work really well, I've got some driver issues.

 

1) First of all, I can't use the middle button and the TrackPoint to scroll. However, I think I've read many people saying that this works fine. My middle button has no function whatsoever, in Windows 7 and 8.1 and with all drivers since release.

 

2) Firmware upgrade doesn't work. I initially hoped this new firmware upgrade could make the TrackPoint/TrackPad less buggy, but when I tried installing it, it would start upgrading, then stop, tell me "There are no supported devices found." and leave the TouchPad malfunctioning after reboot. I recently downgraded from Windows 8.1 to 7 and now it won't even start, telling me immediately that it can't find supported devices.

 

3) The newest Synaptics driver 18.0.7.34 is horrible and unusuable for me. When installing it, I can move the TrackPoint, but clicking the TrackPad won't do a mouse click. Only tapping (not clicking) works and only left-clicking. When only using the TrackPad, I can also press it down and generate a mouse click. However, right-clicking and gestures don't work at all. What on earth is up with that?

Reply
Options

9644 Posts

12-27-2009

Canada

3313 Signins

95283 Page Views

  • Posts: 9644
  • Registered: ‎12-27-2009
  • Location: Canada
  • Views: 95283
  • Message 2 of 8

Re: T440s - UltraNav driver issues

2014-03-22, 15:11 PM
I'm not sure exactly what's happening but it seems to me like the firmware update is complaining about the drivers being out of whack, and the drivers are out of whack because the firmware is out of whack.

Try this tool:
https://driverstoreexplorer.codeplex.com/

1) Download a copy of 18.0.7.34 and have it ready to be installed.
2) Run RAPR and check all of the Synaptics drivers and force uninstall them.
3) Reboot
4) Install 18.0.7.34
5) Try the firmware update

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
Reply
Options

24 Posts

12-02-2013

Germany

167 Signins

749 Page Views

  • Posts: 24
  • Registered: ‎12-02-2013
  • Location: Germany
  • Views: 749
  • Message 3 of 8

Re: T440s - UltraNav driver issues

2014-03-22, 16:03 PM

Thank you for this suggestion.

 

Unfortunately, it malfunctions exactly like before. I guess I'll have to try reinstalling Windows, maybe my current driver setup is seriously messed up.

 

So, back to my issue 1, should the middle button work under normal circumstances? I've got my T440s since October and middle-button scrolling never worked. I begin suspecting my TrackPoint to be damaged hardware-side or firmware-side, not software-side.

Reply
Options

9380 Posts

11-27-2007

Slovakia

15518 Signins

2040239 Page Views

  • Posts: 9380
  • Registered: ‎11-27-2007
  • Location: Slovakia
  • Views: 2040239
  • Message 4 of 8

Re: T440s - UltraNav driver issues

2014-03-23, 23:12 PM

Andy  

______________________________________


Please remember to come back and mark the post that you feel solved your question as the solution, it earns the member + points

Did you find a post helpfull? You can thank the member by clicking on the star to the left awarding them Kudos

Please add your type, model number and OS to your signature, it helps to help you.

Forum Search Option T430 2347-G7U W8 x64, Yoga 10 HD+, Tablet 1838-2BG, T61p 6460-67G W7 x64, T43p 2668-G2G XP, T23 2647-9LG XP, plus a few more.

FYI Unsolicited Personal Messages will be ignored.

de.gif  Deutsche Community   es.gif  Comunidad en Español  uk.gif  English Community ru.gif Русскоязычное Сообщество

PepperonI blog 

Reply
Options

24 Posts

12-02-2013

Germany

167 Signins

749 Page Views

  • Posts: 24
  • Registered: ‎12-02-2013
  • Location: Germany
  • Views: 749
  • Message 5 of 8

Re: T440s - UltraNav driver issues

2014-03-25, 15:08 PM

Bump.

Reply
Options

122 Posts

03-11-2009

Southeastern US

289 Signins

2371 Page Views

  • Posts: 122
  • Registered: ‎03-11-2009
  • Location: Southeastern US
  • Views: 2371
  • Message 6 of 8

Re: T440s - UltraNav driver issues

2014-03-26, 0:31 AM
I've had my T440s for a few weeks now. Came with Win8 preload, upgraded to Win 8.1, then let TVSU update all the drivers. I've not had a single issue like you describe with the touchpad or trackpoint.

With all your upgrading & downgrading versions of software and operating systems, I think a clean install might be in order. I never got the "use Win8 to create a bootable USB key for recovery" thing to work, maybe you can talk support into sending you the DVDs.
Reply
Options

24 Posts

12-02-2013

Germany

167 Signins

749 Page Views

  • Posts: 24
  • Registered: ‎12-02-2013
  • Location: Germany
  • Views: 749
  • Message 7 of 8

Re: T440s - UltraNav driver issues

2014-03-28, 19:07 PM

Okay, Lenovo, I'm starting to get really pissed here.

 

I installed a clean Windows 8.1. With the default Windows drivers, the TrackPoint works barely, but at least it does. Then, I ran System Update and it installed the Synaptics UltraNav driver 18.0.7.34. I get the same problem again: tapping the TrackPad triggers a click, pressing down doesn't. This renders the TrackPoint entirely useless and makes the TrackPad hard to use.

 

Furthermore, I tried flashing the latest Synaptics firmware and got the same issue as in my original post: Flashing starts. After a few seconds, it stops. It tells me it encountered error 0x60 if I remember correctly. Here, you can see the log file: http://s000.tinyupload.com/index.php?file_id=06218624356222399193

 

I think I received a faulty product, but Lenovo's support is horrible. I already contacted them because of several hardware issues. The last time I heard from them was almost two times ago, telling me to wait for a further mail.

Reply
Options

1 Posts

10-01-2014

Stockholm

4 Signins

33 Page Views

  • Posts: 1
  • Registered: ‎10-01-2014
  • Location: Stockholm
  • Views: 33
  • Message 8 of 8

Re: T440s - UltraNav driver issues

2014-10-01, 12:06 PM

this is my encounter with the ultranav drivers for t440s.

 

Our company bought several t440s for deployment around the office.

As many other companys we run our own image, so i removed the ultranav driver

without realizing what is was, tried for a whole day to install it again, didnt work.

triend the newest release and suggested by others a fairly old release of drivers, nothing seemed to

work.

 

a day later i got tired of it and completly reainstalled windows 7 64bit on the computer, all from scratch.

Ran WSUS updates and installed lenovo system update thought that it might be the best way to install

all drivers, every single one except the ultranav driver installed correct.

Now i got really annoyed and gave lenovo a call.

 

After trying again to install several different drivers without any result they came to the conclusion it must have been

an faulty product, so now im waiting for a tech guy to come out and replace any hardware on the computer.

 

So for you out there call Lenovo and give them a headsup on this, this is a silly problem that drives people insane.

 

 

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms