Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

6 Posts

03-08-2018

Cyprus

11 Signins

71 Page Views

  • Posts: 6
  • Registered: ‎03-08-2018
  • Location: Cyprus
  • Views: 71
  • Message 1 of 10

T470 - Excel high CPU usage when dragged from main display to the secondary monitor

2018-06-06, 9:01 AM

I face a strange issue on a Lenovo T470 running Windows 10. The problem is when i open an excel spreadsheet, especially one with many tabs, and i drag it from the main display to the external monitor, Excel's cpu usage jumps from 5-8% to 50-60 %, and is not functioning properly. Cannot move from one cell to another, cannot scroll up and down. It is either very slow, or it totally crashes and i have to kill Excel. If i drag the file back to the main display, it works as expected. The issue occurs only when the external monitor is set up as extended monitor. If i set it up as duplicate monitor, it works fine.

I tried removing and reinstalling the display driver and also tried disabling graphics hardware acceleration, but no luck. And this happens only with excel, no other application. A newer version of the driver is available from Intel, but when i try to install it says that it is not certified for the specific model and i should contact the vendor.

 

Computer specs:

- Lenovo T470

- i5 7300U

- 16 GB RAM

- Windows 10 Enterprise Build 15063

- Intel HD Graphics 620

- Secondary monitor is connected either through HDMI or through an HDMI to VGA adapter.

Reply
Options

9644 Posts

12-27-2009

Canada

3313 Signins

95283 Page Views

  • Posts: 9644
  • Registered: ‎12-27-2009
  • Location: Canada
  • Views: 95283
  • Message 2 of 10

Re: T470 - Excel high CPU usage when dragged from main display to the secondary monitor

2018-06-06, 12:00 PM
Do you happen to have DPI scaling enabled on the secondary monitor?

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
Reply
Options

6 Posts

03-08-2018

Cyprus

11 Signins

71 Page Views

  • Posts: 6
  • Registered: ‎03-08-2018
  • Location: Cyprus
  • Views: 71
  • Message 3 of 10

Re: T470 - Excel high CPU usage when dragged from main display to the secondary monitor

2018-06-06, 12:15 PM
I tried 100%, 125%, 150%.... Nothing changed.
Reply
Options

9644 Posts

12-27-2009

Canada

3313 Signins

95283 Page Views

  • Posts: 9644
  • Registered: ‎12-27-2009
  • Location: Canada
  • Views: 95283
  • Message 4 of 10

Re: T470 - Excel high CPU usage when dragged from main display to the secondary monitor

2018-06-06, 12:32 PM
Sounds like it might just be an Excel/Windows/Intel issue...

What if the external monitor is set up as the primary instead?

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
Reply
Options

6 Posts

03-08-2018

Cyprus

11 Signins

71 Page Views

  • Posts: 6
  • Registered: ‎03-08-2018
  • Location: Cyprus
  • Views: 71
  • Message 5 of 10

Re: T470 - Excel high CPU usage when dragged from main display to the secondary monitor

2018-06-06, 13:14 PM
Tried that as well. The problem still persists. I also believe this is an Intel's issue. One thing i didn't try is to rollback the driver to a previous version. But i can't find an older version of the driver on lenovo's site. Any idea i can get one?
Reply
Options

9644 Posts

12-27-2009

Canada

3313 Signins

95283 Page Views

  • Posts: 9644
  • Registered: ‎12-27-2009
  • Location: Canada
  • Views: 95283
  • Message 6 of 10

Re: T470 - Excel high CPU usage when dragged from main display to the secondary monitor

2018-06-06, 13:28 PM
You can try the new drivers off the Intel site as mentioned in your opening post and work around the certification issue using these steps (should still work on Windows 10):
https://www.intel.com/content/www/us/en/support/articles/000005474/graphics-drivers.html

Do remember to make a system restore point beforehand in case it goes wrong.

You can also usually find some older drivers on the Intel download center as well.

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
Reply
Options

6 Posts

03-08-2018

Cyprus

11 Signins

71 Page Views

  • Posts: 6
  • Registered: ‎03-08-2018
  • Location: Cyprus
  • Views: 71
  • Message 7 of 10

Re: T470 - Excel high CPU usage when dragged from main display to the secondary monitor

2018-06-07, 10:20 AM

I used a third party utility (https://www.wagnardsoft.com/content/display-driver-uninstaller-ddu-v17086-released) to remove display drivers. After that i managed to install Intel's drivers. Tried that on three machines that had the issue. One machine was ok after that, the rest two still had the issue.

Reply
Options

9644 Posts

12-27-2009

Canada

3313 Signins

95283 Page Views

  • Posts: 9644
  • Registered: ‎12-27-2009
  • Location: Canada
  • Views: 95283
  • Message 8 of 10

Re: T470 - Excel high CPU usage when dragged from main display to the secondary monitor

2018-06-08, 0:56 AM
Which version of Office/Excel are you using on the machines?

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
Reply
Options

6 Posts

03-08-2018

Cyprus

11 Signins

71 Page Views

  • Posts: 6
  • Registered: ‎03-08-2018
  • Location: Cyprus
  • Views: 71
  • Message 9 of 10

Re: T470 - Excel high CPU usage when dragged from main display to the secondary monitor

2018-06-18, 14:19 PM

Apologies for the late reply. It appears that the issue occurs if the two screens (the laptop and the external) have different DPI scaling issues, for example if the one is set to 100% and the other is set to 125%. If both have the same scaling settings everything works fine. I still did not understand why this happens only in Excel....

Reply
Options

9644 Posts

12-27-2009

Canada

3313 Signins

95283 Page Views

  • Posts: 9644
  • Registered: ‎12-27-2009
  • Location: Canada
  • Views: 95283
  • Message 10 of 10

Re: T470 - Excel high CPU usage when dragged from main display to the secondary monitor

2018-06-19, 16:09 PM
Yeah that was my initial guess; I saw a similar thread previously but can't seem to dredge it up again. I don't quite remember the solution to it either...

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms

Most Liked Authors

(Last 7 days)

View All