English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

1 Posts

04-10-2020

SG

1 Signins

0 Page Views

  • Posts: 1
  • Registered: ‎04-10-2020
  • Location: SG
  • Views: 0
  • Message 11 of 17

Re:T470S: Web camera stops working after 2-3 seconds

2020-04-10, 9:08 AM
Thank you so much on posting the steps to resolve the camera issues. I did exactly the steps and both my laptops are now able to have the camera functions.
Reply
Options

2 Posts

04-16-2020

HU

4 Signins

30 Page Views

  • Posts: 2
  • Registered: ‎04-16-2020
  • Location: HU
  • Views: 30
  • Message 12 of 17

Re:T470S: Web camera stops working after 2-3 seconds

2020-04-16, 15:07 PM

I followed your advice, and did what you said (and i was so proud of myself to do so) but unfortunately it doesn't worked for me. :( I still have the same problem as the others wrote (the cam stop after 1-2 sec). I have a Lenovo Z50 with Lenovo Easy Camera. Any other idea? 

Reply
Options

1 Posts

06-03-2020

IN

3 Signins

15 Page Views

  • Posts: 1
  • Registered: ‎06-03-2020
  • Location: IN
  • Views: 15
  • Message 13 of 17

Re:T470S: Web camera stops working after 2-3 seconds

2020-06-03, 9:54 AM
Thanks a lot. I am using Lenovo ThinkPad X1 Yoga 2nd Generation. I've been facing this issue from quite some time and the solution worked. Thanks again :)
Reply
Options

1 Posts

06-19-2020

US

1 Signins

5 Page Views

  • Posts: 1
  • Registered: ‎06-19-2020
  • Location: US
  • Views: 5
  • Message 14 of 17

Re:T470S: Web camera stops working after 2-3 seconds

2020-06-19, 1:52 AM

Just wanted to say you are awesome.

Reply
Options

2 Posts

08-03-2020

AU

2 Signins

15 Page Views

  • Posts: 2
  • Registered: ‎08-03-2020
  • Location: AU
  • Views: 15
  • Message 15 of 17

Re:T470S: Web camera stops working after 2-3 seconds

2020-08-03, 23:00 PM

Worked for me too. 

Thanks!

Reply
Options

3 Posts

06-15-2016

NA

4 Signins

24 Page Views

  • Posts: 3
  • Registered: ‎06-15-2016
  • Location: NA
  • Views: 24
  • Message 16 of 17

Re:T470S: Web camera stops working after 2-3 seconds

2020-08-07, 14:39 PM

The registry solution worked on my L460. Thanks a lot!

Reply
Options

1 Posts

10-08-2020

ID

1 Signins

5 Page Views

  • Posts: 1
  • Registered: ‎10-08-2020
  • Location: ID
  • Views: 5
  • Message 17 of 17

Re:T470S: Web camera stops working after 2-3 seconds

2020-10-08, 4:30 AM

@ dropsonic wrote:
 

 

I finally found the solution.

 

  1. Start Regedit.exe and go to the following key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Media Foundation\Platform
  2. Create a REG_DWORD value named EnableFrameServerMode and leave the default value (0).
  3. Do the same for the following key: HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows Media Foundation\Platform

 

Reboot is not required. My camera started working immediately after that.

 

The root cause is that Microsoft seems to have dropped support for MJPEG or H264 encoding standards and moved towards YUY2 for performance in one of the major Windows 10 updates.

 

 

This solution works like a charm on Ideapad 320 14ISK, thank you!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete