English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

3 Posts

01-11-2019

GB

5 Signins

81 Page Views

  • Posts: 3
  • Registered: ‎01-11-2019
  • Location: GB
  • Views: 81
  • Message 1 of 5

T470s Thunderbolt port has stopped working

2019-01-11, 10:01 AM

Hi All

 

I have been crawling through these forums and Google in general, it seems a lot of people have similar issues.

 

I run a T470s, I use a Startech USB-C to HDMI adaptor allowing me to connecto to 2 external monitors. I have done for many months and all was fine.

 

I recently ran system update and found multiple drivers needed updating, I ran this and since I cannot use my external monitors. 

 

Thunderbolt software is up to date, as per screenshot it doesnt show the controller version or details in lower half. Device Manager doesnt show the controller at all (even hidden devices).

 

I have tried:

uninstall/reinstall of TB SW

running the firmware update tool but that just says 'No Active Controller' in the system.

I have tried reinstalling every Intel driver available

the BIOS was updated by System Update previously

I have checked the BIOS settings and everything is enabled

 

I found a system restore point from a few days ago which I think is before this started, rolling back to that allows the TB3 SW to show the controller version and a device showing in Device Manager but my monitors still dont work. A further reboot without changing anything takes me back to 'None' controller version and nothing in Device Manager.

 

Open to the idea it could be my adaptor has died, I understand you sometimes need a TB3 device connected to update the FW (?) but I do not have any other devices, hoping to try my adaptor on another machine at head office next week to prove it.

Reply
Options

409 Posts

03-03-2017

JP

1384 Signins

12428 Page Views

  • Posts: 409
  • Registered: ‎03-03-2017
  • Location: JP
  • Views: 12428
  • Message 2 of 5

Re: T470s Thunderbolt port has stopped working

2019-01-17, 8:34 AM

Dear customer,

as long as I understand your situation, Thunderbolt device seems to be broken during previous update process.

I'd like customer to contact Lenovo service to repair the planar.

 

Reply
Options

8 Posts

07-01-2019

US

3 Signins

71 Page Views

  • Posts: 8
  • Registered: ‎07-01-2019
  • Location: US
  • Views: 71
  • Message 3 of 5

Re: T470s Thunderbolt port has stopped working

2019-07-01, 16:01 PM

Can you have customer support contact me to help me as well?

Reply
Options

3 Posts

01-11-2019

GB

5 Signins

81 Page Views

  • Posts: 3
  • Registered: ‎01-11-2019
  • Location: GB
  • Views: 81
  • Message 4 of 5

Re: T470s Thunderbolt port has stopped working

2019-07-01, 16:16 PM

MI_Soldier, if you have the same issue then only solution in the end was to have the motherboard swapped under warranty but not after Lenovo support asked me to wipe my machine and start from fresh. As you can imagine it took hours to backup and wipe it only to find the issue remained.

 

Best I could work out, the firmware update for the thunderbolt bricked the hardware/chip running the port and nothing would bring it back....

Reply
Options

8 Posts

07-01-2019

US

3 Signins

71 Page Views

  • Posts: 8
  • Registered: ‎07-01-2019
  • Location: US
  • Views: 71
  • Message 5 of 5

Re: T470s Thunderbolt port has stopped working

2019-07-01, 17:06 PM
They were just telling me to use the reset on the bottom of the laptop near the ethernet port, so I'm glad I saw this comment that it didn't fix your issue.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete