English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

1 Posts

09-11-2020

BR

1 Signins

5 Page Views

  • Posts: 1
  • Registered: ‎09-11-2020
  • Location: BR
  • Views: 5
  • Message 1 of 1

T480 - Failed to install Intel Management Engine Firmware - 10 [64] - 11.8.79.3722

2020-09-11, 14:05 PM

This thread may be duplicated, but I never seen one with all the information that I am posting here.

 

When trying to install this firmware using Lenovo update tool (the new and the old update tool), I get stuck with a message "Updating the ME firmware".

So, I tried to debug the installation script to realize what's going and if it's possible to force the installation.

 

The installation package contains this:

 

Microsoft Windows [Version 10.0.19041.450]

(c) 2020 Microsoft Corporation. All rights reserved.

 

C:\WINDOWS\system32>cd C:\DRIVERS\WIN\ME\20201109.10180867

 

C:\DRIVERS\WIN\ME\20201109.10180867>dir

Volume in drive C is Windows

Volume Serial Number is B82E-DAB3

 

Directory of C:\DRIVERS\WIN\ME\20201109.10180867

 

09/11/2020  10:18 AM    <DIR>          .

09/11/2020  10:18 AM    <DIR>          ..

02/19/2016  09:15 PM           178,200 FwDetect.exe

02/28/2019  06:17 PM         2,032,600 FwUpdate.exe

06/25/2020  04:52 PM         2,190,936 FWUpdLcl64.exe

06/25/2020  04:52 PM            72,848 Idrvdll32e.dll

06/25/2020  04:52 PM           121,960 ISHLib64.dll

06/25/2020  04:52 PM         2,331,736 MEInfoWin64.exe

04/08/2019  01:13 PM               665 MEUpdate.CMD

06/25/2020  04:52 PM         2,031,616 ME_11.8_Consumer_C0_LP_Production.bin

06/25/2020  04:52 PM         7,348,224 ME_11.8_Corporate_C0_LP_Production.bin

06/25/2020  04:52 PM           125,072 Pmxdll32e.dll

06/25/2020  04:52 PM            80,469 SLA_TOOLS.pdf

             11     16,514,326 bytes

              2 Dir(s)  117,578,330,112 bytes free

 

The first command (after some echoes in the screen), call the MEInfoWin64.exe:

 

%~dp0MEInfoWin64.exe -feat "Intel(R) AMT State" > %~dp0NUL

If errorlevel 1 goto Consumer

 

This is where the stuck happens. The MEInfoWin64.exe can't access whatever they need to access in order to run properly.

So, I went to the BIOS and enabled the Intel AMT:

 

I also disabled any security measures and kept only Computrace enabled:

Then, I rebooted and tried again. Same result.

I checked the Device Manager to check if Intel Management Engine Interface is working properly. All good:

 

 

So, I tried to customize the installation script, by removing the line that is getting stuck and just accepting the CORPORATE profile:

 

@ECHO OFF

 

SET ReturnCode=0

 

CLS

 

echo Updating the ME Firmware...

echo.

 

 

%~dp0FWUpdLcl64.exe -F %~dp0ME_11.8_Corporate_C0_LP_Production.BIN -OEMID 4C656E6F-766F-0000-0000-000000000000 -generic -allowsv -y

SET ReturnCode=%errorlevel%

 

And now I can see an error code:

 

Updating the ME Firmware...

 

 

Intel (R) Firmware Update Utility Version: 11.8.79.3722

Copyright (C) 2007 - 2020, Intel Corporation.  All rights reserved.

 

 

Error 8727: Firmware update tool failed to get the firmware parameters

C:\DRIVERS\WIN\ME\20201109.10180867>

 

Searching for this specific error leads me to specific vendors like Asus. I don't think they apply in my case.

I need assistance to understand what's going wrong. This is a regular Lenovo ThinkPad T480 with Windows 10 Pro 64 bits. Antivirus is disabled during the process (Stock Windows Defender with standard configuration).

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete