English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

2 Posts

11-11-2019

US

2 Signins

75 Page Views

  • Posts: 2
  • Registered: ‎11-11-2019
  • Location: US
  • Views: 75
  • Message 1 of 18

T480 network issue

2019-11-11, 17:46 PM

I've seen this issue now 4 times on 3 different users laptops. I had just reset this T480 to factory image for the exact same problem a few weeks ago. System began blue screening right away after being rebuilt.  Now it's experiencing the same problem that I reset to factory for previously. Essentially there is no internet access despite being connected. In a nutshell the system cannot load websites and port 80 looks blocked and many system utilities hang or don't load or work at all. Task manager, windows search, network properties fails to load, etc. Please tell me by now you have identified this issue. Is it windows updates breaking things, bad drivers,  hardware recall? I've combed through the logs and there's a lot going on in there but nothing that's helped me diagnose or fix the issue.  This also occured on an x1 carbon so it doesn't feel specific to hardware or drivers.  Here a list of some of the troubleshooting I've done, I've likely done more but just putting down what I can think of. 

 

Issue occurs on both wired and wireless

Wired or wireless shows Connected, secured after connecting to wifi

network connection details shows that it has an IP

unable to open network adapter properties, but can view status

ipconfig hangs, if you wait long enough and ctl c it will output

route print hangs

netsh wlan show profiles hangs but eventually outputs

nslookup works fine

ping hangs to dns name

able to ping website IPs ok

telnet hangs connecting to websites

telnet works to known IP on port 22

curl to website hangs

tracert hangs

netstat hangs

ipconfig /flushdns or /registerdns all hang

sfc /scannow did not find integrity violations

malware scans turn up clean

reinstall network adapters

disable firewall

UI based network reset

netsh int ip reset

netsh winsock reset

netsh advfirewall reset

forget wireless networks

task manager hangs trying to close out or trying to end a task

uninstalled windows updates

uninstalled any recently installed programs

ran firewall repair tool

Cleanboot with all non MS services disabled

system restore 3 different times completes successful from within windows, safe mode, or the preboot environment and none fix

Reply
Options

134 Posts

10-18-2018

BA

152 Signins

2277 Page Views

  • Posts: 134
  • Registered: ‎10-18-2018
  • Location: BA
  • Views: 2277
  • Message 2 of 18

Re: T480 network issue

2019-11-11, 19:04 PM

You can go on the Lenovo website and download the drivers for your laptop on a USB and update the Wireless drivers and check to see if that fixes the issue.  Sometimes when you format a laptop it's gonna be missing some drivers.

 

Here is the link: https://pcsupport.lenovo.com/ba/en/products/laptops-and-netbooks/thinkpad-t-series-laptops/thinkpad-t480-type-20l5-20l6/downloads/automatic-driver-update

 

Reply
Options

2 Posts

11-11-2019

US

2 Signins

75 Page Views

  • Posts: 2
  • Registered: ‎11-11-2019
  • Location: US
  • Views: 75
  • Message 3 of 18

Re: T480 network issue

2019-11-11, 19:18 PM

I updated all the drivers, bios, etc a month ago when this first happened as troubleshooting.  Then after I rebuilt it, yes I know it would be missing drivers and such so I ran all windows updates and lenovo updates from vantage utility before returning it to the user.  So everything that is on it, should be pretty current.  I can certainly download and reinstall drivers but I don't believe it'll help at this point. 

Reply
Options

134 Posts

10-18-2018

BA

152 Signins

2277 Page Views

  • Posts: 134
  • Registered: ‎10-18-2018
  • Location: BA
  • Views: 2277
  • Message 4 of 18

Re: T480 network issue

2019-11-11, 19:21 PM

Then it could be a hardware issue. I know I had a old laptop before and I kept on installing all the drivers and everything but once you clicked Restart in Windows it would just flat out refuse to boot and I was really frustrated at it

Reply
Options

1 Posts

12-11-2019

US

1 Signins

73 Page Views

  • Posts: 1
  • Registered: ‎12-11-2019
  • Location: US
  • Views: 73
  • Message 5 of 18

Re: T480 network issue

2019-12-11, 21:29 PM

Hi,

Did you ever get this resolved because I have this issue with multiple Thinkpads also.  Started about 3 months ago.  Have had 8-10 do this now.  Has taken a system restore to bring them back to life.  Pretty much tried the same things you did.  We actually opened a case with Microsoft which is still going on ... they seem to be doing a Google search and giving me things to try from there so in the middle of trying to escalate that case. Need to get a root cause because I can't keep doing system restores on users laptops.  Have seen it on T460, 470, and 480's so far.

Issue only appears when connected to the network (wired or wireless).  Once I connect its all over and takes a reboot to come back.  After reboot if I haven't connected I can do pretty much anything on the laptop... the second I connect it's hung... some windows will open some won't... can type in some places not others, etc.  wifi usually says connected, no internet access

Reply
Options

2 Posts

11-11-2019

US

2 Signins

75 Page Views

  • Posts: 2
  • Registered: ‎11-11-2019
  • Location: US
  • Views: 75
  • Message 6 of 18

Re: T480 network issue

2020-01-17, 1:13 AM

Glad to hear I'm not crazy and the only one having this issue.  Sorry, I haven't found a resolution. I just had another T480 that hadn't experienced this issue before turn up last week.  Exact same issue where I can ping numbers but not names and nslookup works as well as telnet to other ports.  Spent a few hours troubleshooting and ended up formatting it.  I don't have time to backup user data and format these systems everytime they go awry.  The last time it happened I tried to open up cases with lenovo support but their ticketing system is awful and my cases were closed without any support lol.  I don't expect I would get a Sr. Engineer who'd be able to help me anyway.  They'd walk me through all the basics and I don't need that as I've been in IT for 16 years. 

Reply
Options

1 Posts

12-11-2019

US

1 Signins

73 Page Views

  • Posts: 1
  • Registered: ‎12-11-2019
  • Location: US
  • Views: 73
  • Message 7 of 18

Re: T480 network issue

2020-01-17, 14:04 PM

We have tracked it down to dnscache issues which are actually caused by Windows error reporting somehow.  First if we disabled the dnsclient service then things would work (except Edge which relies on that service).  But those issues are actually caused by waiting for the error reporting service so disabling Windows error reporting service instead actually fixes all issues.  I know some run with that service disabled without issue but we're still trying to track down what's causing that to happen in the first place.

What we're doing now though is disabling that service company wide temporarily until we figure out what's going on ... just so we don't have to keep stomping that fire out.

May be something for you to test out with your next problem one.

Reply
Options

2 Posts

11-11-2019

US

2 Signins

75 Page Views

  • Posts: 2
  • Registered: ‎11-11-2019
  • Location: US
  • Views: 75
  • Message 8 of 18

Re: T480 network issue

2020-01-17, 16:20 PM

Thanks for the reply and the addiontional information.  This certainly gives me some things to try and look at the next time it happens.  I had tinkered with the DNS services during my troubleshooting but I hadn't messed with error reporting.  It's such an odd thing to have happen and still persist after a system restore to a date prior. Typically system issues will revert back to stable in cases like this.  I kept looking for common software installs that might be the culprit.  I'm at a small business 50-60 employees and have multiple roles here.  Desktop support isn't my primary function so the less time I spend on things like this the better. I was actually planning to switch to Dell systems in future purchases due to this issue.  Hopefully someone at Lenovo will figure this out and push an update. 

Reply
Options

2 Posts

11-11-2019

US

2 Signins

75 Page Views

  • Posts: 2
  • Registered: ‎11-11-2019
  • Location: US
  • Views: 75
  • Message 9 of 18

Re: T480 network issue

2020-01-20, 19:43 PM

Another report of this issue today...they're becoming far too frequent now.  I was able to edit the registry to disable error reporting service.  That seems to help with troubleshooting now that everything doesn't freeze and hang.  Task manager works, ipconfig outputs, and the network appears as "connected, secured" however flushing dns and stopping the dns service doesn't seem to resolve the issue as I still cannot ping or browse a website by name. Were you able to get a broken system working again with this process? 

Reply
Options

1 Posts

12-11-2019

US

1 Signins

73 Page Views

  • Posts: 1
  • Registered: ‎12-11-2019
  • Location: US
  • Views: 73
  • Message 10 of 18

Re: T480 network issue

2020-01-20, 19:47 PM
Disabling dns client allowed me to browse with Chrome not Edge ... I left that enabled.
But disabling error reporting service allows everything to work. For now that is what we are doing to get these going but still trying to troubleshoot what's happening with that server. I have a case open with Microsoft... I was able to create a remote session with them with that service disabled... then when I enabled that service the problem came back but Microsoft didn't get disconnected so they were able to see the issue. They collected traces and logs and are analyzing them now.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete