Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

7 Posts

09-20-2018

Germany

12 Signins

262 Page Views

  • Posts: 7
  • Registered: ‎09-20-2018
  • Location: Germany
  • Views: 262
  • Message 1 of 5

T480s middle button settings not persistent

2018-09-20, 15:21 PM

I can set Middle Button Action to either Use for scrolling or Use as middle click (in the control panel or Lenovo Vantage) which both work fine until the next reboot. Regardless of the setting, it then uses some kind of fallback-mode. I can't middle-click and I can kind of scroll, but it's worse than before and only works in firefox/chrome.  The control panel/lenovo vantage still show what I had set before but I have to re-apply it to make it work again.

 

I've tried :

  • uninstalling/installing the autoscroll utility
  • uninstalling ELAN Input Device for WDF in the Device Manager and reinstalling it from Windows Update or the driver from the Lenovo website

 

I'm used to open links and close tabs with the middle button and this is driving me insane so I'd be very grateful if someone could tell me how to fix this.

Reply
Options

9575 Posts

01-13-2008

United States of America

78274 Signins

2253770 Page Views

  • Posts: 9575
  • Registered: ‎01-13-2008
  • Location: United States of America
  • Views: 2253770
  • Message 2 of 5

Re: T480s middle button settings not persistent

2018-09-22, 23:51 PM

The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored - questions and answers belong in the forum so that others may contribute and benefit. ... GeezBlog

 

Communities: English Deutsch Español Português Русскоязычное Česká Slovenská Українська Polski Türkçe Moto English

Reply
Options

7 Posts

09-20-2018

Germany

12 Signins

262 Page Views

  • Posts: 7
  • Registered: ‎09-20-2018
  • Location: Germany
  • Views: 262
  • Message 3 of 5

Re: T480s middle button settings not persistent

2018-09-23, 0:10 AM

Since my previous reply got apparently auto-deleted, I'll just try again with some more text. There doesn't seem to be any policy on when bumping a post is/isn't allowed so I'll just go ahead and do it.

 

Does anyone have a solution to this?

Reply
Options

3 Posts

04-04-2019

Germany

7 Signins

63 Page Views

  • Posts: 3
  • Registered: ‎04-04-2019
  • Location: Germany
  • Views: 63
  • Message 4 of 5

Re: T480s middle button settings not persistent

2019-04-04, 21:39 PM
In my case, the following appears to work so far: Open Mouse Properties as administrator (type "Mouse Properties" into Windows Search, right-click and "Run as administrator"), check "Use for scrolling", click "Apply", then check "Use as middle click" again, click "OK".

I have set User Account Control to "Always notify", maybe it has something to do with this setting? Anyway, this is a bug that should be fixed by ELAN/Lenovo.
Reply
Options

3 Posts

04-04-2019

Germany

7 Signins

63 Page Views

  • Posts: 3
  • Registered: ‎04-04-2019
  • Location: Germany
  • Views: 63
  • Message 5 of 5

Re: T480s middle button settings not persistent

2019-04-11, 17:51 PM

For a colleague who also recently got his T480s, the above-mentioned steps didn't work. In his case, the middle button simply did nothing after a reboot or hard shutdown (i.e. shutdown without Fast Boot enabled).

 

Looking inside Task Manager, we found out that whenever the middle button didn't work, only ETDService.exe was running, but ETDCtrl.exe and ETDCtrlHelper.exe were not. He placed links to these executables (they reside in C:\Program Files\Elantech) inside his Startup folder (C:\Users\###YOUR_USERNAME###\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup) and now it works as expected.

 

I hope this gets resolved by Lenovo soon. Buying a laptop for 2000 € and spending hours debugging a trackpoint button felt rather frustrating.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms