Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

2 Posts

04-12-2021

China

3 Signins

5 Page Views

  • Posts: 2
  • Registered: ‎04-12-2021
  • Location: China
  • Views: 5
  • Message 1 of 3

T490s Fan not spinning on windows 10, CPU at 96°C and microphone not working.

2021-04-12, 4:32 AM

Hello,

 

I two T490s running on dual boot Windows 10 and ArchLinux, one recently died for an unknown reason after booting on windows 10 and the other seems to give me a reason why..

They both have a problem with their microphone not working, sound is ok, but microphone is not detected on windows, and detected but not working on linux (the toggle key on the keyboard doesn't light up or down).

 

So, I upgraded everything I could to the latest version with Lenovo Vantage. Fan is still not running on Windows, and not running in "auto" mode on linux, I use thinkfan to force it to run.

 

My first guess is the bios is not handling properly the auto mode, which sensors does the bios use to control the fan speed?

 

Here are some trace:

# cat /sys/class/dmi/id/board_name  
20NX001KMX

# cat /sys/class/dmi/id/bios_version
N2JET94W (1.72 )

 

# sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +69.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +69.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +64.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +66.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +69.0°C  (high = +100.0°C, crit = +100.0°C)

ucsi_source_psy_USBC000:001-isa-0000
Adapter: ISA adapter
in0:           5.00 V  (min =  +5.00 V, max = +15.00 V)
curr1:         3.00 A  (max =  +2.67 A)

pch_cannonlake-virtual-0
Adapter: Virtual device
temp1:        +61.0°C  

BAT0-acpi-0
Adapter: ACPI interface
in0:          12.75 V  

ucsi_source_psy_USBC000:002-isa-0000
Adapter: ISA adapter
in0:           0.00 V  (min =  +0.00 V, max =  +0.00 V)
curr1:         3.00 A  (max =  +0.00 A)

iwlwifi_1-virtual-0
Adapter: Virtual device
temp1:        +48.0°C  

thinkpad-isa-0000
Adapter: ISA adapter
fan1:        3723 RPM
temp1:        +68.0°C  
temp2:            N/A  
temp3:         +0.0°C  
temp4:         +0.0°C  
temp5:        +44.0°C  
temp6:         +0.0°C  
temp7:         +0.0°C  
temp8:            N/A  
temp9:         +0.0°C  
temp10:        +0.0°C  
temp11:       +65.0°C  
temp12:        +0.0°C  
temp13:        +0.0°C  
temp14:        +0.0°C  
temp15:        +0.0°C  
temp16:        +0.0°C  

nvme-pci-3d00
Adapter: PCI adapter
Composite:    +41.9°C  (low  =  -0.1°C, high = +85.8°C)
                       (crit = +88.8°C)
Sensor 1:     +41.9°C  (low  = -273.1°C, high = +65261.8°C)
Sensor 2:     +45.9°C  (low  = -273.1°C, high = +65261.8°C)

acpitz-acpi-0
Adapter: ACPI interface
temp1:        +68.0°C  (crit = +128.0°C)

 

 

Reply
Options

3737 Posts

08-02-2018

United States of America

795 Signins

19358 Page Views

  • Posts: 3737
  • Registered: ‎08-02-2018
  • Location: United States of America
  • Views: 19358
  • Message 2 of 3

Re:T490s Fan not spinning on windows 10, CPU at 96°C and microphone not working.

2021-04-12, 17:41 PM

Hi Tim-sh!


Welcome to community forums


I can see that you already have the updated BIOS version and the issue persist under two different OS. 

 

So, this is more likely a hardware problem and I would suggest bringing it to any of our authorized repair centers in the area for further assistance.

 

You can find the list here: https://pcsupport.lenovo.com/us/en/partnerlocator

Filter the country and the address.

 

However, you can wait for other users' suggestions or recommendations especially those who tried something else.

 

 

 

Jwes_Lenovo



Did someone help you today? Press the thumbs-up icon below to thank them.!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.


Using Browser Search to find your answers in Lenovo and Moto Community

Reply
Options

2 Posts

04-12-2021

China

3 Signins

5 Page Views

  • Posts: 2
  • Registered: ‎04-12-2021
  • Location: China
  • Views: 5
  • Message 3 of 3

Re:T490s Fan not spinning on windows 10, CPU at 96°C and microphone not working.

2021-04-15, 5:36 AM

Thanks for your reply, unfortunately I'm living in Shanghai and there is no repair centers at less than several thousands of kilometers...

 

I'm looking for help on fixing the hardware if this is an hardware problem, and eventually to know how to ensure the motherboard is working properly. All the tests with the diagnostic tools are passing.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms