English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

6 Posts

05-27-2008

Houston, TX

4 Signins

51 Page Views

  • Posts: 6
  • Registered: ‎05-27-2008
  • Location: Houston, TX
  • Views: 51
  • Message 1 of 3

T500 and ATI HD 3650 Driver Problem

2008-09-10, 20:31 PM

I have a brand-new T500. Due to shipping limitations, this was the only model available and it shipped with Windows XP. My company has standardized on Vista Business so I purchased the recovery DVD's with it and loaded Vista as soon as I got it. After the final boot upon install I get an error "ATI Graphics Adapter Driver failed to load." I have been messing with it for about 2 hours now. I've tried uninstalling the driver completely and alternatively installing a) The Lenovo version from the website b) the Microsoft version from Windows Update and c) the ATI version from their website (won't even load).

 

Am I missing something?

Reply
Options

11 Posts

09-03-2008

Germany

26 Signins

171 Page Views

  • Posts: 11
  • Registered: ‎09-03-2008
  • Location: Germany
  • Views: 171
  • Message 2 of 3

Re: T500 and ATI HD 3650 Driver Problem

2008-09-11, 6:49 AM

Hi, seems you are welcome to the "T400/T500-left-anlone-without-proper-driver-support-in-vista" club.

See: http://forums.lenovo.com/lnv/board/message?board.id=T_Series_Thinkpads&thread.id=15703

Message Edited by dasdy78 on 09-11-2008 08:50 AM
Reply
Options

40 Posts

09-10-2008

Dresden, Germany

92 Signins

340 Page Views

  • Posts: 40
  • Registered: ‎09-10-2008
  • Location: Dresden, Germany
  • Views: 340
  • Message 3 of 3

Re: T500 and ATI HD 3650 Driver Problem

2008-09-11, 12:20 PM

hi mmangus,

 

you need to reinstall again ;)

 

try this guide, it worked fine for me.

 

http://forum.notebookreview.com/showthread.php?t=294974

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete