Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

3 Posts

04-02-2009

USA

3 Signins

37 Page Views

  • Posts: 3
  • Registered: ‎04-02-2009
  • Location: USA
  • Views: 37
  • Message 1 of 5

T500 screen blinks off when power is unpluged

2009-04-02, 19:33 PM
I have a t500 w/ xp sp3 & the intel graphics card.  Whenever I disconnect/reconect the ac power the screen turns off for a second.  Why does it do this & how can I fix it?  I was running linux on it and it didn't do this. 
Reply
Options

3 Posts

04-02-2009

USA

3 Signins

37 Page Views

  • Posts: 3
  • Registered: ‎04-02-2009
  • Location: USA
  • Views: 37
  • Message 2 of 5

Re: T500 screen blinks off when power is unpluged

2009-04-03, 4:54 AM
17 views & noone knows?
Reply
Options

16 Posts

04-03-2009

London

22 Signins

172 Page Views

  • Posts: 16
  • Registered: ‎04-03-2009
  • Location: London
  • Views: 172
  • Message 3 of 5

Re: T500 screen blinks off when power is unpluged

2009-04-03, 6:47 AM

Hi,

 

I would try graphic drivers update, or direcX..

 

Check also your power management settings as it might be related I think.

 

Tom

Reply
Options

163 Posts

04-04-2009

Davis, CA

250 Signins

2705 Page Views

  • Posts: 163
  • Registered: ‎04-04-2009
  • Location: Davis, CA
  • Views: 2705
  • Message 4 of 5

Re: T500 screen blinks off when power is unpluged

2009-04-04, 18:21 PM

It is possible that unplugging the AC adapter caused the display driver to crash when it is applying the power management settings caused by the power source switch. I would recommend that you fully uninstall the driver and replace the driver with the latest one you can find. (Despite the fact that I am having issues with the display driver even when I am running the latest version - T500 w/ Vista) But hopefully it will take care of the issue in your case.

Good luck! :)

Reply
Options

3 Posts

04-16-2009

USA

5 Signins

40 Page Views

  • Posts: 3
  • Registered: ‎04-16-2009
  • Location: USA
  • Views: 40
  • Message 5 of 5

Re: T500 screen blinks off when power is unpluged

2009-04-16, 16:51 PM
I have the same problem on my T400 w/ Vista.  Factory clean install.  It's quite annoying...screen turns black for 1 second before turning back on.  Has anyone else been able to fix this?
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms