Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

70 Posts

03-06-2014

United States of America

375 Signins

3941 Page Views

  • Posts: 70
  • Registered: ‎03-06-2014
  • Location: United States of America
  • Views: 3941
  • Message 351 of 371

Re: T540p/T440p+UltraDock+external display issues

2015-08-18, 19:24 PM

Here is a quick update. I thought this issue was going to go somewhere because I had an escalated case with Lenovo support (this was regarding my employer issued t450 and ultradock). Well sadly the support person has gone dark. I have sent a couple emails over the past couple weeks requesting status and I have heard nothing. I did give the support person all the info he requested and also sent him a link to this thread. But sadly no response.

Reply
Options

2 Posts

08-21-2015

Surrey

5 Signins

24 Page Views

  • Posts: 2
  • Registered: ‎08-21-2015
  • Location: Surrey
  • Views: 24
  • Message 352 of 371

Re: T540p/T440p+UltraDock+external display issues

2015-08-21, 11:43 AM

Ok, i must admit trawling through 35 pages was abit of an effort. Here is my story to this issue as it stands

 

Have a home office setup

 

2x u2412m monitors @ 1920x1200

k70 corsair keyboard and mouse

Lenovo ulta dock

Lenovo T440 laptop

 

This was my original setup until this year, had no issues. the two u2412m was connected via vga and dvi

 

I have since now upgraded my monitors and keyboard

 

2x U2515H @2560x1440p

RGB corsair keyboard and mouse

 

I've experience ramdom black outs on one of my monitors to the point i thought the issue was the monitor and RMA'd it. Obviously this didn't fix the issue.

 

I have the first monitor connected via HDMI (i've changed the cable twice)

2nd monitor connected via DP (no issues with this monitor)

 

I have ran the firmware fix and it quotes its up to date

 

So would my next step be to upgrade the psu for the docking station?

 

My theory as its running at 1440p does this require additional signal strength?

 

My mouse is plugged into the laptop itself and the keyboard into the dock.

 

forgot to add this is a work laptop running windows 7

 

 

Reply
Options

13 Posts

10-31-2011

United States

17 Signins

69 Page Views

  • Posts: 13
  • Registered: ‎10-31-2011
  • Location: United States
  • Views: 69
  • Message 353 of 371

Re: T540p/T440p+UltraDock+external display issues

2015-08-21, 14:13 PM

The insanity of this issue, with 35 pages of posts, continues. I think we have so many pages because there's no definitive answer. Some have reported that getting a higher wattage power pack for their docking station cured their ills. But we don't know if they took other measures that had to be combined with that?

 

Some seem to have been cured by just updating the docking station firmware, while others just end up with a different set of symptoms after doing the firmware update (which was my case).

 

For me, I needed a combination of newer Intel graphics drivers plus the higher wattage power supply, and the older firmware. Even with that, I still have a few rare occasions when my screen blanks out but it's almost always under the scenario where I was using my laptop in another room (not docked), and I put the laptop to sleep, then re-docked it, and woke it back up. Even though that's generally not a good thing to do, I do it sometimes and often I'll have the monitor blank out issue until a fresh shutdown (while remaining docked).

 

I've also had to move my wireless USB dongle thingy for my mouse & keyboard. I originally had it in one of the USB ports on the docking station, but several times a day I would experience a temporary disconnect where the docking station's USB for my mouse/keyboard just went to sleep, or went dead for 10 seconds. So now my dongle is in a USB port on the side of the laptop, and that problem went away.

 

Truly, this has been a very frustrating experience with the T440s model. 

 

Reply
Options

2 Posts

08-21-2015

Surrey

5 Signins

24 Page Views

  • Posts: 2
  • Registered: ‎08-21-2015
  • Location: Surrey
  • Views: 24
  • Message 354 of 371

Re: T540p/T440p+UltraDock+external display issues

2015-08-21, 15:21 PM

Its a same really, it seems lenovo have given up. From my woes, coming from a working solution to a broken one using the same dock has fustrated me to the point ive lived with it. Pin pointing the issue is merely wide guessing at this stage, so I can only but 'follow' the crowd. I guess a new psu or powerbrick whatever its called would be the next step.

Reply
Options

9 Posts

01-28-2014

UK

18 Signins

132 Page Views

  • Posts: 9
  • Registered: ‎01-28-2014
  • Location: UK
  • Views: 132
  • Message 355 of 371

Re: T540p/T440p+UltraDock+external display issues

2015-08-25, 14:19 PM

With my case with Lenovo, a replacement dock unsurprisngly made no difference.  They have not sent a replacement power supply.  It's also gone quiet from Lenovo while they 'escalate this'.

 

The 'squiggly distortion' always appears for a couple of seconds before the screen blanks.  But more recently I've noticed the squiggly distortion effect sometimes appears for a few seconds then dissappears (i.e. goes back to normal) without the display blanking. 

 

The only analogy I can think of is like an itch in the nose (squiggly distortion) before, sometimes but not always, a sneeze (screen goes blank for a few seconds). 

 

The temporary distortion appers is most noticeable where there are horizontal lines on the whatever is on the screen, e.g. row lines of a spreadsheet.  One pixel every say 1cm along moves up by one pixel.  Everything goes slightly italic. 

 

i.e. it looks (for a couple of seconds) something like this:

 

Normal

__________________

__________________

__________________

 

Distorted for a couple of seconds

___.___.___.___.___

___.___.___.___.___

___.___.___.___.___

 

It's just done it now as I am typing this.

 

Got a mild distortion, but no blank; then 30 seconds later a more pronounced distortion for a few seconds followed by the screen blank, then back to normal.

 

It's as if the monitor is trying to 'hang on' to the video signal from the dock when the signal from the dock occasionally drifts out of normal parameters.  My Samsung monitor is connected to HDMI from the DisplayPort connector on the dock.

 

Does this describe the symptoms others are experiencing?

 

Reply
Options

6 Posts

03-13-2015

Duluth, GA

7 Signins

40 Page Views

  • Posts: 6
  • Registered: ‎03-13-2015
  • Location: Duluth, GA
  • Views: 40
  • Message 356 of 371

Re: T540p/T440p+UltraDock+external display issues

2015-08-25, 15:32 PM

@js_1

 

Yes, your description of the screen distortion and how it seems that the monitor is desparately trying to hang on to the video signal is exactly what my system was doing.  As previously noted, Lenovo swapped out the dock and the motherboard in my laptop (T440s), and I paid for an upsized 170W power supply--all to no avail. 

 

I was only able to get resultion by going to a USB 3.0 Ultra Dock.  Haven't had a single flicker since. 

Reply
Options

1 Posts

08-25-2015

Chicago

10 Signins

99 Page Views

  • Posts: 1
  • Registered: ‎08-25-2015
  • Location: Chicago
  • Views: 99
  • Message 357 of 371

Re: T540p/T440p+UltraDock+external display issues

2015-08-25, 20:43 PM

I have a thinkpad t440p with the pro dock.  When I have two monitors plugged into the dock, the second occasionally disappears from the system.   sometimes it comes back, sometimes it doesn't.  When it starts disappearing, it usually comes back then disappears every few seconds for a while before disappearing for longer.  I tried every version of the updated dock firmware and the rest of the drivers are up to date.  Lenovo also sent me a new (90w) power supply to replace my original 65w power supply when I told them that might fix the issue.  Nothing has fixed the issue.

Reply
Options

4 Posts

08-03-2015

Germany

13 Signins

100 Page Views

  • Posts: 4
  • Registered: ‎08-03-2015
  • Location: Germany
  • Views: 100
  • Message 358 of 371

Re: T540p/T440p+UltraDock+external display issues

2015-10-22, 12:18 PM

Update: I am still on firmware V2.17 and the problem has returned, although not as frequently as with V2.22, I believe.

The HDMI-connected screen disappears (turns black) evey now and then.

Sometimes this happens several times in very short intervals (seconds / minutes), sometimes it's fine for days.

Reply
Options

3 Posts

12-17-2015

Finland

6 Signins

37 Page Views

  • Posts: 3
  • Registered: ‎12-17-2015
  • Location: Finland
  • Views: 37
  • Message 359 of 371

Re: T540p/T440p+UltraDock+external display issues

2015-12-18, 12:45 PM

Hello,

 

I have similar problems with Thinkpad X240. External monitor cuts off ocassionally and has pixel errors.

 

So far I've tried these

1. Different dock

2. Different power supply

3. Updating dock and BIOS firmware

4. Updating display and graphics card drivers

5. Different cables

6. Direct connection from laptop using mDP - DP cable

 

and none of these helped. Output with 1920x1200 resolution works well, but 2560x1600 causes problems.

 

The only way my external monitor works well is with completely another computer (ThinkCentre m92p) and my old laptop ThinkPad X220 worked well too.

 

So for me the problem seems to be in my laptop hardware or software. I hope someone gets this solved or I'll have to start looking for new laptop.

Reply
Options

1 Posts

02-05-2016

Norway

1 Signins

15 Page Views

  • Posts: 1
  • Registered: ‎02-05-2016
  • Location: Norway
  • Views: 15
  • Message 360 of 371

Re: T540p/T440p+UltraDock+external display issues

2016-02-05, 11:11 AM

The problem is caused by a deffective AC Adapter.

If you have any of the AC Adapters listed you should contact Lenovo to get a new one.

 

- 45N0366

- 45N0502

 

Best Regards

itzbolsi

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms