English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

38 Posts

07-24-2014

CA

64 Signins

417 Page Views

  • Posts: 38
  • Registered: ‎07-24-2014
  • Location: CA
  • Views: 417
  • Message 1 of 3

T580 Image Issue

2019-07-11, 14:56 PM

Hi all.

 

I have a client that has a T580 with a very strange issue I'm hoping someone has seen.

 

Randomly while using the machine, sections of the image will go gray or white in various applications (see attached screenshot.) When the issue first came up, I just assumed it was a faulty display but my client says that the issue happens on both the laptop display and on an external monitor she has connected and rarely at the same time. She doesn't use a dock, the display plugs directly into the laptop.

 

I've tried the following things so far:

 

-Run Vantage and updated all drivers and BIOS.

-Completely uninstalled video drivers and manually reinstalled both Lenovo's and Intel's latest releases.

-Updated Windows 10 to 1903.

-Had her try system with no external displays plugged in.

 

I really don't want to resort to reloading Windows 10 from scratch because I'm not at all convinced that's going to fix this. However, if it's a hardware problem, it's one I've never seen before and since this laptop only has depot warranty, I don't want to put her through the headache of sending it back to Lenovo until I know for sure that it's hardware.

 

Does anyone have any suggestions for this? I'm normally pretty good at troubleshooting weird issues but this one has me stumped.

 

Thanks!

Reply
Options

632 Posts

12-30-2017

PL

1417 Signins

16124 Page Views

  • Posts: 632
  • Registered: ‎12-30-2017
  • Location: PL
  • Views: 16124
  • Message 2 of 3

Re: T580 Image Issue

2019-07-13, 19:17 PM

This looks like either GPU driver issue or hardware issue. You can do two tests:

  • Download latest driver either from Lenovo's website or directly from Intel. Completly remove Intel GPU driver using DDU. Before removing the driver make sure to disconnect the device from the Internet, as Windows 10 tend to install drivers without your approval. After reboot install latest driver version, which you have just downloaded. After another restart connect the device to the Internet and verify, if issue was resolved.
  • If you still can reproduce the issue, then this might be a problem with GPU acceleration. Some applications like web browsers can use acceleration for website rendering. Try to disable this setting. If issue will be no longer present, then motherboard might be faulty and needs to be replaced.
------
...
Reply
Options

38 Posts

07-24-2014

CA

64 Signins

417 Page Views

  • Posts: 38
  • Registered: ‎07-24-2014
  • Location: CA
  • Views: 417
  • Message 3 of 3

Re: T580 Image Issue

2019-07-18, 19:45 PM

The latest drivers from Intel will not install because they give the error that they're not tested for that model and to use the manufacturer's drivers. I have tried the latest Lenovo drivers with no help and in addition, not all of the applications having issues use hardware acceleration. I have not tried a DDU before with Intel drivers, that's definitely an interesting suggestion. I did try one obscure solution involving altering an oddly named setting in the Intel Control Panel (can't remember it now) that worked for some and my client hasn't mentioned the issue since so I'll keep an eye on it. After this, I'll open a case with Lenovo support. Thanks.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete