English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

7 Posts

06-07-2015

USA

11 Signins

89 Page Views

  • Posts: 7
  • Registered: ‎06-07-2015
  • Location: USA
  • Views: 89
  • Message 1 of 15

Thinkpad T420 SSD Error 2100 with Crucial BX100

2015-06-07, 5:34 AM

Hi,

 

I am having an issue with my T420 and a recently acquired Crucial BX100 solid state drive. I checked Crucial's website and it stated the BX100 was compatible with the T420. I installed it per the Lenovo Maintenance Manual but it gives me this error message: 2100: Detection error on HDD0 (Main HDD). I was able to install the BX100 on a desktop and was able to boot and install Windows 8.1 perfectly fine. I was also able to update the firmware. The standard drive that came with the laptop works just fine and I updated the BIOS and all drivers and firmware with the Lenovo System Update utility. I wiped the drive and tried again, but it still gives me the same error. I have tried both UEFI and MBR, but to no avail. I should also note that SATA mode was set to AHCI. Any help would be greatly appreciated.

Reply
Options

65 Posts

04-27-2013

Greece

175 Signins

779 Page Views

  • Posts: 65
  • Registered: ‎04-27-2013
  • Location: Greece
  • Views: 779
  • Message 2 of 15

Re: Thinkpad T420 SSD Error 2100 with Crucial BX100

2015-06-07, 7:29 AM

I read on another thread here that the issue is driver related.

 

For that user, switching to another aHCI driver solved the issue.

 

I would suggest getting the newest Intel driver HERE, loading it in a usb drive and instructing the OS during install to use this driver during setup.

 

Hope it helps

Reply
Options

7 Posts

06-07-2015

USA

11 Signins

89 Page Views

  • Posts: 7
  • Registered: ‎06-07-2015
  • Location: USA
  • Views: 89
  • Message 3 of 15

Re: Thinkpad T420 SSD Error 2100 with Crucial BX100

2015-06-07, 22:16 PM

Installed the drivers, but no nice. Tried loading both the zip and the exe onto a flash drive, but the Windows installation process wouldn't even recognize them.

Reply
Options

8703 Posts

01-13-2008

United States of America

77531 Signins

2210280 Page Views

  • Posts: 8703
  • Registered: ‎01-13-2008
  • Location: United States of America
  • Views: 2210280
  • Message 4 of 15

Re: Thinkpad T420 SSD Error 2100 with Crucial BX100

2015-06-07, 22:32 PM

Hi,

 

If POST throws a 2100 from a cold startup, it's unlikely to be a driver issue.  Drivers aren't involved at that point.  It is true that a driver can cause a BSOD and subsequent 2100, but 2100 from the get-go points to SSD/laptop incompatibility.

 

Typically the issue is that the SSD firmware takes too long to initialize and the BIOS drive probe code times out and flags the drive as not present.

 

Sorry, I don't have a fix for you :(  I'm having the same problem with a different Crucial SSD on a different T machine.

 

I'd suggest opening a case with Crucial.  See if their support has any suggestions, and at least get the issue registered with them.

 

Z.


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored - questions and answers belong in the forum so that others may contribute and benefit. ... GeezBlog

 

Communities: English Deutsch Español Português Русскоязычное Česká Slovenská Українська Polski Türkçe Moto English

Reply
Options

7 Posts

06-07-2015

USA

11 Signins

89 Page Views

  • Posts: 7
  • Registered: ‎06-07-2015
  • Location: USA
  • Views: 89
  • Message 5 of 15

Re: Thinkpad T420 SSD Error 2100 with Crucial BX100

2015-06-08, 0:34 AM

Thanks for the reply, at least I have some idea of what's causing the problem. I've sent an email to Crucial and will update if anything comes of it. Do you know if this issue occurs with other SSDs like Sandisk or Samsung? What about mSATA drives? 

Reply
Options

8703 Posts

01-13-2008

United States of America

77531 Signins

2210280 Page Views

  • Posts: 8703
  • Registered: ‎01-13-2008
  • Location: United States of America
  • Views: 2210280
  • Message 6 of 15

Re: Thinkpad T420 SSD Error 2100 with Crucial BX100

2015-06-08, 0:47 AM

I've seen reports of  this kind of problem with most manufacturer's SSDs.  That's a very casual observation on my part - not something I've tracked.  It varies with laptop, SSD vendor, and SSD model, unfortunately.

 

I run a Crucial m4 mSATA drive in my T420 without problems.  OTOH, in the T450s I've been working with, a Crucial m4 2.5" works but an m500 throws a 2100 in some situations.  The m.2 drives I've tested work fine.  None of them are Crucial, so I don't have that data point.

 

Z.


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored - questions and answers belong in the forum so that others may contribute and benefit. ... GeezBlog

 

Communities: English Deutsch Español Português Русскоязычное Česká Slovenská Українська Polski Türkçe Moto English

Reply
Options

7 Posts

06-07-2015

USA

11 Signins

89 Page Views

  • Posts: 7
  • Registered: ‎06-07-2015
  • Location: USA
  • Views: 89
  • Message 7 of 15

Re: Thinkpad T420 SSD Error 2100 with Crucial BX100

2015-06-09, 22:03 PM

This is a minor update as I don't have a fix yet, but I've contacted Crucial support. Hopefully I'll have an answer soon. I'm not sure how much this will help but I've tried the Archlinux installer and here is some of the startup output

 

After logging into the root environment, I tried 'lsblk' and then started GParted and the 'print' command. Neither could detect the driver either.

Reply
Options

1 Posts

06-11-2015

Germany

3 Signins

18 Page Views

  • Posts: 1
  • Registered: ‎06-11-2015
  • Location: Germany
  • Views: 18
  • Message 8 of 15

Re: Thinkpad T420 SSD Error 2100 with Crucial BX100

2015-06-11, 11:41 AM

Hello,

 

any news to this issue? I accidentally found this (relatively new) thread. I am very interested to participate in any good news regarding this, because I am confronted with exactly the same challenge. Thinkpad T420, brand new Crucial BX 100 (256 GB), permanent 2100 detection error. I helped myself by using a Toshiba SSD, wich was formerly installed in my desktop. It cooperates with the Thinkpad without any gripe. The Crucial SSD is installed in my desktop now. And performs there as one would expect it to do.

But nevertheless: This solution was not the one I sought for. At least because the Toshiba is only a 128 GB device.

OK. Sorry for my germlish... and: Any good news would be highly appreciated!

Reply
Options

7 Posts

06-07-2015

USA

11 Signins

89 Page Views

  • Posts: 7
  • Registered: ‎06-07-2015
  • Location: USA
  • Views: 89
  • Message 9 of 15

Re: Thinkpad T420 SSD Error 2100 with Crucial BX100

2015-06-11, 15:45 PM

Nothing yet, I'm still in contact with Crucial tech support. You should send them an email as well, so at the very least they become aware of it. Though anyone knowledgable on the issue seems to agree it's a BIOS/power issue, so it's worth getting in touch with Lenovo as well.

Reply
Options

2 Posts

06-14-2015

Canada

2 Signins

14 Page Views

  • Posts: 2
  • Registered: ‎06-14-2015
  • Location: Canada
  • Views: 14
  • Message 10 of 15

Re: Thinkpad T420 SSD Error 2100 with Crucial BX100

2015-06-14, 12:18 PM

Same Problem with Exactly the Same Thinkpad T420 and Crucial MX100 (256)

 

Am I glad to have come across this new thread! I'm facing the exact same issue with the exact same specs – ThinkPad T420 and crucial MX100 256 GB.

 

I get this detection error almost once every two days and it is getting very annoying. After searching the web, this thread seems to be my biggest hope.

 

Furthermore, I have been in touch with the crucial support team, but it does not look like this is something they have a solution for. ac53. I hope you come across a solution and save us all. :-)

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms