Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

124 Posts

12-14-2007

NYC

701 Signins

1715 Page Views

  • Posts: 124
  • Registered: ‎12-14-2007
  • Location: NYC
  • Views: 1715
  • Message 1 of 6

Trackpoint scrolling -- can I disable horizontal? (It keeps flipping pages when I don't mean to...)

2013-03-21, 16:25 PM

Hi all,

 

I really like using the Trackpoint to scroll.

 

But an increaing number of Web sites react to horizontal scrolling by jumping to other pages.

 

So, for example, if I'm reading down a page -- and if I need to use the Trackpoint to scroll down as I'm reading -- if I'm not perfectly vertical when I pull down on the Trackpoint, the Web site detects it as a horizontal scoll, and I get whisked off to another page.

 

I can't be the only person having this problem?

 

Is there some way to disable the Trackpoint from scrolling horizontally without disabling it from scrolling vertically?

Reply
Answer
Options

60 Posts

12-23-2012

India

601 Signins

2512 Page Views

  • Posts: 60
  • Registered: ‎12-23-2012
  • Location: India
  • Views: 2512

Re: Trackpoint scrolling -- can I disable horizontal? (It keeps flipping pages when I don't mean to.

2014-03-15, 18:35 PM

Hi colonel,

Thanks, it works.

Here is how I did it for firefox browser:


1. Open C:\Program Files\Synaptics\SynTP\TP4table.dat with your favorite text editor (Run as Administrator mode might be needed for some Windows version).

 

2. Search for "firefox.exe" text

 

3. There is a line like this:

*,*,firefox.exe,*,*,MozillaWindowClass,WheelVkey,0,9

 

4. I changed the scrolling type to:
*,*,firefox.exe,*,*,MozillaWindowClass,WheelStd,0,9

 

5. To see the effect immediately, using task manager or Process Explorer, kill this process:

Syntpenh.exe

Syntphelper.exe

Syntplpr.exe

 

or you can just reboot the Windows.

 

Reference:

http://forums.lenovo.com/t5/W-Series-ThinkPad-Laptops/W520-Trackpoint-Scrolling-Doesn-t-Work-In-Lightroom/td-p/629391/page/2

 

Reply

Replies(5)
Options

60 Posts

12-23-2012

India

601 Signins

2512 Page Views

  • Posts: 60
  • Registered: ‎12-23-2012
  • Location: India
  • Views: 2512
  • Message 2 of 6

Re: Trackpoint scrolling -- can I disable horizontal? (It keeps flipping pages when I don't mean to.

2014-03-02, 11:22 AM
I recently bought thinkpad and I also have same problem too. Is there any solution, maybe from third party tools?
Reply
Options

9644 Posts

12-27-2009

Canada

3313 Signins

95283 Page Views

  • Posts: 9644
  • Registered: ‎12-27-2009
  • Location: Canada
  • Views: 95283
  • Message 3 of 6

Re: Trackpoint scrolling -- can I disable horizontal? (It keeps flipping pages when I don't mean to.

2014-03-02, 15:41 PM
Might be able to set a scrolling type override for your browser in this file:
C:\Program Files\Synaptics\SynTP\TP4table.dat

Not sure which of the scrolling modes works, though.

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
Reply
Answer
Options

60 Posts

12-23-2012

India

601 Signins

2512 Page Views

  • Posts: 60
  • Registered: ‎12-23-2012
  • Location: India
  • Views: 2512
  • Message 4 of 6

Re: Trackpoint scrolling -- can I disable horizontal? (It keeps flipping pages when I don't mean to.

2014-03-15, 18:35 PM

Hi colonel,

Thanks, it works.

Here is how I did it for firefox browser:


1. Open C:\Program Files\Synaptics\SynTP\TP4table.dat with your favorite text editor (Run as Administrator mode might be needed for some Windows version).

 

2. Search for "firefox.exe" text

 

3. There is a line like this:

*,*,firefox.exe,*,*,MozillaWindowClass,WheelVkey,0,9

 

4. I changed the scrolling type to:
*,*,firefox.exe,*,*,MozillaWindowClass,WheelStd,0,9

 

5. To see the effect immediately, using task manager or Process Explorer, kill this process:

Syntpenh.exe

Syntphelper.exe

Syntplpr.exe

 

or you can just reboot the Windows.

 

Reference:

http://forums.lenovo.com/t5/W-Series-ThinkPad-Laptops/W520-Trackpoint-Scrolling-Doesn-t-Work-In-Lightroom/td-p/629391/page/2

 

0 person found this solution to be helpful.

This helped me too

Reply
Options

9644 Posts

12-27-2009

Canada

3313 Signins

95283 Page Views

  • Posts: 9644
  • Registered: ‎12-27-2009
  • Location: Canada
  • Views: 95283
  • Message 5 of 6

Re: Trackpoint scrolling -- can I disable horizontal? (It keeps flipping pages when I don't mean to.

2014-03-16, 16:08 PM
Works like a charm.

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
Reply
Options

1 Posts

06-22-2017

Canada

1 Signins

27 Page Views

  • Posts: 1
  • Registered: ‎06-22-2017
  • Location: Canada
  • Views: 27
  • Message 6 of 6

Re: Trackpoint scrolling -- can I disable horizontal? (It keeps flipping pages when I don't mean to.

2017-06-22, 19:37 PM

I tried your method and It did not work for me. I am using Thinkpad Bluetooth Laser Mouse on Lenovo S230u laptop.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms