Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

7 Posts

05-07-2011

Italy

245 Signins

725 Page Views

  • Posts: 7
  • Registered: ‎05-07-2011
  • Location: Italy
  • Views: 725
  • Message 1 of 9

Ultranav driver 15.2.20.0 unusable on T510

2011-05-07, 21:21 PM

Hi, after installing ultranav driver 15.2.20.0 update, two finger scrolling became totally unresponsive on my system (T510 i7 Win7 64 Optimus).

It works for the first time, but as I lift my fingers off the pad it looks like I have to wait at least two to three seconds in order to be able to use the feature again. The mouse cursor is unresponsive, shows the arrow and doesn't move.

I had to revert back to 15.2.19.0, which I am happily using as I write this.

Anyone experienced the same issue?

 

Reply
Options

248 Posts

08-24-2010

New york

823 Signins

2655 Page Views

  • Posts: 248
  • Registered: ‎08-24-2010
  • Location: New york
  • Views: 2655
  • Message 2 of 9

Re: Ultranav driver 15.2.20.0 unusable on T510

2011-05-07, 22:07 PM

yes and that is why i am not going to update my system lol  i had to roll bak driver

Reply
Options

34 Posts

04-27-2011

San Francisco, CA

1698 Signins

1900 Page Views

  • Posts: 34
  • Registered: ‎04-27-2011
  • Location: San Francisco, CA
  • Views: 1900
  • Message 3 of 9

Re: Ultranav driver 15.2.20.0 unusable on T510

2011-05-07, 22:57 PM
I am having the same issue on my T420S.

There is one more bug I am experiencing. Sometimes after the system resumes from sleep, the ultranav driver does some weird things. For example, if I am trying to scroll with the trackpoint while holding the middle button, the cursor will still move around the screen.

Even if I set the trackpoint stick to only use advanced features, and not act as a mouse, sometimes after resume it still moves around the screen.

The only way to correct this is either to fully log out and back in, or to restart the system.
Reply
Options

9644 Posts

12-27-2009

Canada

3313 Signins

95283 Page Views

  • Posts: 9644
  • Registered: ‎12-27-2009
  • Location: Canada
  • Views: 95283
  • Message 4 of 9

Re: Ultranav driver 15.2.20.0 unusable on T510

2011-05-07, 23:42 PM
@neanderthal, unit88888888
It goes away if you disable PalmCheck.

@antsh
You might want to fully uninstall the drivers, run CCleaner, then try reinstalling it again.

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
Reply
Options

7 Posts

05-07-2011

Italy

245 Signins

725 Page Views

  • Posts: 7
  • Registered: ‎05-07-2011
  • Location: Italy
  • Views: 725
  • Message 5 of 9

Re: Ultranav driver 15.2.20.0 unusable on T510

2011-05-08, 8:15 AM

ColonelONeil,

 

thanks, I thought about it and tried to set PalmCheck at minimum and saw no difference. I still could not match the responsiveness of 15.2.19.0, which I find was an improvement over the previous versions.

 

Reply
Options

34 Posts

04-27-2011

San Francisco, CA

1698 Signins

1900 Page Views

  • Posts: 34
  • Registered: ‎04-27-2011
  • Location: San Francisco, CA
  • Views: 1900
  • Message 6 of 9

Re: Ultranav driver 15.2.20.0 unusable on T510

2011-05-09, 6:38 AM

ColonelONeill,

Did the reinstall, unfortunately I am still sporadically experiencing the same issue. After a few sleep/resume cycles, the cursor moves around the screen even when it should stay still and only scroll.

 

P.S. I am running a UEFI Only/GPT install if it matters.

Reply
Options

38 Posts

11-28-2010

Michigan, USA

84 Signins

363 Page Views

  • Posts: 38
  • Registered: ‎11-28-2010
  • Location: Michigan, USA
  • Views: 363
  • Message 7 of 9

Re: Ultranav driver 15.2.20.0 unusable on T510

2011-06-11, 3:00 AM

Still waiting for a fix for this. Anyone have any ideas where to get the old version?

Reply
Options

9644 Posts

12-27-2009

Canada

3313 Signins

95283 Page Views

  • Posts: 9644
  • Registered: ‎12-27-2009
  • Location: Canada
  • Views: 95283
  • Message 8 of 9

Re: Ultranav driver 15.2.20.0 unusable on T510

2011-06-11, 7:31 AM
@bradsh
Does 15.3.6.0 also have the issue? I'd ditch the whole Synaptics two finger scroll in favor of http://code.google.com/p/two-finger-scroll/, anyway.

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
Reply
Options

7 Posts

05-07-2011

Italy

245 Signins

725 Page Views

  • Posts: 7
  • Registered: ‎05-07-2011
  • Location: Italy
  • Views: 725
  • Message 9 of 9

Re: Ultranav driver 15.2.20.0 unusable on T510

2011-06-12, 7:48 AM

@bradsh

 

I disinstalled the update and reinstalled the former version I found at:

 

http://download.lenovo.com/ibmdl/pub/pc/pccbbs/mobiles/6hgx37ww.exe

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms