English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

2 Posts

09-06-2020

UA

8 Signins

25 Page Views

  • Posts: 2
  • Registered: ‎09-06-2020
  • Location: UA
  • Views: 25
  • Message 1 of 4

WWAN Fibocom L850-GL (FRU 01AX786) doesn't work in the ThinkPad T14s Gen 1 (Type 20UH - AMD)...

2020-09-09, 8:47 AM

Hi everyone!

 

The brand new ThinkPad T14s on AMD (Model type 20UH) with installed the WWAN module Fibocom L850-GL (FRU 01AX786) on Windows 10  (Version 2004) displays message NO SERVICE after SIM card installed (the cellular operator is displayed correctly). 

 

The WWAN Fibocom L850-GL driver (version 0.9.4.399) installed properly and the OS sees the WWAN module correctly.

I've also tried use this WWAN driver but the result was the same :(

 

Fibocom L850-GL WWAN Software for Windows 10 (Version 1903 or later) - ThinkPad T14 Gen 1, T14s Gen 1, X13 Gen 1 

Link: https://pcsupport.lenovo.com/uu/en/products/laptops-and-netbooks/thinkpad-t-series-laptops/thinkpad-t14s-type-20uh-20uj/downloads/DS545912 

Could someone provide the working solution how to fix this issue?

 

Thanks in advance

Reply
Options

6 Posts

09-03-2018

UA

5 Signins

71 Page Views

  • Posts: 6
  • Registered: ‎09-03-2018
  • Location: UA
  • Views: 71
  • Message 2 of 4

Re:WWAN Fibocom L850-GL (FRU 01AX786) doesn't work in the ThinkPad T14s Gen 1 (Type 20UH - AMD)...

2020-10-04, 13:08 PM

I have exactly the same issue. I got the Fibocom L850-GL from my old Thinkpad T480s where it worked perfectly. My new t14s shows 'No Service' with the same sim card. I tried updating BIOS, installing drivers but nothing worked. My new laptop is based on Ryzen platform. Super frustrating. Lenovo guys please help

Reply
Options

4 Posts

09-22-2020

US

6 Signins

35 Page Views

  • Posts: 4
  • Registered: ‎09-22-2020
  • Location: US
  • Views: 35
  • Message 3 of 4

Re:WWAN Fibocom L850-GL (FRU 01AX786) doesn't work in the ThinkPad T14s Gen 1 (Type 20UH - AMD)...

2020-10-06, 1:47 AM

I have that card running in a T495. The windows 10 default worked fine. Right now I have the simcard in a gateway so i can't check it out.  T-mobile if that helps. Note I ran the sim in a phone just to make sure it actually worked.

 

As an aside, I also have the Fibocom working under linux.

https://github.com/xmm7360/xmm7360-pci

 

All this said, Lenovo would do everyone a favor and switch to Sierra WWAN cards.

Reply
Options

6 Posts

09-03-2018

UA

5 Signins

71 Page Views

  • Posts: 6
  • Registered: ‎09-03-2018
  • Location: UA
  • Views: 71
  • Message 4 of 4

Re:WWAN Fibocom L850-GL (FRU 01AX786) doesn't work in the ThinkPad T14s Gen 1 (Type 20UH - AMD)...

2020-10-07, 11:35 AM

After the recent restart it started to configure the broadband device and then started working. All good now

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete