English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

4 Posts

05-11-2014

UK

8 Signins

120 Page Views

  • Posts: 4
  • Registered: ‎05-11-2014
  • Location: UK
  • Views: 120
  • Message 1 of 6

WiFi problem after upgrading to Windows 8.1 Lenovo R400 ThinkPad

2014-05-11, 13:32 PM

 I have this problem after updating to 8 to 8.1

 

Right after updating to 8 to 8.1, all of a sudden my wifi stops working. I used my philips external wifi usb stick and now I'm able to get the internet going.

 

However if I disconnect my philips usb I no longer get the internet because the built in wifi that came with the R400 ThinkPad no longer works. I went through the device manager and under properties it tells me, 'Device not working properly' however it is up to date.

 

Im Running Windows 8.1  64bit  Laptop Lenovo R400 ThinkPad

 

 

 

 

Reply
Options

3019 Posts

03-15-2014

Bangalore

1126 Signins

57257 Page Views

  • Posts: 3019
  • Registered: ‎03-15-2014
  • Location: Bangalore
  • Views: 57257
  • Message 2 of 6

Re: WiFi problem after upgrading to Windows 8.1 Lenovo R400 ThinkPad

2014-05-13, 4:17 AM

Hi Matti,

 

Welcome to Lenovo Community!

 

I’m sorry to hear that you are facing the issue with Wif on ThinkPad R400.

 

To resolve the issue I suggest you to revert your network adapter driver back to an older version instead of the one installed by windows 8.1.

 

You can do this by going to device manager, right click on your Wifi adapter, go to update driver, then "browse my computer for driver software, then "let me pick from a list of....”, check the "show compatible hardware" checkbox and finally select the older version of current driver. You have to give it a try.

 

Hope this helps! 

 

Best regards.

Hemanth Kumar



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Reply
Options

4 Posts

05-11-2014

UK

8 Signins

120 Page Views

  • Posts: 4
  • Registered: ‎05-11-2014
  • Location: UK
  • Views: 120
  • Message 3 of 6

Re: WiFi problem after upgrading to Windows 8.1 Lenovo R400 ThinkPad

2014-05-13, 11:36 AM

Hi There,

 

I went into device manager and there was no other choice to revert  I only have  INTEL R-82567LM GIGABIT NETWORK which is showing...?

Reply
Options

3019 Posts

03-15-2014

Bangalore

1126 Signins

57257 Page Views

  • Posts: 3019
  • Registered: ‎03-15-2014
  • Location: Bangalore
  • Views: 57257
  • Message 4 of 6

Re: WiFi problem after upgrading to Windows 8.1 Lenovo R400 ThinkPad

2014-05-13, 12:23 PM

Hi Matti,

 

Thank you for replying back!

 

Please uninstall the current driver from the control panel – program and feature option and restart the system, after restarting the system the windows will automatically install the driver for that.

 

Please check if the issue still persists after installing the driver.

 

Hope this helps!

 

Best regards,

Hemanth Kumar.

 



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Reply
Options

4 Posts

05-11-2014

UK

8 Signins

120 Page Views

  • Posts: 4
  • Registered: ‎05-11-2014
  • Location: UK
  • Views: 120
  • Message 5 of 6

Re: WiFi problem after upgrading to Windows 8.1 Lenovo R400 ThinkPad

2014-05-13, 13:57 PM

Hi Hemanth,

 

Ive tried uninstalling and it has put the same driver back on, still no joy, ive also tried updating the driver software and it saying its up to date...??

Reply
Options

3019 Posts

03-15-2014

Bangalore

1126 Signins

57257 Page Views

  • Posts: 3019
  • Registered: ‎03-15-2014
  • Location: Bangalore
  • Views: 57257
  • Message 6 of 6

Re: WiFi problem after upgrading to Windows 8.1 Lenovo R400 ThinkPad

2014-05-14, 5:47 AM

Hi Matti,

 

Thank you for replying back!

 

I suggest you to reinstall the Windows 8.1, as all the windows driver will not update, if you have upgraded the Windows 8 to Windows 8.1.

 

Please download Windows 8.1 separately and reinstall the OS, I hope this may resolve the issue.

 

Note: I am not suggesting for clean installation, only reinstalling the same OS.

 

Do not update the drivers from ThinkVantage system update utility. I suggest you to uninstall the current drivers and download the drivers manually for Windows 8.1 and install it.

 

Below is the link to enter the downloads page and download updates accordingly, please click on "Select Product" then in "QUICK PATH" enter the MTM no. select the exact model.

 

http://support.lenovo.com/en_US/downloads/default.page#

 

Hope this helps!

 

Best regards,

Hemanth Kumar



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete