Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

3 Posts

08-02-2015

Los Angeles

4 Signins

22 Page Views

  • Posts: 3
  • Registered: ‎08-02-2015
  • Location: Los Angeles
  • Views: 22
  • Message 1 of 6

Wifi extremely slow after Windows 10 Upgrade

2015-08-02, 21:04 PM

After upgrading to Windows 10 my wifi connection is extremely slow.  I updated all the Lenovo drivers after the upgrade and it hasn't helped. The listed network driver is 2x2 11b/g/n Wireless LAN M.2 Adapter. 

 

I've included screenshot below of a speedtest on the same network between my T440s and my smartphone.  The smartphone results are what should be expected on the laptop. 

 

T440s Speed Test

 

Samsung S6 Speed Test

 

When observing the task manager there are no other programs utilizing the network.   

 

Reply
Options

1 Posts

08-19-2015

Brazil

1 Signins

6 Page Views

  • Posts: 1
  • Registered: ‎08-19-2015
  • Location: Brazil
  • Views: 6
  • Message 2 of 6

Re: Wifi extremely slow after Windows 10 Upgrade

2015-08-19, 4:46 AM

I had the same problem.
After trying many suggestions on the internet I found one that solved my problem. I took more than a week to solve but now I'm happy.
On my case the problem was the security wifi protocol. I was using AES and changed to TKIP. For me there is no reason to this to work, but solved my problem.
Hope it helps.

Reply
Options

4691 Posts

12-11-2015

United States of America

4715 Signins

54117 Page Views

  • Posts: 4691
  • Registered: ‎12-11-2015
  • Location: United States of America
  • Views: 54117
  • Message 3 of 6

Re: Wifi extremely slow after Windows 10 Upgrade

2015-12-12, 0:20 AM

I had the same problem with very slow WiFi with Windows 10 on my H50, and had tried updating drivers and resetting the connections etc, but the only permanent fix for me was to disable the Bluetooth adapter when it was not needed, which is most of the time on my desktop.   

 

To disable, you must disalbe the adapter via Windows Device Manager 

 

  1. Right Click on the Start Menu
  2. Select (left click) on Device Manager
  3. Double left click on the item called Bluetooth to open
  4. Right Click on the Bluetoot Adapter (on my H50 it is called "RealTek Bluetooth 4.0 Adapter")
  5. Select (left click) Disable
  6. Select (left click) yes on warning message "Disabling this device will cause it to stop functioning"
  7. Close Device Manager

No Restart/Reboot is required, and once complete, you should be able to test your speed immediately.

 

Note:  To re-enable Bluetooth, follow same steps shown above, only on step 5, choose Enable instead.

Reply
Options

1 Posts

12-12-2015

Rugeley

2 Signins

9 Page Views

  • Posts: 1
  • Registered: ‎12-12-2015
  • Location: Rugeley
  • Views: 9
  • Message 4 of 6

Re: Wifi extremely slow after Windows 10 Upgrade

2015-12-12, 13:33 PM

I've been agonising over the same problem for days and your fix works. Thank you thank you thank you !!! 

Reply
Options

725 Posts

11-21-2013

United States of America

837 Signins

10702 Page Views

  • Posts: 725
  • Registered: ‎11-21-2013
  • Location: United States of America
  • Views: 10702
  • Message 5 of 6

Re: Wifi extremely slow after Windows 10 Upgrade

2015-12-12, 14:15 PM

BlueTooth and wifi on the 2.4GHz band share the same antenna.  That's why wireless can suffer if you're using BT at the same time. 

 

For best results, get a dual band router and use the 5GHz band for wifi.  (If you have dual band wireless adapter.)

Reply
Options

1 Posts

06-06-2017

India

1 Signins

8 Page Views

  • Posts: 1
  • Registered: ‎06-06-2017
  • Location: India
  • Views: 8
  • Message 6 of 6

Re: Wifi extremely slow after Windows 10 Upgrade

2017-06-06, 6:32 AM

You are a lifesaver. Disabling the blutooth fixed it for me.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms