Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

3 Posts

01-07-2021

Indonesia

6 Signins

30 Page Views

  • Posts: 3
  • Registered: ‎01-07-2021
  • Location: Indonesia
  • Views: 30
  • Message 1 of 6

T420 Wireless Network Issues

2021-01-07, 1:29 AM

So yesterday my internet suddenly disconnected. I checked the wifi icon and the wifi button is gone. It just shows me the airplane mode (which i couldnt click anyway). I am currently using an ethernet cable right now. I have been trying to solve this issue all day yesterday but it just dosent work. So what should i do?

Reply
Options

4407 Posts

01-22-2010

United States of America

38778 Signins

586136 Page Views

  • Posts: 4407
  • Registered: ‎01-22-2010
  • Location: United States of America
  • Views: 586136
  • Message 2 of 6

Re:T420 Wireless Network Issues

2021-01-07, 2:05 AM

Hi, 

 

Make sure you didn't turn it off from the wireless switch on the right side of the machine.  Page 5:

 

https://download.lenovo.com/pccbbs/mobiles_pdf/t420_and_t420i_ug_en.pdf

 

Dave


Community GuidelinesSearchPrivate MessagingENDEESPTRUUACZ-SKTRMoto
PM requests for individual support are not answered. If a post solves your issue, please mark it so.

I am not a Lenovo employee


Using Browser Search to find your answers in Lenovo and Moto Community
Reply
Options

3 Posts

01-07-2021

Indonesia

6 Signins

30 Page Views

  • Posts: 3
  • Registered: ‎01-07-2021
  • Location: Indonesia
  • Views: 30
  • Message 3 of 6

Re:T420 Wireless Network Issues

2021-01-07, 9:23 AM

The wireless radio switch is green the whole time but the issue is not solved. One thing i just remembered is i accidentally uninstalled Intel Wifi link 1000 (i think) from the device manager. I think that is the problem. How do i solve this then?

Reply
Options

2064 Posts

03-11-2020

Greece

225 Signins

10581 Page Views

  • Posts: 2064
  • Registered: ‎03-11-2020
  • Location: Greece
  • Views: 10581
  • Message 4 of 6

Re:T420 Wireless Network Issues

2021-01-07, 10:51 AM

Hi Canifyyy,

 

Check for any Wifi driver updates on the Support Page. Reinstall any drivers associated with the Wifi.

Also try to restart the device, if the Intel Wifi Link isn't back, then go into device manager and select the screen with the magnifying glass over. (Scan for Hardware changes) and see if it comes back. 

In the event this does not bring it back, then In the search bar, search for "Windows Updates" , and select "Check for Updates" to see if it finds anything that you're missing.

 

Regards

 

Voithos



Did someone help you today? Press the thumbs-up icon below to thank them with a Kudos!!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Please don't ask me questions by Private Message; questions belong in the forums.

Reply
Options

3 Posts

01-07-2021

Indonesia

6 Signins

30 Page Views

  • Posts: 3
  • Registered: ‎01-07-2021
  • Location: Indonesia
  • Views: 30
  • Message 5 of 6

Re:T420 Wireless Network Issues

2021-01-08, 4:19 AM

1. I tried restarting, the wifi worked. under network adapters there is Intel Centrino Wireless N 1000. BUT after some minutes the same issue happened. on device manager, Intel Centrino Wireless N 1000 has yellow (!) icon or sometimes the Intel Centrino Wireless N 1000 disappeared under network adapters.

 

2. I tried checking for updates but it's already up to date.

 

3. I don't know how to update drivers and i also don't know which driver to install from the support page.

Reply
Options

1 Posts

03-28-2021

United States of America

2 Signins

10 Page Views

  • Posts: 1
  • Registered: ‎03-28-2021
  • Location: United States of America
  • Views: 10
  • Message 6 of 6

Re:T420 Wireless Network Issues

2021-03-28, 8:24 AM

Hi,

My ThinkPad's Wi-Fi disconnects and reconnects by itself as I am using the machine. Sometimes the network is connected but says "no internet", what can be the reason?

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms