English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

22 Posts

01-06-2010

Missouri

45 Signins

1488 Page Views

  • Posts: 22
  • Registered: ‎01-06-2010
  • Location: Missouri
  • Views: 1488
  • Message 1 of 7

how to disable automatic launch of WIE in startup configuration with no options to do so?

2010-01-19, 5:43 AM

Thinkpad T400 2764CTO running Windows 7 Home Premium 64

 

PC only 2 weeks old, very little on it, but getting slower and slower. Finally found the configuration for the startup menu and disabled several things I knew I didn't want at startup. One problem that I can't seem to figure out, is how to disable Windows Internet Explorer from being launched at startup? I have tried disabling every Microsoft option, and it still launches. Is there a specific Lenovo option [that does not obviously have anything to to with WIE] in the startup menu that, if disabled, will stop the WIE browser from being launched? How do I know which options are not safe to disable when attempting to slim down startup configuration for faster/more reliable performance?

Thanks,

Ann

Reply
Options

106 Posts

09-23-2009

United States

197 Signins

1875 Page Views

  • Posts: 106
  • Registered: ‎09-23-2009
  • Location: United States
  • Views: 1875
  • Message 2 of 7

Re: how to disable automatic launch of WIE in startup configuration with no options to do so?

2010-01-19, 19:09 PM

Have you tried to disable it in Control Panel- Programs and Features- Turn Windows Features on or Off to see if this is what you want.

Reply
Options

22 Posts

01-06-2010

Missouri

45 Signins

1488 Page Views

  • Posts: 22
  • Registered: ‎01-06-2010
  • Location: Missouri
  • Views: 1488
  • Message 3 of 7

Re: how to disable automatic launch of WIE in startup configuration with no options to do so?

2010-01-19, 22:38 PM

Is being able to turn a program on or off in the Control Panel, a feature available in previous OSes like Vista or XP? My Windows 7 Control Panel only allows you to either uninstall or repair a program; nothing to temorarily turn them on or off. Or are you using "disable" to mean uninstall? There are at least 8 entries in the Program section of the Control Panel that have the word "Windows," and I couldn't begin to guess which one to uninstall, and if I did, that would prevent being able to use it at all; I just don't want it to launch the browser at startup.

Reply
Options

106 Posts

09-23-2009

United States

197 Signins

1875 Page Views

  • Posts: 106
  • Registered: ‎09-23-2009
  • Location: United States
  • Views: 1875
  • Message 4 of 7

Re: how to disable automatic launch of WIE in startup configuration with no options to do so?

2010-01-20, 0:18 AM

I was talking about up in the left hand corner of Programs and Features there is a line Turn Windows Features on or off. If you click on this line it brings up a box where you can turn off or on different Windows features. Uncheck the box for Internet Explorer and restart computer. To turn back on just check the box again. You also get a warning about programs depending on Internet Explorer.

 

The path is Control Panel, Programs and Features, Turn Windows features on or off, uncheck box for Internet Explorer, and restart computer. I don't think it gets rid of it entirely but I know it removes quick launch icons. I think Internet Explorer is built into Windows and yes you could do this in Windows XP Pro.

 

Hope this helps.

Reply
Options

22 Posts

01-06-2010

Missouri

45 Signins

1488 Page Views

  • Posts: 22
  • Registered: ‎01-06-2010
  • Location: Missouri
  • Views: 1488
  • Message 5 of 7

Re: how to disable automatic launch of WIE in startup configuration with no options to do so?

2010-01-20, 6:51 AM

 

Either I *completely* misread your instructions; that fix is major overkill for what I was trying to do; that fix does not apply to my problem; that fix is only for XP or Vista and not W7; or my PC is already so messed up (despite clean hardware diagnostics, no viruses, no malware, and it is only 2 weeks old), that it performed unexpected and unwanted actions when trying to use the Windows features on/off program control panel options.

 

Opened Control Panel, went to Programs, and finally found the option on the left for turning Windows features on and off. Unchecked the box for IE8, which required a restart. The restart time was 4-5 times longer than usual, even when launching superfluous programs from the startup menu, since it had to "reconfigure Windows." After restarting, WIE did not automatically launch, and its toolbar icon was gone too. Tried to turn it back on like you said, which also required a restart, which didn't make sense to me, since I expected the browser to launch again following another extra long restart once the box was re-selected. Although, surprisingly, it didn't, so for a moment thought it had somehow worked. Then I realized that my WIE icon was still missing from the toolbar, so there was no way to launch it even if I wanted to. Went back into the Control panel and checked every Windows feature box possible; another extra-long restart; still no toolbar icon for WIE. Had to go into the computer files to find WIE so that I could create a desktop shortcut icon so I could manually launch the browser from that. However, when I clicked on the shortcut, it went into a browser setup mode, as if it was being set up for the first time. Finished setup and tried to go to a webpage, but kept getting a connection error.

Diagnosed it, and it said that the Local Area Connection had no valid IP address. Waited on hold with Mediacom for a hour before being disconnected, trying to find out what the IP address was and where to re-enter it, since unchecking the IE8 box in the Windows features part of the Control Panel, doesn't just temporarily disable the function, but apparently actually deletes the toolbar icon, as well as the IP address. Took several more attempts over several hours to get ahold of Mediacom reset the signal to get the IP address back and get back online. So that really does not seem like a viable solution for trying to save time and resources by removing something from the startup menu, if it just quadruples startup time, deletes WIE toolbar icon and IP address permanently, requires creating a desktop shortcut, and then requires several more hours on phone with ISP for signal reset to get the IP address back. Would have been much faster and done less apparent damage than just going ahead and letting it launch at startup and then just closing it. *sigh*

I know that just having an icon in the toolbar does not mean that that particular program will launch at startup, as I have several others that have toolbar icons that I have been able to uncheck in the startup menu, so I can use the toolbar icons to launch each program manually. There just doesn't seem to be any program active in the startup menu that would be launching the browser, and still concerned about unchecking something necessary in startup that could screw it up even more.

Is there any way to get my toolbar WIE icon back without a full system restore, so that I have less shortcut clutter on my desktop?

Reply
Options

106 Posts

09-23-2009

United States

197 Signins

1875 Page Views

  • Posts: 106
  • Registered: ‎09-23-2009
  • Location: United States
  • Views: 1875
  • Message 6 of 7

Re: how to disable automatic launch of WIE in startup configuration with no options to do so?

2010-01-20, 8:44 AM

I tried mine all I did was check the box. I did a restart and I can see mine in the ALL Programs again. I don't see why youre isn't there. If you see it under Start- All Programs you can right click and then Pin To Taskbar to create a quick launch icon. Yes it works in Windows 7 also too. Perhaps we're talking about different things I'm not sure what you're saying about Internet Explorer toolbar and launch on startup. Perhaps it was something they created in the install of your broadband service similar to the dialup programs that launch automatically on startup. All I do here (Avenuebroadband) is plug my router in to my cable modem and I'm up and running, sometimes with a restart.. All I have are the names for internet explorer in the features in start All Programs. Mine never had anything to do with my IP address so I don't quite understand your problem there. Perhaps getting local help would be better in your case.

Sorry I couldn't help you then .

 

Reply
Options

69 Posts

07-31-2009

Hudson Valley

238 Signins

2779 Page Views

  • Posts: 69
  • Registered: ‎07-31-2009
  • Location: Hudson Valley
  • Views: 2779
  • Message 7 of 7

Re: how to disable automatic launch of WIE in startup configuration with no options to do so?

2010-01-21, 0:12 AM

Can you elaborate on what is being displayed when Internet Explorer is being launched on startup?  That isn't a standard feature of Windows (displaying an IE session on startup) unless something has customized the configuration to do so.  I don't recall my Thinkpad being configured in that manner. Has the machine always behaved that way?   If you check the Startup folder (look in "All Programs" then search for the Startup folder) is there an IE 'shortcut' there?  If so, that will invoke an instance of IE when the machine starts up.  Simply delete it there if you don't want it.

 

If you are turning off the IE8 via the Control panel, I believe you are actually disabling it , not merely preventing it from launching at startup. 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete