English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

19 Posts

09-26-2016

US

32 Signins

299 Page Views

  • Posts: 19
  • Registered: ‎09-26-2016
  • Location: US
  • Views: 299
  • Message 11 of 19

Re: t480s/dock:40ah - USB HID devices not found with docking station

2018-04-04, 18:11 PM
I got two Ultra docks and one Pro dock. All is working fine with T480. (Though, this guy has a battery-discharge issue: internal batter always drains first.)
Reply
Options

3 Posts

04-27-2018

IT

17 Signins

68 Page Views

  • Posts: 3
  • Registered: ‎04-27-2018
  • Location: IT
  • Views: 68
  • Message 12 of 19

Re: t480s/dock:40ah - USB HID devices not found with docking station

2018-05-03, 10:13 AM

Similar problem here. 40AH pro-docking not working. Tried firmware update with no apparent result. Support ordered a new one, but it seems that part is unavailable at the moment. Support has no idea when will be available again.

 

Daniele

Reply
Options

6 Posts

03-30-2018

US

49 Signins

189 Page Views

  • Posts: 6
  • Registered: ‎03-30-2018
  • Location: US
  • Views: 189
  • Message 13 of 19

Re: t480s/dock:40ah - USB HID devices not found with docking station

2018-05-03, 14:12 PM

Look at the Ultra dock - mine has worked fine since then and has like 2 more ports than the pro (yes, it is a little more in cost)

Reply
Options

3 Posts

04-27-2018

IT

17 Signins

68 Page Views

  • Posts: 3
  • Registered: ‎04-27-2018
  • Location: IT
  • Views: 68
  • Message 14 of 19

Re: t480s/dock:40ah - USB HID devices not found with docking station

2018-05-03, 14:14 PM

Just got a call from Lenovo support. 40AH should be available again May, 16. 

 

Cheers,

Daniele

Reply
Options

2 Posts

05-21-2018

US

9 Signins

30 Page Views

  • Posts: 2
  • Registered: ‎05-21-2018
  • Location: US
  • Views: 30
  • Message 15 of 19

Re: t480s/dock:40ah - USB HID devices not found with docking station

2018-05-22, 19:47 PM

Has anyone experienced any new developments with this issue?  I seem to be facing the same issue with a new out of the box 40ah ProDock and a T480s.

 

USB 3.0 devices work in the USB 3.0 ports, but not in the 2.0 ports, and 2.0 devices don't work in any port.

Ethernet/Power/Display Ports all seem to work just fine. 

 

I contacted Lenovo support, they're sending a replacement dock and they requested the Machine Type from both the dock and Laptop. (Unsure if it is because of any special issues they're seeing or if that is just normal procedure.)

 

WIll post back with findings once I get the replacement.

 

Thinkpad Pro Docking Station

Type: 40AH

FRU: 01HY745

 

Thinkpad T480S

Type: 20L7

Reply
Options

3 Posts

04-27-2018

IT

17 Signins

68 Page Views

  • Posts: 3
  • Registered: ‎04-27-2018
  • Location: IT
  • Views: 68
  • Message 16 of 19

Re: t480s/dock:40ah - USB HID devices not found with docking station

2018-05-29, 5:50 AM

40AH replacement arrived last friday. Seems to work properly. 

 

Daniele

Reply
Options

2 Posts

05-21-2018

US

9 Signins

30 Page Views

  • Posts: 2
  • Registered: ‎05-21-2018
  • Location: US
  • Views: 30
  • Message 17 of 19

Re: t480s/dock:40ah - USB HID devices not found with docking station

2018-06-12, 18:33 PM

So far I'm on a second replacement, and I'm still having the exact same issue - Lenovo Support is utterly useless and is basically a waste of time.  Does anyone have any other recommendations? 

Reply
Options

1 Posts

08-14-2018

PL

3 Signins

51 Page Views

  • Posts: 1
  • Registered: ‎08-14-2018
  • Location: PL
  • Views: 51
  • Message 18 of 19

Re: t480s/dock:40ah - USB HID devices not found with docking station

2018-08-14, 22:05 PM

FCF_IT wrote: 

"USB 3.0 devices work in the USB 3.0 ports, but not in the 2.0 ports, and 2.0 devices don't work in any port.

Ethernet/Power/Display Ports all seem to work just fine."

 

I have the same issue with T480. Waiting some ideas of Lenovo support team.

 

But for me it seams to be not a problem of dock station but the USB-C output of notebook. The same problem I observed using Unitek V300A (USB3.1 Gen1 Type-C 3-Port Hub + HDMI Converter). According to documentation devices with 2.0 should works under each port of this converter, but doesn't work - only devices with 3.0 works.

Reply
Options

2 Posts

02-28-2019

DK

2 Signins

27 Page Views

  • Posts: 2
  • Registered: ‎02-28-2019
  • Location: DK
  • Views: 27
  • Message 19 of 19

Re: t480s/dock:40ah - USB HID devices not found with docking station

2019-02-28, 9:50 AM

try to use some compressed air on the usb-c port on the laptop we have alot of them at work and the problem is dust in the usb-c port works 8 out of 10 times for me.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete