English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

5 Posts

12-08-2014

US

3 Signins

74 Page Views

  • Posts: 5
  • Registered: ‎12-08-2014
  • Location: US
  • Views: 74
  • Message 1 of 5

12-day-old T470s failed magnetic lid switch, causing erratic behavior and rendering system useless..

2018-04-19, 4:17 AM

The title sums it up.

 

https://photos.app.goo.gl/5wNJuFfFYFOcKxxm2

 

I have an RMA for a refund in progress, but wanted to see if anyone has any ideas before I ship it away.

 

I have verified it is the lid switch, because I can get it to stop if I hold a magnet just right around the switch, which is to the left of the webcam and mic.

 

Right out of the box, "L" key was bad on the keyboard; it doesn't register unless it's hit just right. I was dealing with it for now and was going to get a warranty part to fix it, but now this happened... 

Reply
Options

10715 Posts

01-02-2010

US

39412 Signins

409157 Page Views

  • Posts: 10715
  • Registered: ‎01-02-2010
  • Location: US
  • Views: 409157
  • Message 2 of 5

Re: 12-day-old T470s failed magnetic lid switch, causing erratic behavior and rendering system usele

2018-04-19, 5:16 AM

I would set a small screw on the palmrest to see if the magnet is really in place.  (center, at the front right below the place the lid switch is)  I wonder if the box was dropped in shipping affecting the keyboard and dislodging the magnet.


Rich


To help with forum searches, check this out: https:/forums.lenovo.com/t5/Welcome-FAQs/Using-Browser-Search-to-find-your-answers-in-Lenovo-and-Moto-Community/m-p/5016916

I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo.
Reply
Options

5 Posts

12-08-2014

US

3 Signins

74 Page Views

  • Posts: 5
  • Registered: ‎12-08-2014
  • Location: US
  • Views: 74
  • Message 3 of 5

Re: 12-day-old T470s failed magnetic lid switch, causing erratic behavior and rendering system usele

2018-04-19, 15:28 PM
Negative; the magnet in the base is present and in place, and can be felt with another magnet.

The problem isn't that it detects when the lid is closed, rather that it thinks the lid is still closed after it's been opened.

Appears to be a total failure of the magnetic reed switch.

Here's a better video:
https://photos.app.goo.gl/ixhTmDCbNB5I1aDc2
Reply
Options

10715 Posts

01-02-2010

US

39412 Signins

409157 Page Views

  • Posts: 10715
  • Registered: ‎01-02-2010
  • Location: US
  • Views: 409157
  • Message 4 of 5

Re: 12-day-old T470s failed magnetic lid switch, causing erratic behavior and rendering system usele

2018-04-19, 19:30 PM

Sounds like a bad Hall sensor.  (magnetic switch)


Rich


To help with forum searches, check this out: https:/forums.lenovo.com/t5/Welcome-FAQs/Using-Browser-Search-to-find-your-answers-in-Lenovo-and-Moto-Community/m-p/5016916

I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo.
Reply
Options

5 Posts

12-08-2014

US

3 Signins

74 Page Views

  • Posts: 5
  • Registered: ‎12-08-2014
  • Location: US
  • Views: 74
  • Message 5 of 5

Re: 12-day-old T470s failed magnetic lid switch, causing erratic behavior and rendering system usele

2018-04-21, 4:50 AM
A hall sensor makes sense, I thought it would just be a magnetic reed switch like the good ol days.

I was just printing my RMA label and getting ready to pack it up, when I decided to fire it up for one last check. Today, it's working fine...

I'm torn. I love the **bleep** thing, but I can't trust it now.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save