Showing results for 
Search instead for 
Did you mean: 
What's DOS?
Posts: 1
Registered: ‎05-16-2017
Location: CA
Views: 11,871
Message 1 of 5

2100: Detection error on HDD0 (Main HDD)

Whenever I try to restart my ThinkPad T440s, it takes a very long time to get past the "ThinkPad" screen.  If I hard reboot it while it's stuck here (press and hold the power key, then turn it back on), it loads just fine.  However, if I let it keep going it beeps loudly and angrily and gives me the 2100: Detection error on HDDO (Main HDD) on a black screen with only "Press Esc to continue".  When I press Esc it loads the boot screen, but without access to my hard drive.  If I hard reboot it again, it starts just fine.


Any ideas on why it would be doing this, or what I could do to fix it?  It looks like it was a common problem a few years ago, but this is new to me and it doesn't really look like there was a fix back then.  Hoping there's better news now?


Any help is appreciated!

Community SeniorMod
Community SeniorMod
Posts: 10,186
Registered: ‎01-01-2010
Location: US
Views: 11,844
Message 2 of 5

Re: 2100: Detection error on HDD0 (Main HDD)

It appears the drive is not responding fast enough at power-up.  It is impossible to be sure without seeing it, but it sounds like one of 2 things:  The most likely is that the disk is getting sick and needs replacing.  The 2nd option is that the SATA controller chip on the motherboard is getting sick.  In any case, the first step is to back up your data.  Then, if you still have warranty repaining, call support.  If no warranty remains, try a different disk.  You need a thin (7mm) one.


I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo.
What's DOS?
Posts: 2
Registered: ‎05-31-2017
Location: US
Views: 11,756
Message 3 of 5

Re: 2100: Detection error on HDD0 (Main HDD)

Win 8


PNY 128gb SSD


This seems to be an issue with either the mobo or as someones suggested before, the part between the mobo and hdd. If I stick the SSD in a caddy on another PC, it runs fine, so its doubtful that SSD firmware is to blame. I've noticed that on my machine, if system wide write speeds (as indicated in Task Manager) drop to something stupidly slow like 1MB, then the next time I restart I'll get the 2100 error. I've also had the 2100 error twice after letting the battery run down (charger was accidentally unplugged). To resolve it in the past I attempted to open the laptop to check the HDD controller, unscrewing the case from mobo etc. It got too fiddly and I couldnt see the last screw so I pieced it back together and it booted up fine (I hadnt touched anything HDD related). Another time its resolved itself simply by leaving it for an evening, and trying it the next morning.


I've also witnessed it get to the 2100 error in BIOS, then to a screen that says Please wait..., after which it restarted itself to Windows. Interestingly, this was after I updated BIOS from the Lenovo drivers. I assumed at the time that the update had some explicit fix for the 2100 error, but alas the error is back and BIOS isnt fixing it - so maybe that was a fluke. I've also tried with and without Battery present, doesnt seem to matter. Reinstalling the OS is no good, as the drive isnt a valid option (loads up the SSD manufaturer and model, but the size is 0 bytes)


As it stands, Im going to leave it for a while, powering it on every now and then in the hope it sorts itself again.



Have tried the following

- Updating BIOS doesnt seem to work

- SSD works fine in other machines

- Problem comes and goes, can resolve itself it seems

- As a precursor to the error, drive performance will drop, error appears on next reboot

- A Lenovo rep in a previous post advised the machines will need servicing, suggests hardware is poss at fault

- OS resintall - Drive appears as 0GB, and is unaccessible.


Havent tried

- using a known working regular old HDD whilst the 2100 error is present 

- SMART test from Diagnostics, as it isnt present, though CPU, Memory etc are (There are youtube videos of this technique working)

What's DOS?
Posts: 3
Registered: ‎01-26-2018
Location: US
Views: 9,492
Message 4 of 5

Re: 2100: Detection error on HDD0 (Main HDD)

I ran into a similar situation recently that might also cause the 2100 error. However, since your problem was so long ago, you may have already found a solution. But if you haven't (or if others have this problem), I recently ran across the same error message on my T430 laptop. In my case, I had defined a password in the BIOS settings for my harddrive. During the boot (or reboot) process, the BIOS would prompt me for this password. And if I took too long to respond, the BIOS code would, sort of, unmount my HDD0 device and then continue the boot process. Since HDD0 was my only harddrive, the T430 could not boot and gave me the "2100: Detection error on HDD0 (Main HDD)" error message. Rebooting and then making sure to enter the correct password would allow the boot to succeed. So if you were in a similar situation (i.e. had set a HDD password in your BIOS) and did not enter the password quickly enough on boot or reboot, this might explain one way to get the 2100 error message.
Paper Tape
Posts: 2
Registered: ‎12-25-2013
Location: US
Views: 3,580
Message 5 of 5

Re: 2100: Detection error on HDD0 (Main HDD)

I was getting the same Blue screen and HDD0 error message.  I read all the answers and many of them seemed plausible. However, there may be a much simpler solution.  It is possible the HDD has come loose and does not have a good connection into the slot.


First I shut down my computer, then removed the batter.  When I took the plastic cover off and opened the slot for the HDD, I noticed the HDD appeard a bit crooked.  I realized the HDD was not firmly inserted all the way into the slot, so I pushed the HDD all the way in, replaced the battery.  When I restarted the laptop, it booted with no problem, and I have not had the HDD0 error message since.


With this many people having the same HDD0 error message, I believe this is being caused by a design flaw in the plastic cover for the HDD slot.  There should be a larger rubber strip to hold the HDD firmly in place so it does not come loose and cause a connection problem.

Check out current deals!

Shop current deals

Top Kudoed Authors