Showing results for 
Search instead for 
Did you mean: 
Posts: 32
Registered: ‎09-29-2014
Location: Canada
Views: 2,471
Message 1 of 3

5ghz wifi problem T520

I have a T520 with Intel Centrino 6205 network card.


I have ability to run Win 7 and Win 10.


With Win 10, both 2.4 and 5Ghz SSIDs are available.

With Win 7, I only see the 2.4 GHz SSID.


I use Win 7 most of time, so would like to get this to work.


The driver for the Centrino card appears to be dated 22July2014. When I try and update from the Device Manager, it goes into an endless on-line search. Looking at this site, three driver options come up, but the numbers don't look like the one that is installed. The Intel Proset software version is 17.12.0 dated 2Oct2014.



Is there a way to switch on the 5Ghz band in settings somewhere?

If it is a driver problem, how to I find the correct driver?


Bit Torrent
Posts: 705
Registered: ‎11-21-2013
Location: US
Views: 2,432
Message 2 of 3

Re: 5ghz wifi problem T520

You can try here  


for both a ProSet install and a bare driver.  Note that they say "The following products are supported with this software and driver package", and the 6205 is listed.  But at the bottom, they list only the devices that will actually update.


You can use the drivers there, but they will only install the last version that was released for that card.  They end-of-life drivers eventually, and the 6205 went out about a year and a half ago. 


I have a couple, and the most recent driver that will install is, dated 4/30/15.


Also, that card will see both bands, but it still maxes out at 300mps for either band. 

Posts: 32
Registered: ‎09-29-2014
Location: Canada
Views: 2,421
Message 3 of 3

Re: 5ghz wifi problem T520

Thanks for reply and the Intel link.


I updated the drivers and the 6205 driver is now dated 30/04/2015 and version This after using the Intel driver utility that scans computer and then installs appropriate driver.


But still no 5Ghz band on Win 7.  (Yet it is there using Win 10.) When going to Device Manager/Properties/Advanced both 2.4 and 5GHz options show up they are set to Auto (tried 20MHz only but that made no difference).


So question still was - How do I get 5Ghz to show up in Windows 7 Pro?


I had a look again at Device Manager/Properties/Advanced. I finally scrolled all the way to the bottom to where it says Wireless mode. Chose item 6. 802.11a/b/g - it was previosly on b/g, I think. Anyway, that did the trick. Currently at 300Mbps which is a lot better than the 54-120  I was seeing before! New TP AC1200 C50 dual band router just installed and not tweaked, but seems to be fine for our simple needs.

Check out current deals!

Shop current deals

Top Kudoed Authors