cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
thinkFan
Paper Tape
Posts: 2
Registered: ‎02-22-2013
Location: Romania
Views: 3,890
Message 1 of 6

About Intel WiFi Link 5300 AGN

Hi there guys,

it's my first post on this forum even although I should've asked here first. I have the same problem with the network wifi adapter as mentioned in the previous thread with this subject: it happens to disconnect and after that it doesn't appear in Device Manager for some time. Ussually I go there 'scan for hardware changes' and it appears back, but sometimes it doesn't come back for good and I need to restart my laptop. 

So..this is quite sad. I've read all the opinions about this and all solutions so far and nothing worked for me. 

I checked my driver on Intel and it says: 

Product DetectedIntel(R) WiFi Link 5300 AGN
Current Driver Installed14.3.2.1
This device is unknown or unsupported. Please contact the manufacturer for possible updates.

So I downloaded their newer driver which is 15.3 and still the driver version remains 14.3. 

 

This is becoming quite annoying becouse it happens to disconnect right when I am downloading or writing an email. 

       

Did someone from tech support found a solution for this? please! Smiley Happy I would appreciate a lot. Thank you.

 

p.s. I am running win8 pro.

redeye_091776
What's DOS?
Posts: 2
Registered: ‎10-13-2012
Location: Silicon Valley, CA
Views: 3,863
Message 2 of 6

Re: About Intel WiFi Link 5300 AGN

I suspect there are variants of the Intel 5300 card that will work in Lenovo systems, and other versions of the card that are designed for other systems (like HP, etc) and will not work in a Lenovo. It's possible that the 5300 card you have wasn't designed for Lenovo platforms, and as a result doesn't match up with the bios whitelist on your system.

 

Did the system originally come with this card, or was the card installed sometime later? If installed later, was the card supposedly compatible with Lenovo systems (incl your model)? I picked up my new 5300 card from eBay sometime back... it was listed as compatible with my Lenovo T400 (incl a few other models), and once I installed it (and installed the driver, updated access connections, rebooted the system etc), it came right up at 450mbps when near the access-point.

 

Finally, the 15.x (I'm assuming Lenovo) driver might not support this older 5300 card... my T400 is running a 14.x driver for Win7 64-bit which does support the 5300, but I noticed the 15.x driver for my system doesn't support the older 5300 (and states that in the release notes for this ver).

 

That's all I can come up with for now... hope something here helps you out. And keep me posted... will check this thread from time to time.

 

Mike

Community SeniorMod
Community SeniorMod
Posts: 1,952
Registered: ‎12-02-2007
Location: AU
Views: 3,851
Message 3 of 6

Re: About Intel WiFi Link 5300 AGN


@thinkFan wrote:

So I downloaded their newer driver which is 15.3 and still the driver version remains 14.3. 

 


According to the read-me file for the 15.* series drivers from Intel, they DO NOT support the 5300 AGN card.

 

Cheers,

 

Bill

------------------------------
I don't work for Lenovo
Highlighted
Guru
Posts: 948
Registered: ‎06-03-2011
Location: US
Views: 3,829
Message 4 of 6

Re: About Intel WiFi Link 5300 AGN

The first thing I would do is open the computer up and reseat the card. It is possible that is is not fully in the connector slot.

 

What model do you have?

 

Here are some other thoughts. If I remember correctly the 5300 AGN came out in the T400 generation and was the 3 antenna card for that time. I remember it being a little troublesome at first, but after forcing it to operate in full power mode (disabling any power saving operation) it seemed to work fine. So you may want to turn off any wifi powersaving. Future drivers seemed to mitigate this issue and allow for smooth operation in power saving modes. 

 

WiFi cards must be on the BIOS whitelist to work in a Lenovo model, so if this is a card you added to the system its important that it compatible with the system it was purchased for. Often only 2 antennas are available in some systems with webcams, so if you have a webcam you may want to look into that and make sure that the correct antenna connectors are attached.

 

Its possible that this card is just not supported under Windows 8. The card was current during the Windows Vista era and supported under Windows 7. If you are unable to get it working under Windows 8 you may need to switch to Windows 7. 

X1 Carbon 3rd Gen Type 20BT i7-5500U, 2560x1440 (non-touch), Win 10 Pro, 8GB RAM, 512 SSD, Intel 7625 WiFi, BT 4.0 | ThinkVision P24q-10 monitor

------------------------------------------
When asking for help, post your question in the forum. Remember to include your system type, model number, and OS. Do not post your serial number.

Did someone help you today? Thank them with a Kudo!

If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help others with the same question in the future.
thinkFan
Paper Tape
Posts: 2
Registered: ‎02-22-2013
Location: Romania
Views: 3,801
Message 5 of 6

Re: About Intel WiFi Link 5300 AGN

I found ur answers very helpful. This helped me understand how the things are working about the hardware match. 

I have t400 2768AB1 and it camed with this installed wifi adapter. I did not changed since then, but it is possible to be different becouse I bought my laptop through the refurbishment system so I will ask the first user or try to open up my laptop and see for myself.

But what intrigues me is the question: why this happened after some time when everything was working smooth and did not happen from the start?

Hmm..about power saving options wifi: I deactivated  all those options from Thinkpad power manager and control panel 

.. and it has periodes you know..I mean it can happen 20x times a day or not even once a day..I cannot figure out what determinates it.

 


Thanks for your concern and feedback.

Retired Support Specialist
Posts: 613
Registered: ‎12-11-2012
Location: raleigh, nc
Views: 3,657
Message 6 of 6

Re: About Intel WiFi Link 5300 AGN

Hi All,

 

Don't forget that sometimes it's just about how your system talks to the router.

Routers don't get updated as much as the technology in your computer.

Sometimes it may be neccesary to change security settings or the particular WiFi mode you are using.

The latest driver does not always mean the best driver.

Also, have you tried any assistive software like PROSet wireless?

 

It seems like WiFi connectivity requires an orchestra of systems working together and any one piece out of tune can breakdown everything.

Make sure you have BIOS and Chipset drivers are updated.

Sometimes playing with different WLAN drivers work (I've had Broadcom WLAN cards using Intel drivers with much success).

 

That was just my 2 cents from my experience with this issue.

Hope this helps someone somewhere.

 

 

Be AWESOME Everyday!

Donate KUDOS and Click "Accepted Solution"

Did someone help you today?
Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"

This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Check out current deals!


Shop current deals

Top Kudoed Authors