Showing results for 
Search instead for 
Did you mean: 
Serial Port
Posts: 23
Registered: ‎04-02-2011
Location: San francisco,ca
Views: 1,815
Message 1 of 3

BIOS updater app not working - "Thinkvantage system update" not working for BIOS

I  successfully cloned my HDD to a SSD and installed the latest available (as of today)  Thinkvantage System Update program (after uninstalling the prior  SU version 4.0 on my T410).    The SSD is working fine, but  i noticed a few problems  even though i installed  all the drivers  by running System update  (with multiple reboots).  The  SSD speed is sub-optimal and  Samsung  magician  says "there is no Samsung SSD on system.  If you are using a custom storage driver  Samsung Magician may not work properly - please install the latest storage driver."   BIOS reports that there is  a Samsung  EVO.


The only thing that was not done was the BIOS update for my old BIOS version 1.18.  So, finally i tried BIOS download/update option that was given in  Thinkvantage  System update.  Even though goes through the download process, it did not install it (i got no windows asking prompts).  So, then i  installed the  Lenovo BIOS update utility from   This downloaded, and i got installed onto my computer, but at end when i said install bios  it came up with an error  box saying  "The process does not recognize the system.  The process has been cancelled".    Next,  i tried manually going into the directory where the  BIOS update application was installed and started  the  WINPLASH64 app (i have 64-bit Windows 7 installed).  This application could not run successfully, because it says  it could not find the  "Flash-rom"   file which was specified in the   "New BIOS"  field  in the starting window of this application.  All this was done today, with whatever i could find on the lenovo website.


So,  my guess is that  going from  BIOS  version  1.18  to the current and latest  1.45 version  of BIOS  is too big of  a jump  and has not been tested.  Is there an intermediate version of  BIOS i need to download  and install before updating to the 1.45 ?  If so, where can i find this intermediate version  ?  I do need a BIOS update because i was able to get  the expected  SSD speeds on another (DELL)  laptop,  which  has  similar specs like  my Thinkpad.  I am hoping that  BIOS update is the only thing i need, since i am hoping that  System update has installed the proper  Intel  storage drivers that my SSD needs.


Thanks in advance for any suggestions.

Posts: 7,116
Registered: ‎09-03-2014
Location: SK
Views: 1,791
Message 2 of 3

Re: BIOS updater app not working - "Thinkvantage system update" not working for BIOS

Hello nsamuel,


I'd be interested to know if you can install 1.45 after a lower version; if it doesn't work we need to get it fixed and I don't have a T410 to test with. To find an older version please go to the link you provided in your above post and scroll down to the bottom of the page; you'll find several older versions there to choose from.




English Community Leader
Please remember to come back and mark the post that you feel solved your question as the solution, it earns the member + points 
Did you find a post helpfull? You can thank the member by clicking on the star below their post awarding them Kudos

Please don't ask me questions by Personal Message; questions belong in the forums.

  Communities:   English    Deutsche    Español    Português    Русскоязычное    Česká    Slovenská    Українська   Język Polski    Moto English

Serial Port
Posts: 23
Registered: ‎04-02-2011
Location: San francisco,ca
Views: 1,756
Message 3 of 3

Re: BIOS updater app not working - "Thinkvantage system update" not working for BIOS

I found the problem today, with a careful look at things again. Here are my observations / suggestions for Lennovo to fix.


  1. Note: I am a windows-7 user. Now, Notice that the title of the following two support pages have very similar title (especially for someone searching for a Windows-7 system BIOS using google).
    Bios Update utility for Windows 8, windows 7 etc...
    Bios Update Utility for Windows 7......
    But in small letters (without making it part of title) is the info (in the first link above) that it is meant for only T400. Looking at the title you would think it is for all Thinkpads. Mine was a T410 and the second link gave the right BIOS utility that worked for me. Thank goodness, i suddenly thought of checking the info carefully in the first webpage which i had used for the download previously. (an error). So, i suggest that lenovo make things clear in title (it is already a long title anyways) - or atleast put the model numbers right up top.

  2. If the model number is not right, the BIOS update utility should flash a correct warning, rather than giving obscure error messages.

  3. System Update  (latest version as of today)  failed on BIOS and history shows "failed to download". I tried twice  on Aug. 16th at 6.40pm  PST.  I don't know if that server was broken at that time.  Otherwise, there is a bug in System Update,  going from 1.18 BIOS.  

  4. Now  my BIOS is updated as well as all drivers (according to  System Update),  but my  SSD is not being recognized by  Samsung magician. Also the same SSD is giving twice the speed on a Dell laptop that is also SATA-ii  rated like my  T410.   Obviously,  the  AHCI  driver that shows up in my T410 under Device-Manager  is not  upto date.  It shows that i am using  Intel 5 series 6 port SATA  AHCI  controller.  Need to start a seperate thread on this issue, i guess.

BTW,  why is the "numbered list"  not showing up in my post ?  When i am typing (creating this message)  i hit the "Numbered list" icon  and  the numbers are showing up while i type this message.  But once i hit POST message,  the  screen is refreshed, and  my numbered list is gone  in the message.   "Preview message"  did not show the numbers either.


Check out current deals!

Shop current deals

Top Kudoed Authors