cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
qwgh
Paper Tape
Posts: 1
Registered: ‎03-17-2018
Location: US
Views: 255
Message 1 of 2

Cannot update T470 BIOS from version 1.30

Hi,

 

I've been having an issue for a while now where I cannot update my BIOS from version 1.30. I additionally appear to be having issues with the Intel ME:

 

PS C:\DRIVERS\WIN\ME> .\MEInfoWin.exe -verbose

Intel(R) MEInfo Version: 11.8.50.3448
Copyright(C) 2005 - 2017, Intel Corporation. All rights reserved.




Windows OS Version : 10.0

    Table Type 174 ( 0x AE ) found, size of   0 (0x 00 ) bytes
    Table Type 222 ( 0x DE ) found, size of  72 (0x 48 ) bytes
    Table Type  14 ( 0x 0E ) found, size of  42 (0x 2A ) bytes
    Table Type 134 ( 0x 86 ) found, size of  15 (0x 0F ) bytes
    Table Type  16 ( 0x 10 ) found, size of  25 (0x 19 ) bytes
    Table Type  17 ( 0x 11 ) found, size of 103 (0x 67 ) bytes
    Table Type  19 ( 0x 13 ) found, size of  33 (0x 21 ) bytes
    Table Type  14 ( 0x 0E ) found, size of  14 (0x 0E ) bytes
    Table Type 222 ( 0x DE ) found, size of  72 (0x 48 ) bytes
    Table Type  14 ( 0x 0E ) found, size of  42 (0x 2A ) bytes
    Table Type 134 ( 0x 86 ) found, size of  15 (0x 0F ) bytes
    Table Type  16 ( 0x 10 ) found, size of  25 (0x 19 ) bytes
    Table Type  17 ( 0x 11 ) found, size of 103 (0x 67 ) bytes
    Table Type  19 ( 0x 13 ) found, size of  33 (0x 21 ) bytes
    Table Type  14 ( 0x 0E ) found, size of  14 (0x 0E ) bytes
FW Status Register1: 0x8030404E
FW Status Register2: 0x340D0006
FW Status Register3: 0x00000020
FW Status Register4: 0x00000000
FW Status Register5: 0x00000000
FW Status Register6: 0x00000000

  CurrentState:                               Unknown (14)
  ManufacturingMode:                          Disabled
  FlashPartition:                             Valid
  OperationalState:                           CM0 with UMA
  InitComplete:                               Initializing
  BUPLoadState:                               Success
  ErrorCode:                                  Debug Error
  ModeOfOperation:                            Normal
  SPI Flash Log:                              Not Present
  FPF HW Source value:                        FPF HW Not Set
  ME FPF Fusing Patch Status:                 ME FPF Fusing patch NOT supported in this FW Version
  Phase:                                      BringUp
  ICC:                                        Valid OEM data, ICC programmed
  ME File System Corrupted:                   No
  PhaseStatus:                                CHECK_BUP_OVERRIDE_STRAP
  FPF and ME Config Status:                   Not committed

Error 86: Communication error between application and Intel(R) ME module (FWU client)

Error 81: Internal error (Could not determine FW features information)

When attempting to install a BIOS update either via the .exe or via bootable USB, the process appears to successfully flash but fail to reboot the system. After waiting several hours, I forcibly rebooted the system to find that the update wasn't applied.

 

I believe the issue with the BIOS and the ME state are linked - the 1.30 has some hibernation/reboot bugs and I think the ME is in a corresponding state also preventing successful reboots. At the moment, I cannot reboot or shutdown my T470 and regularly have to make use of the reset button to force a shutdown.

 

What are my options for forcibly updating the BIOS if I can't rely on the OS to cleanly shut down?

jester0
What's DOS?
Posts: 1
Registered: ‎04-20-2018
Location: IT
Views: 183
Message 2 of 2

Re: Cannot update T470 BIOS from version 1.30

Hi have the very same problem with a Dell XPS 9365 convertible laptop.

ME is kinda stuck initializing, therefore interfaces exported by itself doesn't work. e.g. ISH (Integrated sensor hub)

 

It's also impossibile to update the BIOS either running it from windows or directly from the bios menu itself. Like you said, when the system tries to reboot in update mode it just boot the system normally.

 

By the way, I'm able to flash the bios putting the update file in an usb stick and entering bios recovery mode.

On Dell system you need to press and keep pressed ctrl + esc while plugging in the power cord (when powered off).

It tries to load the bios recovery from hard drive and from usb as well...

 

Anyway, flashing the bios doesn't seem to help with the ME problems we have.

 

Did you find a solution?

 

 

Check out current deals!


Shop current deals

Top Kudoed Authors