English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

6 Posts

01-15-2014

SK

6 Signins

47 Page Views

  • Posts: 6
  • Registered: ‎01-15-2014
  • Location: SK
  • Views: 47
  • Message 1 of 15

Charging stops and starts every few seconds in a loop T440s

2018-10-25, 21:30 PM

When I plug in the charger, it'll show that it's charging, then a few seconds later it stops.
Then a few seconds later it starts again. Then it stops. Then starts.

I tried to find some solution on the internet, but no succes. Did you experienced similar charging problems pls? Thank you for any advice...

Reply
Options

276 Posts

10-28-2016

US

471 Signins

2554 Page Views

  • Posts: 276
  • Registered: ‎10-28-2016
  • Location: US
  • Views: 2554
  • Message 2 of 15

Re: Charging stops and starts every few seconds in a loop T440s

2018-10-25, 22:55 PM

Are you running windows 10?

 

If so try the steps below - I have a T480 which has dual batteries, I beleive the T480s only has one non-removable battery.

So ... ignore the steps related to the 2nd removable battery:

 

 I may have some extra unnecessary steps in here, but I wanted to be sure I didn't screw it up:

  • Open the Device Manager by searching for it or right-clicking the Start button and selecting Device Manager.
  • Click Batteries on the list to expand it and you should see two items (maybe three items – if your machine is equipped with two batteries there may be two, but on my machine which does have two batteries only one was displayed) Anyway:
  • You will see: : Microsoft AC Adapter
  •  And one or two  Microsoft ACPI-Compliant Control Method Battery (s)
  • Right-click on each item and choose Uninstall device. Yes, you are uninstalling your laptop's battery drivers, but don't worry because they will automatically be reinstalled when you restart your laptop.
  • Shut down your laptop.
  • Unplug the power cable from your laptop.
  • Power on the laptop (running on batteries now) and enter BIOS
  • Go to:  Config --> Power  -->  and select the option to “Disable built-in battery”
  • You will get a prompt that says the machine will power down if you continue.
  • Acknowledge the prompt  --> the machine shuts down.
  • If your laptop has a second removable battery, remove it.
  • Plug in the charger cable to your laptop, this puts the internal battery back on-line and powers up the system.
  • Let it stabilize at the desktop – if you want to check Device Manager you should now see the AC adapter and ONE battery (the internal battery, the 2nd battery is uninstalled and laying on your desk at this point).
  • Shut down the machine
  •  unplug the charger cable
  • install the 2nd external battery, making sure it it latched and then locked in place.
  • plug the charger cable back in
  • power on the laptop and boot to the desktop
  • At this point my machine was fixed – both batteries and the AC adapter were registered in Device Manager, and both batteries once again showed up as separate line items in the Microsoft battery taskbar item and functioned properly.

If my post answers your question, please mark it as an”Accepted Solution“!
If my post helps you, please click the star to give it a "Kudo"!

In a galaxy far far away, a long time ago I worked for IBM for many years.

Currently I do not work for, nor do I speak for either Lenovo or IBM.

 

If my post helps a Kudo is appreciated, if I answer your question, please mark it ”Accepted Solution“ and give it a Kudo! ... Some years ago I worked for IBM. Currently I do not work for, nor do I speak for Lenovo or IBM.
Reply
Options

6 Posts

01-15-2014

SK

6 Signins

47 Page Views

  • Posts: 6
  • Registered: ‎01-15-2014
  • Location: SK
  • Views: 47
  • Message 3 of 15

Re: Charging stops and starts every few seconds in a loop T440s

2018-10-26, 12:27 PM

Thank you for your fast anser, it gives me a hope for the solution. 

Yes, it is Windos 10, yes T440s has also dual batteries. So I followed eactly your advices. Everything went well, until:

  • install the 2nd external battery, making sure it it latched and then locked in place.
  • plug the charger cable back in

Unfortunately, after pluging the charger cable, the charging cycle on/off started again (even before powering and booting the laptop).

Do you have probably some advice? 

Thank you again.

Reply
Options

6 Posts

01-15-2014

SK

6 Signins

47 Page Views

  • Posts: 6
  • Registered: ‎01-15-2014
  • Location: SK
  • Views: 47
  • Message 4 of 15

Re: Charging stops and starts every few seconds in a loop T440s

2018-10-26, 12:36 PM

... I found out that during that endless stop/start charging cycle the laptop has sometimes problem with the RTC tests (from the motherboard test group). Could it be conneced somehow? 

Reply
Options

276 Posts

10-28-2016

US

471 Signins

2554 Page Views

  • Posts: 276
  • Registered: ‎10-28-2016
  • Location: US
  • Views: 2554
  • Message 5 of 15

Re: Charging stops and starts every few seconds in a loop T440s

2018-10-26, 13:40 PM

Weird.... very weird...

 

Did you run Lenovo Vantage to find the RTC error or some other tool?

 

I it was me what I would do next is:

 

1) try to borrow another compatible charger and see if symptoms change or are resolved

2) would suggest the H/W diagnostics from Lenovo vantage

3) review the event logs and see if anything is posted there that gives a clue

If my post helps a Kudo is appreciated, if I answer your question, please mark it ”Accepted Solution“ and give it a Kudo! ... Some years ago I worked for IBM. Currently I do not work for, nor do I speak for Lenovo or IBM.
Reply
Options

6 Posts

01-15-2014

SK

6 Signins

47 Page Views

  • Posts: 6
  • Registered: ‎01-15-2014
  • Location: SK
  • Views: 47
  • Message 6 of 15

Re: Charging stops and starts every few seconds in a loop T440s

2018-10-28, 15:08 PM

Yes, it’s weird…. and very annoying. When unplugged, the laptop is working flawlessly. When I plug it, it starts its strange charge / not charge cycle, the laptop is slower and battery goes down, until it is totally discharged and the laptop switches down. Then it is charging normally and can be used normally again. When it is charged at ca. 84%, the annoying cycle begins again... This time it stops at 81%, looks ok, but it is not charging.

 

Yes, I used Lenovo Vantage tool for diagnostics, all other tests went OK.

I tried already several chargers, it's always the same.

I even measured the voltage of built-in battery (BIOS) battery - it is ok.

 

Reply
Options

1 Posts

05-16-2019

AT

1 Signins

27 Page Views

  • Posts: 1
  • Registered: ‎05-16-2019
  • Location: AT
  • Views: 27
  • Message 7 of 15

Re: Charging stops and starts every few seconds in a loop T440s

2019-05-16, 16:03 PM

I have got the same problem.

 

- followed the steps - no solution

- I did a bios update

- I tested it with both batteries in single mode (one battery disconneted while the other was connected)

- I used different AC adapters - and used only the adapter with both batteries disconnected (no problems) -

 

and it happens also when the laptop is switched off. (because everytime the light at the power button is blinking

 

has someone different ideas?

Reply
Options

1 Posts

02-14-2016

Brasil

2 Signins

6 Page Views

  • Posts: 1
  • Registered: ‎02-14-2016
  • Location: Brasil
  • Views: 6
  • Message 8 of 15

Re: Charging stops and starts every few seconds in a loop T440s

2019-08-15, 2:09 AM

i'm having the same issue with a X240 Laptop, when I plug in the charger it starts to charge then stops, then starts, the stops... when its turned off it also do the same, blinking the power led... man, it's driving me crazy..

Reply
Options

3 Posts

07-24-2016

NA

2 Signins

24 Page Views

  • Posts: 3
  • Registered: ‎07-24-2016
  • Location: NA
  • Views: 24
  • Message 9 of 15

Re: Charging stops and starts every few seconds in a loop T440s

2019-11-07, 3:09 AM

im also haveing same problem my one is lenovo thinkpad t400, first i got this problem the i remove my battery and try to power on in with ac adopter then it work few days later it power on and shutdown imediatly,so later i noticed my power adopter connect and disconet about every 5sec,

do any guys think this might be a power is problem in motherboard?

Reply
Options

3 Posts

07-24-2016

NA

2 Signins

24 Page Views

  • Posts: 3
  • Registered: ‎07-24-2016
  • Location: NA
  • Views: 24
  • Message 10 of 15

Re: Charging stops and starts every few seconds in a loop T440s

2019-11-07, 3:11 AM
sorry guys for spelling mistakes
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save