Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

2 Posts

01-29-2009

USA

3 Signins

5 Page Views

  • Posts: 2
  • Registered: ‎01-29-2009
  • Location: USA
  • Views: 5
  • Message 1 of 3

Conexant audio driver problem on T500 Vista 64

2009-01-29, 3:00 AM

I recently followed the Lenovo update procedure, and installed the latest Conexant driver (a recommended update according to Lenovo). Since then the audio device is no longer working. I feel sure that the original Conexant driver that came with the T500 worked, but when I roll back the driver it installs the Microsoft High definition driver, not the previous Conexant driver.

Does anyone have this same problem, and is there a solution?

Reply
Options

3 Posts

01-31-2009

Texas

7 Signins

84 Page Views

  • Posts: 3
  • Registered: ‎01-31-2009
  • Location: Texas
  • Views: 84
  • Message 2 of 3

Re: Conexant audio driver problem on T500 Vista 64

2009-01-31, 17:44 PM

System:

Lenovo ThinkPad T400

Windows Vista Basic x32 2GB RAM

 

I installed 10 updates using ThinkVantage System Update on January the 27th, one of which was the "Conextant Audio Features II" version 4.76.0.0 update. Another possibly related was the BIOS update version 1.20-1.01.

 

The sound works in games, Windows Media Player and Quicktime, but it doesn't work in any of my web browsers (Google Chrome, Firefox, IE). The browsers don't show up in the mixer window. The system sounds don't work and when I change the volume via the icon in the system tray it doesn't make the little "ting" sound.

 

I opened the Programs and Features and attempted to remove the Conextant HD??? (don't remember the whole name) which showed an install date of the 27th. Vista said that it crashed while trying to remove it and it now doesn't show in the program list.

 

I'm thinking about doing a system restore. 

 

 

Reply
Options

3 Posts

01-31-2009

Texas

7 Signins

84 Page Views

  • Posts: 3
  • Registered: ‎01-31-2009
  • Location: Texas
  • Views: 84
  • Message 3 of 3

Re: Conexant audio driver problem on T500 Vista 64

2009-02-01, 0:07 AM

From what I can find it seems that Vista's registry got messed up when we updated our audio driver. I found this thread: http://social.msdn.microsoft.com/forums/en-US/mediafoundationdevelopment/thread/94cdc662-e974-43de-8feb-6eb156924347/

 

I applied the registry patch and it fixed it. I'm warry of blindly applying things like this to my registry, so before I did, I created a restore point and exported a copy of my registry.

 

Warning/Disclaimer

Editing the registry in any way, including the method described below without proper knowledge of what you are doing can cause serious errors and the author may not be held liable for resulting damages. :robothappy:

 

After backing up your registry, copy this (the text in red) to a text file and save it as *something*.reg - not .txt. Then click on the file and click ok (let it patch your registry).

 

---------------------------------------------------------------------------------------------------------------------------

 

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32]
"midimapper"="midimap.dll"
"msacm.imaadpcm"="imaadp32.acm"
"msacm.msadpcm"="msadp32.acm"
"msacm.msg711"="msg711.acm"
"msacm.msgsm610"="msgsm32.acm"
"msacm.trspch"="tssoft32.acm"
"vidc.cvid"="iccvid.dll"
"VIDC.I420"="i420vfw.dll"
"vidc.iv31"="ir32_32.dll"
"vidc.iv32"="ir32_32.dll"
"vidc.iv41"="ir41_32.ax"
"VIDC.IYUV"="iyuv_32.dll"
"vidc.mrle"="msrle32.dll"
"vidc.msvc"="msvidc32.dll"
"VIDC.YVYU"="msyuv.dll"
"wavemapper"="msacm32.drv"
"msacm.msg723"="msg723.acm"
"vidc.M263"="msh263.drv"
"vidc.M261"="msh261.drv"
"msacm.msaudio1"="msaud32.acm"
"msacm.sl_anet"="sl_anet.acm"
"msacm.iac2"="C:\\WINDOWS\\system32\\iac25_32.ax"
"vidc.iv50"="ir50_32.dll"
"wave"="wdmaud.drv"
"midi"="wdmaud.drv"
"mixer"="wdmaud.drv"
"VIDC.WMV3"="wmv9vcm.dll"
"VIDC.VP40"="vp4vfw.dll"
"msacm.voxacm160"="vct3216.acm"
"MSVideo"="vfwwdm32.dll"
"MSVideo8"="VfWWDM32.dll"
"wave1"="wdmaud.drv"
"midi1"="wdmaud.drv"
"mixer1"="wdmaud.drv"
"aux"="wdmaud.drv"
"vidc.VP70"="vp7vfw.dll"
"vidc.X264"="x264vfw.dll"
"VIDC.FPS1"="frapsvid.dll"
"vidc.VP60"="vp6vfw.dll"
"vidc.VP61"="vp6vfw.dll"
"vidc.VP62"="vp6vfw.dll"
"vidc.DIVX"="DivX.dll"
"VIDC.UYVY"="msyuv.dll"
"VIDC.YUY2"="msyuv.dll"
"VIDC.YVU9"="tsbyuv.dll"
"VIDC.DRAW"="DVIDEO.DLL"
"VIDC.YV12"="yv12vfw.dll"
"wave2"="wdmaud.drv"
"midi2"="wdmaud.drv"
"mixer2"="wdmaud.drv"
"aux1"="wdmaud.drv"
"wave3"="wdmaud.drv"
"midi3"="wdmaud.drv"
"mixer3"="wdmaud.drv"
"aux2"="wdmaud.drv"
"VIDC.MSUD"="msulvc05.dll"
"wave4"="wdmaud.drv"
"midi4"="wdmaud.drv"
"mixer4"="wdmaud.drv"

 

 

-------------------------------------------------------------------------------------------------------------------------

 

Message Edited by JordanCronin on 01-31-2009 04:11 PM
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms