Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Paper Tape
Posts: 1
Registered: ‎05-07-2012
Location: Munich
0 Kudos

Display changes to very low contrast and high brightness while in dockingstation

Hallo everyone,


the display of my T510 (typ 4337) chnages the brightness and contrast itself while in dockingstation. The contrast gets very low so that neither backround nor icons are clearly visible.The only thing that helps in this situation is a reboot of the system.

Sometimes it happens twice a day in other times only once a week. Since I have to work with my T510 its annoying to shot down the system in the middle of day.


I updated the video driver as in other post recommended:


I also updated with the lenovo updater and search the web for the newest video driver.

Has anyone the same problem and found a solution?

System is (from Intel Info Center):
OS: Win7 (64bit) Service Pack 1
Model; T510
Driver version
Processor Intel Family 6 Model 37 Stepping 5

Accelerator Information:
Intel HD Graphics
Video BIOS: 2117.1
Graphics mode 1920 by 1080

Any help would be appreciatediciated Thanks in advance.

Posts: 293
Topics: 2
Kudos: 16
Solutions: 10
Registered: ‎02-01-2012
Location: Inda
0 Kudos

Re: Display changes to very low contrast and high brightness while in dockingstation

Display get changed automatically while using dockingstation. Please update the Bios of your system
from below mentioned web link


After that please restart the system and check whether the issue has been resolved.



Thanks & Regards,


Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution".! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!