cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
barryinindy
What's DOS?
Posts: 2
Registered: ‎11-26-2013
Location: USA
Views: 8,033
Message 11 of 26

Re: Docked T430 - will not detect external keyboard at boot

I am having the same problems. It's not a Windows issue. Issue occurs before Windows in introduced. Issue occurs in the Lenovo Diags CD. So this is not a Windows issue. Tried different docks. Other T430s work in this dock except this particular laptop. USBs work on on the laptop. All periphrials on the dock work except USB ports.

 

System board??

 

Please help!

lead_org Microsoft MVP Contributor
Microsoft MVP Contributor
Posts: 21,009
Registered: ‎12-19-2008
Location: Australia, Melbourne
Views: 8,026
Message 12 of 26

Re: Docked T430 - will not detect external keyboard at boot

@barryinindy,

Go into your bios menu, under configs, make sure your graphics option is in Optimus mode.

Regards,

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft
barryinindy
What's DOS?
Posts: 2
Registered: ‎11-26-2013
Location: USA
Views: 8,025
Message 13 of 26

Re: Docked T430 - will not detect external keyboard at boot

Optimus is not an option under Video.

 

I'm confused as to the connection between video and USB ports on the dock.

 

-B

lead_org Microsoft MVP Contributor
Microsoft MVP Contributor
Posts: 21,009
Registered: ‎12-19-2008
Location: Australia, Melbourne
Views: 8,001
Message 14 of 26

Re: Docked T430 - will not detect external keyboard at boot

Sorry i was reading couple of posts at once, and i mistakenly posting on the wrong thread. Disregard my previous post.
Regards,

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft
Former Employee
Posts: 2,835
Registered: ‎03-20-2012
Location: Malaysia
Views: 7,990
Message 15 of 26

Re: Docked T430 - will not detect external keyboard at boot

Hi Wes-,

I've Pm you some details i require, could you PM me back with the details.

Regards
schnefi
What's DOS?
Posts: 1
Registered: ‎11-28-2013
Location: Switzerland
Views: 7,976
Message 16 of 26

Re: Docked T430 - will not detect external keyboard at boot

Hi there

Same problem here on several T430 notebook docked. using Fujitsu Keyboards. also not able to set a hardware password on boot with external keyboard.

but if push off an on again it works every time. question, why does it not work at 1st try to start the the notebook.

i'm also using bitlocker. also did boot twice with suspended bitlocker mode.

changed mouse, keyboard, screen, all cables, still not working properly.

Wes-
Ctrl-Alt-Del
Posts: 7
Registered: ‎11-13-2013
Location: Texas
Views: 7,942
Message 17 of 26

Re: Docked T430 - will not detect external keyboard at boot

PM Sent.

Wes-
Ctrl-Alt-Del
Posts: 7
Registered: ‎11-13-2013
Location: Texas
Views: 7,935
Message 18 of 26

Re: Docked T430 - will not detect external keyboard at boot

Okay, it seems like the problem may be resolved.  I downloaded and installed the latest BIOS and tested.  Seems to have done the trick.  Old BIOS Version/Date = G1ET90WW (2.50), 12/18/2012.  New BIOS Version/Date = G1ET99WW (2.59), 11/13/2013.

 

Not saying this is the ultimate solution for everyone, but it seems to have worked for me.

Former Employee
Posts: 2,835
Registered: ‎03-20-2012
Location: Malaysia
Views: 7,915
Message 19 of 26

Re: Docked T430 - will not detect external keyboard at boot

Hi Wes,

thanks for psoting back our result. I'd like to check with everyone here affected does installing the BIOS assisted you. If ytou have yet to try you can download the BIOS from the Link below.

http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS029252

Please do post back you results.

Regards
MaoTenDoo
Paper Tape
Posts: 1
Registered: ‎12-31-2013
Location: Merica
Views: 7,859
Message 20 of 26

Re: Docked T430 - will not detect external keyboard at boot

Around Dec 9th, I had two L430's (with WinXP) in 4337 docking stations (w/ 90W adapters) that were unable to use the docks' USB ports.  Display & ethernet ports work fine.  I've ran ThinkVantage updates, done Windows System Restores, swapped docks, manually updated the chipset, BIOS, & camera drivers several times (often getting a "USB Hub Power Exceeded" message).  Sent one back to Lenovo Tech Support, but they could find nothing wrong.  I've installed BIOS 2.56, 2.57 & 2.59.  In Device Manager, the following devices show Error 10 codes:

 

- Imaging Devices \ Integrated Camera (USB\VID_04F2&PID_B2EA\6&228F9119&0&6)

 

- USB Controllers \ Generic USB Hub (USB\VID_17EF&PID_100A\6&228F9119&0&1)

 

I've uninstalled all USB devices & rebooted to wipe/refresh the drivers & tried disabling the Power Mgt feature for both USB Root Hubs.  Nothing helps.

 

Edited to add:  Sometimes after an update or tweak, the error codes clear up & USB mouse/keyboard work fine, but the errors come back after a Windows restart.

Check out current deals!


Shop current deals

Top Kudoed Authors