cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Lucas_Barton
Paper Tape
Posts: 6
Registered: ‎06-14-2018
Location: US
Views: 6,964
Message 1 of 10

Dual Monitors (DisplayPort) not working on Pro Side Dock (40AH) with T480

I have two 27" 2560x1440 60hz monitors that are plugged into the new Pro side-connect dock (40AH) with a new T480 (Intel 620 integrated graphics) in Windows 10 Pro. I can get either monitor to work fine with the dock individually, but trying to run both simultaneously by extending or duplicating the desktop between them seems to fail as selecting either option under Display Settings just makes the primary monitor black out for a few seconds then come back - the secondary monitor stays black.  There's no error msg or popup that would help me investigate further unfortunately.

 

I'm trying this with the T480's lid closed, and I'm running the latest 1.14 BIOS update and latest Intel HD graphics drivers. This setup worked fine on my old OneLink dock and X1 Carbon previously, so I don't think it's an issue with the monitors themselves.

 

Anyone have a similar setup with the new Pro dock that's working?

ChristopherF2
Paper Tape
Posts: 4
Registered: ‎06-21-2018
Location: US
Views: 6,866
Message 2 of 10

Re: Dual Monitors (DisplayPort) not working on Pro Side Dock (40AH) with T480

I am running into this issue as well with 2 23" 2560x1440p screens. I tried updating dock formware but it errors out and tells me the machine is not docked. Updated all other software and firmware that could be related to this issue but can still only get one external screen to work.

Lucas_Barton
Paper Tape
Posts: 6
Registered: ‎06-14-2018
Location: US
Views: 6,851
Message 3 of 10

Re: Dual Monitors (DisplayPort) not working on Pro Side Dock (40AH) with T480

I'm wondering if it's a limitation somehow with the combination of the T480 and Pro Dock. I saw elsewhere that someone with an X1 Carbon was able to use 2x monitors via Displayport on the Pro dock.

Did you try lowering the resolution or refresh rate of your monitors ? It didn't work for me but is something to try

ChristopherF2
Paper Tape
Posts: 4
Registered: ‎06-21-2018
Location: US
Views: 6,845
Message 4 of 10

Re: Dual Monitors (DisplayPort) not working on Pro Side Dock (40AH) with T480

I should mention I'm on a p52s, but same dock. I did try running both of my external screens at 1080p and with lower refresh rates but ran into the same issue. When I plugged in 2 native 1080p screens the dock worked perfectly. 

Lucas_Barton
Paper Tape
Posts: 6
Registered: ‎06-14-2018
Location: US
Views: 6,836
Message 5 of 10

Re: Dual Monitors (DisplayPort) not working on Pro Side Dock (40AH) with T480

Taking a guess but the issue could be that the P52s and T480 both only support 1 DisplayPort output over Thunderbolt. The X1 carbon may support 2x DisplayPorts. In that case, the Ultra dock would be the better option as (I think) it has a built-in MST hub.
Lucas_Barton
Paper Tape
Posts: 6
Registered: ‎06-14-2018
Location: US
Views: 6,834
Message 6 of 10

Re: Dual Monitors (DisplayPort) not working on Pro Side Dock (40AH) with T480

Edit: 1 DisplayPort output at 1440p native. Just saw your comment about 2x 1080p native screens working fine.

ChristopherF2
Paper Tape
Posts: 4
Registered: ‎06-21-2018
Location: US
Views: 6,833
Message 7 of 10

Re: Dual Monitors (DisplayPort) not working on Pro Side Dock (40AH) with T480

I can use both display ports if I plug in 2 1080p screens though. And their fact sheet for this dock says it can do up to 2 4k displays at 30 hz.

Lucas_Barton
Paper Tape
Posts: 6
Registered: ‎06-14-2018
Location: US
Views: 6,827
Message 8 of 10

Re: Dual Monitors (DisplayPort) not working on Pro Side Dock (40AH) with T480

Right, it can do 4k 30hz x2 on a laptop with a full 4x Thunderbolt implementation like X1 Carbon. The T480 and P52s only have partial 2x Thunderbolt implementation and I think that's what is hampering us here. Would love if someone else could confirm this.

ChristopherF2
Paper Tape
Posts: 4
Registered: ‎06-21-2018
Location: US
Views: 6,822
Message 9 of 10

Re: Dual Monitors (DisplayPort) not working on Pro Side Dock (40AH) with T480

Ahh, I am following now. Really frustrating though because on my hp slimdock 2013 I had zero problems with using these screens. Benefits of dedicated docking port I guess.

Lucas_Barton
Paper Tape
Posts: 6
Registered: ‎06-14-2018
Location: US
Views: 6,778
Message 10 of 10

Re: Dual Monitors (DisplayPort) not working on Pro Side Dock (40AH) with T480

So, I tried a Thunderbolt 3 Thinkpad dock with my T480 laptop instead of that Pro dock, and it works fine with both WQHD 1440p monitors and the laptop screen open simultaneously. So, it seems to be some sort of limitation with just the Pro dock. I think you'll have better luck with returning the Pro dock and getting a TB3 dock (40AC) instead, or you could even try the Ultra dock (40AJ) if you prefer the side connect docking style.

Check out current deals!


Shop current deals

Top Kudoed Authors