cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
nevetssf
Punch Card
Posts: 21
Registered: ‎10-13-2015
Location: US
Views: 1,617
Message 1 of 9

Fibocom L850-GL on T480 - "Windows has stopped this device..."

I have a T480 with a Fibocom L850-GL WAN card. Frequently, but all the time, when waking up from sleep, it fails to appear in my Wireless options, and when I look at it in the device manager, under Device status Windows gives the message "Windows has stopped this device because it has reported problems. (Code 43)"

 

I see others have had some problems with this card, but I haven't found this specific issue.

 

I've installed the latest drivers as of today (2018-07-28) but I'm still having this problem. If I manually disable and re-enable the device it always comes back, but it's pretty annoying to have to do that. 

 

Before I contact Lenovo for repair (the laptop is only a couple of weeks old) I wanted to check the forum for any ideas.

 

Thanks!

 

 

sclexman
Bit Torrent
Posts: 4,580
Registered: ‎11-22-2011
Location: US
Views: 1,585
Message 2 of 9

Re: Fibocom L850-GL on T480 - "Windows has stopped this device..."

Microsoft pushed out win 1803 updates this week.

Lenovo shows new drivers for your device this week.

1803 july 25.PNGfibocom.PNG

 

 I would try the support page driver, with readme stating fix firmware update failure issue.

nevetssf
Punch Card
Posts: 21
Registered: ‎10-13-2015
Location: US
Views: 1,564
Message 3 of 9

Re: Fibocom L850-GL on T480 - "Windows has stopped this device..."

Thanks. Unfortunately, the problem persists but in a slightly different way - when waking up from sleep, the Fibocom L850-GL now disappears from the Device Manager. I've tried un-installing and re-installing it, but to no avail.

 

I'll contact Lenovo. 

 

Thanks!

Twang1337
Serial Port
Posts: 60
Registered: ‎06-19-2018
Location: AU
Views: 1,546
Message 4 of 9

Re: Fibocom L850-GL on T480 - "Windows has stopped this device..."

What was the outcome from lenovo? Have a look at X1 forums. Buckets of problems with Fibocom L850-GL.

no servicer error/vanishing/insert sim error

 

nevetssf
Punch Card
Posts: 21
Registered: ‎10-13-2015
Location: US
Views: 1,539
Message 5 of 9

Re: Fibocom L850-GL on T480 - "Windows has stopped this device..."

No answer from Lenovo yet, I just submitted a warranty service request this morning.
nevetssf
Punch Card
Posts: 21
Registered: ‎10-13-2015
Location: US
Views: 1,507
Message 6 of 9

Re: Fibocom L850-GL on T480 - "Windows has stopped this device..."

I finally called Lenovo after not hearing from them for 2 days (rebooting the machine every time I want to use LTE is driving me crazy). The short version is that they've been no help so far, and I'm supposed to get a call from a service technician. 

 

The hardware department did transfer me to the software department, which refused to speak to me until I paid them an additional fee to fix "the configuration", which I told them was outrageous and declined to do. 

 

I think their engineering team needs to fix it and I have no idea how to contact them. From past experience with other LTE modems on Lenovo systems, they'll release a series of patches until finally the issue gets fixed. Still, I am surprised how unhelpful their service has been so far. Not a great experience so far. 

jfranche825
Fanfold Paper
Posts: 8
Registered: ‎11-25-2015
Location: US
Views: 1,183
Message 7 of 9

Re: Fibocom L850-GL on T480 - "Windows has stopped this device..."

Almost three months later? Has updated drivers helped or did Lenovo support get back to you?

nevetssf
Punch Card
Posts: 21
Registered: ‎10-13-2015
Location: US
Views: 1,174
Message 8 of 9

Re: Fibocom L850-GL on T480 - "Windows has stopped this device..."

Actually, yes. Lenovo issued a series of patches and now the modem works very well. It connects quickly and wakes from sleep without any issues.

 

Now I just have occasional screen flicker to deal with :-) 

nevetssf
Punch Card
Posts: 21
Registered: ‎10-13-2015
Location: US
Views: 743
Message 9 of 9

Re: Fibocom L850-GL on T480 - "Windows has stopped this device..."

Perhaps I concluded too quickly that everything is working.

The card does connect to LTE reliably now, even after waking from sleep, but I'm getting BSOD's every few days, PAGE_FAULT_IN_NONPAGED_AREA, What Failed: NetAdapterCx.sys

This seems to be LTE-related. I saw in another thread that others are having similar problems.

Check out current deals!


Shop current deals

Top Kudoed Authors