cancel
Showing results for 
Search instead for 
Did you mean: 
Lenovo Staff
Views: 702,462

On Windows 7, 8, and 8.1, ThinkPad T/W/X systems use fingerprint software.  T440 and later models use Lenovo Fingerprint Manager Pro.  This software was needed because those versions of Windows did not natively support fingerprint readers.

 

Starting with Windows 10, Microsoft has added full support for fingerprint readers into the operating system.  You only need a driver.  The fingerprint software is no longer needed, and should be uninstalled prior to upgrading to Windows 10.  The purpose of this guide is to help you upgrade your Win7/Win8/Win8.1 system to Windows 10, so that you can successfully continue using your fingerprint reader.

 

Before upgrading to Windows 10, you need to make sure you know your Windows password.  Whether you have fingerprints enrolled or not, the Windows 10 upgrade process will ask you for your Windows password, so you must know it.

 

Below are the steps I took to successfully upgrade a T450 system running Windows 7.  My system has 2 fingers enrolled, and I also have preboot authentication where I use my fingerprint to enter the BIOS Power-On password.

 

  1. Open Control Panel -> Programs -> Uninstall a Program.  Scroll down to Lenovo Fingerprint Manager Pro and then click on "Uninstall/Change".
  2. Click "Yes" at the prompt about "Are you sure...?"
  3. When the uninstallation finishes, click on "Finish" to restart the computer as prompted.
  4. After the reboot, log into Windows using your Windows password.
  5. Upgrade to Windows 10
  6. After the upgrade, open Device Manager (type Device Manager into the search bar)
  7. Expand the category for “Biometric devices”
  8. Double-click on the fingerprint device. On my system, it’s called “Synaptics FP Sensors (WBF) (PID=0017)
  9. Click on the “Driver” tab
  10. Click on the “Update Driver…” button
  11. Choose the option for “Search automatically for updated driver software…”
  12. You should see a message like “Windows has successfully updated your driver software”. Click on “Close”
  13. Back on the “Driver” tab, confirm that the Driver Version is now 4.5.308.0 or later. This is the latest version of the driver as of July 31, 2015
  14. Click on “Close”, and then close Device Manager.
  15. The next step is to enroll fingerprints in Windows 10, to do this, we use the new Windows 10 feature called “Windows Hello”. To get to it, open Settings -> Accounts -> Sign-in options
  16. To use Windows Hello, Microsoft requires that you first set a PIN. Under the PIN section, click on the Add button to create a PIN.  Follow the on-screen prompts to create your PIN.
  17. Under the Windows Hello section, find the fingerprint item and click on the “Set up” button. Follow the on-screen prompts to enroll your finger.  Enroll more fingers if you want to.
  18. Windows 7 only: You might see a problem where the “Set up” button is greyed out, and you can’t click on it.  You might also see red text at the top of the Sign-in options windows that says “Some settings are managed by your organization”.  As of July 31, 2015, this is a bug that we are working with Microsoft to solve.  You can manually fix it yourself by modifying the registry.  Download the attached .reg file, double-click it, and then click on “Yes” to confirm that you want to modify the registry.  Reboot the PC and then go back to step 17.

 

Any questions or comments, please leave them here.  I hope this was helpful.  Thanks for reading!

 

NOTE ABOUT T430 AND EARLIER:

These systems (with Authentec fingerprint readers) use ThinkVantage Fingerprint Software which is still needed on Windows 10.  It can be downloaded here:  http://support.lenovo.com/us/en/downloads/ds036923

 

Was this information helpful?

Comments
dmsanz

It worked for me on my Thinkpad x240, thank you.

 

I just installed Windows 10 (fresh install) and didn't need to install Lenovo Fingerprint Manager. It was enough with the driver 4.5.308.0 that Windows was able to find through Device manager

carodri2

Do you still have power-on by fingerprint support after the upgrade to Windows 10 and using Windows Hello? Since I enrolled in Windows Hello after the Windows 10 upgrade, I cannot power on my T520 with my fingerprint, although I can logon with it. (I was able to power on my machine after the upgrade before enrolling in Hello.)

Unfortunately, T430 and older (like your T520) will not support power-on by fingerprint in Windows 10 when using Windows Hello.  The supplier of that fingerprint sensor, Authentec, no longer exists.  So it was not possible to make the driver changes needed for Windows Hello support in Windows 10.  You might be able to keep using ThinkVantage Fingerprint software in Windows 10 if it's more important to you to keep the power-on feature.  I haven't personally tried it.  If you can't get it working, let me know and I will see if I can write a similar guide just for these older systems with the Authentec fingerprint reader.

carodri2

Thanks for you prompt response! I tried to disable Windows Hello (by removing the PIN and fingerprints), but it appears that once it senses that there are fingerprints registered with the TP Fingerprint Software (v 6.0), it re-enrolls them in Windows Hello and it doesn't allow me to power-on the machine with the fingerprint. Do you have any suggestions on how to have it work the same way it did in Windows 8.1 (one swipe for both power-on and sign-in)? A guide for the Authentec fingerprint reader and Windows 10 would be awesome.

 

Incidentally, I also tried a system restore -- that didn't work either, :-(.

Skoop

What's the relationship between a driver of any particular version and the PID number?  Looking around, I can find the 308 driver for both pid=0017 (mine) and at least one other, pid=0011. 

 

Are the drivers interchangeable, or pid-specific?

For the laptop systems with Synaptics fingerprint, it is the same driver for all the different PIDs.

For Windows 10 on a system with Authentec Fingerprint (like ThinkPad T430), I got everything working (including power-on) by installing ThinkVantage Fingerprint Software version 6.0:  http://support.lenovo.com/us/en/downloads/ds036923

 

Then, only use ThinkVantage Fingerprint Software to enroll fingerprints.  Do not use Windows Hello to enroll fingerprints.  Remove any existing fingerprints that might be enrolled in Windows Hello.

tangoo

Deleted by author

tangoo,

 

For ThinkPads T430 and older, ThinkVantage Fingerprint Software 6.0 is all you need.  It includes the driver that works on Win10.  No need for anything else.

 

http://support.lenovo.com/us/en/downloads/ds036923

tangoo

Deleted by author

carodri2

I have reinstalled the TFP software and reenrolled the fingerprints to no avail. The interesting thing is that before I reinstalled, I was able to power on the machine from fingerprint in Windows 10 two or three times at random, all times after the laptop had not been used for hours.

 

On the device manager, the Biometric devices entry reads "TouchChip Fingerprint Coprocessor (WBF advanced mode). Is this the correct device/driver (version 1.6.2.352, 2/27/2013)?

kokmeng

Well, I only managed to finish up-till step 14. I have problem locating "Windows Hello" in step 15. When I activate "Windows Hello" manually as advised by WindowsCentral Forum, I got this error. 

 

Capture.PNG

 

How can I restore back the Fingerprint support in Windows 10? Please help. 

kokmeng

 

What system are you using?  If it's T430 or earlier, you need to use ThinkVantage Fingerprint Software.  The link is in my earlier comment, 3 above yours.  Also I have no idea what you are trying to do in your screenshot.

kokmeng
Hi, Model: T440P Current OS: Windows 10 Pro Prev. OS: OS: Windows 7 Pro 64 preinstalled through downgrade rights in Windows 8.1 Pro I was trying to follow the steps to make my Fingerprint working again in Windows 10. The problem is I could'nt find Windows Hello in my Windows 10. Should I follow to use T430's Fingerprint Software? Thanks.

kokmeng

 

You don't need any fingerprint software.  To enroll fingerprints, look at steps 15-17 again.  If you still need help, post a screenshot of what you see at those steps.

overlind

I too was fighting with my fingerprint reader after my upgrade from Windows 7 to 10.  I have a Thinkpad W700 with an Authentec AES2810 reader.  I think my computer would fall into the "Note about T430 and Earlier" section, but the ThinkVantage Fingerprint Software would not detect my Authentic reader.  What worked for me was to uninstall all of the Lenovo software that I had from Windows 7 as the initial steps (1-5) indicate.  In place of steps 6-14 (because Microsoft does not include the Authentec driver), install the Authentec WBF driver package from the link below on Dell's website.  It does not have anything inside it that is branded just for Dell machines.... just the Authentec WBF compatible driver.

 

http://www.dell.com/support/home/us/en/19/Drivers/DriversDetails?driverId=DFDJ9

 

After that, continue with steps 15-17 to set up Windows Hello to enable fingerprint based logins to Windows 10.

 

My initial issues on all this was to get LastPass fingerprint scanning to work again.  As best I can understand, it accesses the fingerprint reader through the Windows Biometric Framework.  This driver allowed not only Windows to work with the fingerprint reader as Microsoft intended, but got LastPass working too.

overlind

 

The "Note about T430 and earlier" really should have said "T430, T420, and T410".  T400 (and your W700) uses an even older sensor that wasn't supported even on Windows 8 or 8.1.  What you did is the way to get it working in Windows 10, although I think preboot authentication for BIOS passwords probably doesn't work.

tangoo
I'm sorry someotherguy but I have to step back in here. Of course the "older sensor" was supported in Windows 8.1 and Windows 8.0. Just to be clear, I have owned (or worked with during my time as an IBM employee) nearly every Thinkpad ever made beginning with the 700 series. The fingerprint reader on EVERY T4xx works in Windows 10, Including power-on and hard drive passwords. It is not an 18 step process, it takes only 3 steps. I know this post will step on your toes someotherguy, but these are the facts. If anyone wants to know how to make the fingerprint reader work for ANY T4xx with the power-on, hard drive, and login passwords - in 3 steps - let me know. Maybe I'll even test it out on my old T60, or T41, or T43...
kokmeng

Oh please tangoo. I already have my FIngerprint Manager Pro uninstalled. 

 

What should I do next? I just need to restore my Fingerprint support!

 

By the way, why is the "Set up" button grey off? 

 

Capture.PNG

ibrahimov

Hi someotherguy,

 

Thanks for posting the guide. I have Lenovo X240, and I did a fresh install of Windows 10 Pro x64.

 

Per this guide, I did not install the Fingerprint Manager Pro, since I have Synaptics Fingerprint device.

 

In  Windows 8.1, and the respective option enabled in Fingerprint Manager Pro, I could do a single swipe after turning on the laptop, and it will log me on both through BIOS password and Windows password as well. This is not working in Windows 10. Is there a way to make it work? Do I have to install Fingerprint Manager Pro to get it working like this?

 

Thank you.

ibrahimov

 

The single sign-on feature works on Win10 when you use driver version  4.5.308.0 or later.  You definitely don't need/want Lenovo Fingerprint Manager Pro on Windows 10.

 

If you have this version of driver already , and it's not working, then my next suggestion is to clear the fingerprint data in BIOS:

 

1.  Reboot

2.  Press F1 to enter BIOS Setup

3.  Change to the Security page, and then select the Fingerprint item

4.  Choose the option to Reset Fingerprint Data, and then wait for it to finish

5.  Press F10 to save/exit and reboot to Windows

6.  Delete your fingerprints and try enrolling again, from the Settings -> Accounts -> Sign-in Options screen

ibrahimov

Thanks 

tangoo

If you have the TouchChip Fingerprint Coprocessor (WBF advadvanced mode) driver version 1.6.2.352 will work in Windows 10.

 

Uninstall any Lenovo fingerprint reader software currently installed and reboot. Use driver update in computer management to change the TouchChip Fingerprint Coprocessor (WBF advadvanced mode) to version 1.6.2.352 and reboot. Install g1f914ww_64.exe and reboot (I say reboot after every step just to be sure).

 

Set a user account pin in Windows 10 (settings->accounts->Sign-in options) and delete any fingerprints you set up in Windows 10. You must set a pin or Windows 10 login will fail regardless of whether you are using the built-in Windows 10 reader or the Lenovo software.

 

In the ThinkVantage Fingerprint software click "Use fingerprint scan instead of power-on and hard rive passwords" and "Use fingerprint scan instead of power-on button" . If you don't see these options your bios doesn't support it. It takes two reboots to start working.

 

Here's a link to the driver and the Lenovo fingerprint reader software:

https://drive.google.com/file/d/0B82mESIUbcoCN2VOZEo5aFNPNWc/view?usp=sharing

 

And to answer your question kokmeng fingerprint is greyed out because you haven't set a pin. You must set a pin to use the built-in Windows 10 reader - or the Lenovo reader. Repeat - you must set a pin to use any print reader, period.

 

jl11

It does not work on my T450s under Windows 10, even though the drivers "Synaptics FP Sensors (WBF) (PID=0017)" are installed correctly. I can get into the Windows Hello Fingerprint Setup (snapshot below) but the FP reader doesn't do anything.

Since the notebook is brandnew I didn't have Win 7 or 8 on it before for testing the FP reader, but the driver installed without any issues -- so it's maybe not a hardware problem.

Any suggestion?

 

devices_snapshot.PNG

 

WinHelloSetup.PNG

kokmeng

Thakns Tango. Just checked and I do have a PIN but yet the the "Set up" button is grey off. 

 

Any other suggestion? Without this button enable I cannot test further. 

 

Pin.PNG

kokmeng,

 

Do you see red text at the top of the Sign-in options window that says “Some settings are managed by your organization”?  If so, please read step 18 in the original article.

kokmeng

Thanks someotherguy but I am on Windows 10 now. Can I still use the same .reg file? 

 

tangoo
Deleted by author
kokmeng

So, nobody can help?

My questions remain open & sequence of activities as follow:

1. I have uninstalled Lenovo Fingerprint Pro Manager by following the step 1-4 as adviced by this article
2. Upgrade to Windows 10 as normal without hitting any problem
3. Biometric devices driver updated to 4.5.308.0
4. Personal PIN setup as per step 15-16
5. The "Set up" button for Windows Hello is grey off

So, question is how to fix this? I have tried step 18 but nothing change. Windows Hello "Set up" button remained grey off. I also notice that the .reg file is only for Windows 7 as stated in this article?

I am desparately need help here!

mavang

You use the Easy Driver Pack software version 6.5 to get device for Windows 10 or  all the equipment for the Windows operating system, download at: http://micombank.com/phanmemDetail.aspx?idsw=81

Emeric

Tangoo,

 

I have a Thinkpad T520 bought in 2011/07.

I follow all your steps but the fingerprint don't works to start the laptop... Fingerprint light is green, but nothing hapens when i try tu use it...

I have the good finger print driver 1.6.2.352 (i don't have to uprgrade it, it was ok)

I have the good fingerprint software g1f914ww_64.exe

I created a pin in windows 10, and deleted 

I install the software and in the settings tag, "Use fingerprint scan instead of power-on and hard rive passwords" and "Use fingerprint scan instead of power-on button" are already selected.

Before, all was ok with windows 8.1... When i upgraded with win 10, the fngerprint was ok to start the PC, but I had to use it first to start and after to login. It why i unstalled the software... Since, impossible to star the PC with the finger print. 

Thank your for any help

 

Emeric

This morning.... it works...

I don't know why, but all is ok now. 

Thank you to evrybody on this  forum !

carodri2

I have noticed that the fingerprint power-on in my T520 works sometimes in Windows 10 (my driver version is1.6.2.352). If I'm able to power-on the laptop with my fingerprint, the next time I need to power-on my machine (after a shutdown) the power-on fingerprint support will not work (the sensor stays green and does not recognize my finger), and I'd have to wait until the logon screen to scan my finger (I would get a Windows Hello message then). If I shutdown afterwards, it is very likely that the power-on finger scanning will work the next time, but it is not always the case. Something is not right within Windows 10.

mullinsmf

Hello  tangoo,

 

I have a Thinkpad T400 PN 6475AT3.

Please send me the steps for setting up the Fingerprint Reader in Windows 10.

I wasn't able to find a way to send you a direct message.

 

Thank You,

Moses

sdjokic

hi..

did anybody faced the serious issue i did on my t440s?..

i was using password and fingerprint logon options on  8.1..besides that i had a smart card option as well..so, credential providers smartcard, password and fingerprint were active..

i've upgraded from 8.1 to 10 ( while fingerprint pro was installed )..and after that there were just smarcard and fingerprint..

no password option for login at all..i've used fingerprint..after tons of posts and forums i've found out this info about uninstalling fingerprint pro prior upgrading to win10..since i didn't, a i made a mistake and removed fingerprint from win10 since i was hoping it would offer me password..after reboot i didn't have option to login neither with fingerprint or password, just smartcard which i don't have..so, i needed to revert to 8.1 from safe mode..so, after that i've uninstalled fingerprint pro and did the upgrade again..the some thing happend..i'm back on 8.1..

 

so, i cannot upgrade to win10 since i cannot have option to login using password and i don't want to rely on fingerprint..

does anybody have an idea what happens with credentials provider in this upgrade and how to solve it..

 

thanx..

 

regards..

fakhrulhilal

I used to enroll my fingerprint using Lenovo Fingerprint Manager Pro rather than builtin windows feature. Because it can enroll my fingerprint for my BIOS supervisor password also. When I upgraded to windows 10, without clearing fingerprint data in BIOS, I still can use it. But now, I can't use my fingerprint to configure my BIOS (as replacement for supervisor password) after resetting fingerprint data. 

I can't install Lenovo Fingerprint Manager Pro again due to incompatibility for windows 10. How can I solve this?

Emeric
Hello, I just bought a Thinkpad X250. I follow the instruction below for windows 10 (windows hello and power-on password) Fingerprint works fine, but only after push start button. With my T520, i can start the computer with finger print. Any idea if it's possible? Thank you
ibrahimov

Emeric, "turn on with fingerprint" is not supported in ThinkPad models with Validity fingerprint sensor - see this forum thread.

Emeric
Ok, my english is poor so thank you for your help. However, the X250 is not for me. I think i going to upgrade my T520, or buy a T530 I7 to have this fonction...
WildGustav

Power On Fingerprint issues on Lenovo X201 Tablet (Type 3113-WE8) Windows 7 64Bit Upgraded to Windows 10 Professional 64Bit via Taskbar icon.

 

This post gives some background information which could help you fix intermittent power on by fingerprint problems.

 

Win10 upgrade went smoothly but Win10 got stuck at last "Let's start" screen with a buzz from the speakers (Keyboard Volume control varied buzz - Ethernet port lights constantly flashing) - still stuck after an hour of no progress at same screen (also still buzzing) so rebooted then Win10 was up and running as an upgrade installation but had to manually set date format and language localizations - will clean install Win10 in a couple of months - this was just to secure the free Win10 licence with free DVD playback application.

 

Found that Win 10 will happily talk to AuthenTec fingerprint reader using the carried over Win7 fingerprint reader driver ver1.6.2.352 but that alone will not get power on by fingerprint working.

 

Therefore yesterday installed Thinkvantage Fingerprint Software for 64Bit Windows 8.1 (g1f914ww_64.exe) resulting in version 6.0.0.8102 installed on Windows 10 Pro 64Bit.

 

Had already cleared BiOS of fingerprints and removed Lenovo software for fingerprints and the rest of the Lenovo software that Lenovo tells you to remove from Win7 BEFORE upgrading to Win10.

 

Ran Norton Removal Tool on Win7 before upgrade to Win10 - Interestingly Norton Removal Tool knocked out the fingerprint reader driver under Win7 so used Control Panel Device Manager to uninstall driver which prompted an automatic reinstall of the driver a further reboot and Win7 fingerprint power on and log in was back to normal - had NOT yet uninstalled Lenovo fingerprint software at that point - am pretty sure NRT knocked out the fingerprint reader once before on Win7 a couple of years ago.

 

Absolutely could not get power on by fingerprint working yesterday using the earlier info in this post - still not working this morning - deleted Norton 360 directories and files to stop the already removed Norton nagging to reinstall and switched off - tried my fingerprint again to power on and it suddenly worked for the first time ever meaning Power On and then Win10 logon with just one swipe of the finger! Hurrah! (Incredibly the reinstall Norton nagging still continued after the manual Norton directory deletions!)

 

Yesterday I found that I could alter the behaviour of the fingerprint reader by switching off its lights from within Win10 so instead of showing a unresponsive steady green LED when the laptop was powered off there would be no lights at all on the fingerprint reader - also ticked the remaining checkbox to always show power options in Lenovo Fingerprint reader software but none of that made fingerprint power on happen.

 

Today eight or nine times in a row total success switching off then powering on and logging in to Win10 with just a fingerprint Heart- then all of a sudden no Power On by Fingerprint $*&£! Robot Mad- Power on by pressing power then log in to Win10 by fingerprint still continues to work.

 

What changed?

 

I unplugged Ethernet internet connection used during Win10 upgrade and went back to Wi-Fi AND Turned off Bluetooth both ways via "Fn" + "F5" and via Win10 settings one of those ways did not cause the Bluetooth light to go out on the ThinkPad which could be significant? AND tried out the pen to write onscreen also using the screen rotation buttons while converting into a Tablet BUT what seemed to get it working again was getting the Bluetooth light to go out and suddenly Power on by Fingerprint once again works! Now Bluetooth has turned itself back on!

 

Is this a conflict between the (USB?) bus the fingerprint reader, indicator lights, screen rotation buttons etc or a software conflict involving Norton? Or is this just the usual problems from NOT doing a clean Windows installation but an Upgrade instead - this laptop still plays Win7 boot tones while booting Win10 - I thought Win10 was meant to boot in silence? Does joining or leaving wired/wireless networks trigger the problem?

 

Only other point is that the Wireless Radios physical switch on the side of the X201 Tablet was set to the OFF position - which disables both Wi-Fi & Bluetooth Radios - until I unplugged Ethernet and connected to Wi-Fi - does the physical Wireless Radio switch affect Power On by Fingerprint behaviour?

 

It’s a long post but the power on by fingerprint intermittent glitch is triggered and then solved by one of the things I listed doing.

 

WildGustav

Update - Installing four more fingerprints knocked out fingerprint power on yet again but Win 10 logon still fine - Fingerprint Power on then started working again the next day.

 

Thought everything was finally settled then a random refusal to power on by fingerprint happened again - do not know what triggered that one - but overall my Lenovo Thinkpad X201T is currently Powering on and logging in to Win 10 with a single fingerprint read.

 

Lenovo should write newer dedicated 64-Bit Windows 10 drivers NOT for the AuthenTec fingerprint reader but instead the Bluetooth, Wi-Fi, tablet screen buttons etc. (the things I mentioned in my previous post) as it seems to be something in those areas that is tripping up the previously 100% reliable power on by fingerprint.

 

How about a BiOS and ECP (Embedded Controller Program) update from Lenovo for Windows 10 - after all the last X201T BiOS & ECP update was 21 June 2013 to BiOS version 1.40 with ECP 1.15

sfpincchicago

I'm running Win10 w/Lenovo E550.  My fingerprint reader has been working just fine up until this morning, when it just suddenly stopped sensing a print.  I can go into setup a fingerprint and get stuck on the "swipe your finger" because it just will not sense a finger.  Not on lock screen, not on setup, nowhere.

ibrahimov

sfpincchicago, I had a similar issue several times. Deleting the fingerprint device from Device Manager, and restarting the laptop seemed to help.

sfpincchicago

Delete the fingerprint device?  As in the actual reader part you swipe your finger?

ibrahimov

sfpincchicago, I mean deleting it in the Device Manager in Windows (Win + R -> devmgmt.msc).

In my case, the device name is 'Synaptics FP Sensors (WBF) (PID=0017)', it is under Biometric Devices section.

Once you delete it and reboot, it will get reinitialized. In my case, it helped to get it back working.

sfpincchicago

I'll give it a shot and report back.   Win10 is such a pain.

sfpincchicago

As it turns out, I went in and updated the software, then locked my computer and scanned with my finger and it once again recognised my input.

ibrahimov

Good news sfpincchicago! I think the software update essentially did the same thing - the device was reinitialized and started working.

sfpincchicago

Most likely.  Odd, though, that it happens.  More evidence Win10 is a pain.

tripplec

Hmm a lot of situations here. Well I did upgrade my T520 to Windows 10 64bit lastest version and everything worked including starting from, logging in via the finger print scan. I went to download Lenovo Settings from the Windows store and had to create a windows account for authention. Once set and password entered via that process. My finger print no longer logs me in. I went through the Windows 10 process and created the mandatory PIN # for login it requires. Scanned my finger after but is said, finger is already scanned. Yes not suprising. I am not sure how to associate my finger to the login. The login screen has two options shown on the left. For PIN login or below Finger print scan starting with Vista (as series of numbers). Clicking the later does nothing and only the pin # gets me in now.

 

All because I created a Microsoft account.

Contributors