cancel
Showing results for 
Search instead for 
Did you mean: 
Lenovo Staff
Views: 865

Question

I have a power on password as well as a HDD password set up on my T420. I then upgraded the firmware on the drive which was an OCZ SSD.

 

I had upgraded my hard drive to SSD and placed a password on both the User and HDD via BIOS. Everything worked fine.

 

Recently, I upgraded the firmware on the drive and restarted, but the User password was automatically entered since it was a reboot but the HDD password showed a "Stop" symbol. It denied my old password three times and the system restarted.

 

I pulled the drive out and plugged it into a USB dock connected to my desktop and was able to back up all my files off it. I then formatted the drive and plugged it back into the T420 and still got the password prompt.

 

I have tried taking out the HDD, resetting to default, making sure the passwords were cleared. Only the User password field was available to clear, and there was no section for the HDD. 

 

I plugged HDD back in and got only the HDD password prompt.

 

Answer

The password is stored in an inaccessible part of the drive. The password is supported as a feature of the firmware. Thus a firmware flash could render the password inoperable. Only a hard drive chipset supported "Secure Erase" will reset it. 

 

To read more, click on http://tinyapps.org/docs/wipe_drives_hdparm.html

 

You can use a live boot Linux and follow the instructions for a Secure Erase. Note that all of your data will be erased as a result so be careful. 

Was this information helpful?