cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
microwu
Fanfold Paper
Posts: 3
Location: USA
Views: 3,320
Message 1 of 7

How to make Bluetooth default on every time T500 boots

Hi everyone,

 

I am a new T500 2081 user.  I did a Windows 7 pro x64 clean install and was able to install all the ThinkVantage software including the hotkey driver, so I can use Fn+F5 to activate the Bluetooth.  The problem is everytime I restart my T500 the Bluetooth is off by default.  I have to press Fn+F5 to activate it again and again.  I am getting a Thinkpad Bluetooth laser mouse and it will be a pain if I have to activate my mouse every time the computer is restarted. 

When I boot my computer in Ubuntu 9.10 on another partition of the hard drive the Bluetooth is always on, so I guess the issue in Windows 7 is a software setting one.  Any idea how to fix it?  Thank you!!!

microwu
Fanfold Paper
Posts: 3
Location: USA
Views: 3,233
Message 2 of 7

Re: How to make Bluetooth default on every time T500 boots

Does anyone have the same problem?

 

I found this description at http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-57107#notturnon, answer to question #2: "Whenever you start the computer or resume operation after it has been in standby or hibernation mode, you must turn on the Bluetooth features."

 

Does that mean you just always have to press Fn+F5 everytime?

Retired Guru
Posts: 372
Location: US
Views: 3,225
Message 3 of 7

Re: How to make Bluetooth default on every time T500 boots

 


@microwu wrote:

Does anyone have the same problem?

 

I found this description at http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-57107#notturnon, answer to question #2: "Whenever you start the computer or resume operation after it has been in standby or hibernation mode, you must turn on the Bluetooth features."

 

Does that mean you just always have to press Fn+F5 everytime?


 

This information is quite old and most likely not valid for newer systems.   Bluetooth should remain on as long as it was enabled during the last boot and the radio hasn't been shut off..  That being said I would look in your power profile and make sure the system isn't shutting down the bluetooth radio when there are no devices connected.  (or after sleep).  This would make you have to turn it on every time. 

 

Also I would check the bluetooth settings and make sure there aren't any settings which leave it shutoff by default, this could also be considered a possible security feature. 

 

Sorry I don't have any more complete information to offer since my thinkpad didn't come with bluetooth... I wanted the turbo drive Smiley Happy

 

Thinkpad T500-2081 CTO | T9400 2.53GHz | 8 GB RAM | ATI HD3650 + Intel GM45 | 15.4" LED WXGA+ | Windows 10 | ATI Catalyst 13.1 (non-switchable)
Thinkpad 390x | PII 333 | 256mb ram | NeoMagic 256AV | SVGA LCD | OS/2 v4.52
wsko
Fanfold Paper
Posts: 13
Location: USA
Views: 3,180
Message 4 of 7

Re: How to make Bluetooth default on every time T500 boots

Hi,

 

I have the same problem on my T61 with Windows 7 x64 and I am alo looking for a solution too. 

 

This problem didn't show up until several months ago, after some updates from Lenovo.  I actually have been running Windows 7 x64 RTM from MSDN since August 2009.  At that time, Lenovo didn't release any of the Windows 7 drivers yet, so I forced the system to use Windows Vista drivers.  Everything worked fine, Bluetooth stayed on after standby or hibernation with Vista drivers on Windows 7.  Then, I saw that Lenovo released the Windows 7 drivers and tools several months ago, so I updated them.  And that's when Bluetooth stopped staying on after standby or hibernate.  I suspect it's either the current drivers or some Lenovo tools on Windows 7 defaulting Bluetooth to stay "off" after standby or hibernation.

 

I also have a bluetooth mouse, docking station with external monitor. It's very annoying that I have to open up my laptop screen to turn on bluetooth with Fn+F5.

 

I have had my T61 and bluetooth mouse for 2.5 years now.  I didn't have this problem until the recent updates from Lenovo.  Lenovo, please look into this and fix the bug.

 

Thanks

microwu
Fanfold Paper
Posts: 3
Location: USA
Views: 3,135
Message 5 of 7

Re: How to make Bluetooth default on every time T500 boots

Hi sys3175,

Thanks for replying but there doesn't seem like any setting in the power management tools from both win 7 and lenovo that we can change to prevent bluetooth from shutting down during standby or hibernation.  Like wsko said it was not an issue before. Seems like a driver problem...  I'm curious how other users are doing with win 7 + bluetooth.

jaybhai
What's DOS?
Posts: 1
Location: Santa Clara, CA
Views: 2,788
Message 6 of 7

Re: How to make Bluetooth default on every time T500 boots

This is also a problem with my x200t, so definitely sounds like a lenovo drive issue.  Still can't find any solution to this or even a workaround.

 

Please message me if you have found something that works.  It's freakin' annoying to enable bluetooth every time my machines comes out of sleep.

 

I expect better from Lenovo.

vmikalinis
Fanfold Paper
Posts: 3
Location: Florida
Views: 2,587
Message 7 of 7

Re: How to make Bluetooth default on every time T500 boots

Ive noticed the same thing on my new T510 with all of the latest updates.

Top Kudoed Authors