Showing results for 
Search instead for 
Do you mean 
Reply
Bit Torrent
Posts: 2,238
Registered: ‎03-08-2012
Location: CA
Message 11 of 37 (417 Views)

Re: Huge slowdown on T520 after updating through TV System Upgrade

Hard you gone to drivers in Device manager and selected Roll Back?

T520 Model 4239 Intel(R) Core(TM) i7-2860QMbr>; Nvidia NVS 4200M Win 10 64bit
Z70-80 I7 - 5500U 16GB GB - 1TB HD Win 10 64bit FHD 17.3", G840 w/2GB

Punch Card
Posts: 16
Registered: ‎03-27-2012
Location: United States
Message 12 of 37 (415 Views)

Re: Huge slowdown on T520 after updating through TV System Upgrade

It doesn't give me the option to do so.
Bit Torrent
Posts: 2,238
Registered: ‎03-08-2012
Location: CA
Message 13 of 37 (387 Views)

Re: Huge slowdown on T520 after updating through TV System Upgrade

That would imply the driver did not get changed. You can check compare versions if yours is current.

T520 Model 4239 Intel(R) Core(TM) i7-2860QMbr>; Nvidia NVS 4200M Win 10 64bit
Z70-80 I7 - 5500U 16GB GB - 1TB HD Win 10 64bit FHD 17.3", G840 w/2GB

Guru
Posts: 9,240
Registered: ‎12-26-2009
Location: US
Message 14 of 37 (382 Views)

Re: Huge slowdown on T520 after updating through TV System Upgrade

[ Edited ]

This is probably normal. Because some binaries were updated, .NET Framework will use idle time to recompile them into faster code. You should notice a process or two called mscorsvw.exe that takes up CPU.

If you want to expedite this process, go to Start, Run,
C:\Windows\Microsoft.NET\Framework\v2.0.50727\ngen.exe executequeueditems

 

Also, if you have a platter drive, remember to defrag it after significant software changes on the system. Windows will try to do it every Wednesday at 1AM, but that's not always possible.

W520: 2960XM, Q2000M @ 1090/1362, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
Bit Torrent
Posts: 2,238
Registered: ‎03-08-2012
Location: CA
Message 15 of 37 (378 Views)

Re: Huge slowdown on T520 after updating through TV System Upgrade

ColonelONeill: Good to know its doing that but if has to wait for each Wed and the system is being used deferring the process it could be a long time completing. It would have been good to have a prompt appear asking if I wanted it to complete a systems update like that.
T520 Model 4239 Intel(R) Core(TM) i7-2860QMbr>; Nvidia NVS 4200M Win 10 64bit
Z70-80 I7 - 5500U 16GB GB - 1TB HD Win 10 64bit FHD 17.3", G840 w/2GB

Punch Card
Posts: 16
Registered: ‎03-27-2012
Location: United States
Message 16 of 37 (362 Views)

Re: Huge slowdown on T520 after updating through TV System Upgrade

I ran the .NET things and defragged -- it didn't make much of a difference. My computer's still running really hot, there's high DPC latency, etc. As for not being able to roll back the integrated graphics driver, I'd guess that's because I was never able to actually install a new driver, only uninstall the one that was there (and seemed to be causing problems).

Punch Card
Posts: 16
Registered: ‎03-27-2012
Location: United States
Message 17 of 37 (343 Views)

Re: Huge slowdown on T520 after updating through TV System Upgrade

I don't know if this helps at all: two times in a row, I tried running the Procmon (Process Monitor) tool, and each time, it opened the window, and as soon as it loaded I got a BSOD. The description for both of them was SYSTEM_SERVICE_EXCEPTION, and it's attributed to ntoskrnl.exe.
Punch Card
Posts: 16
Registered: ‎03-27-2012
Location: United States
Message 18 of 37 (320 Views)

Re: Huge slowdown on T520 after updating through TV System Upgrade

Any ideas?
Guru
Posts: 9,240
Registered: ‎12-26-2009
Location: US
Message 19 of 37 (312 Views)

Re: Huge slowdown on T520 after updating through TV System Upgrade

Try running a SFC /SCANNOW from the commandline. Maybe something got botched somewhere.
W520: 2960XM, Q2000M @ 1090/1362, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
Punch Card
Posts: 16
Registered: ‎03-27-2012
Location: United States
Message 20 of 37 (305 Views)

Re: Huge slowdown on T520 after updating through TV System Upgrade

I did one at the start of this, but did another one just in case: nothing. "Windows Resource Protection did not find any integrity violations."
Top Kudoed Authors