English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

14 Posts

12-19-2008

Michigan

27 Signins

171 Page Views

  • Posts: 14
  • Registered: ‎12-19-2008
  • Location: Michigan
  • Views: 171
  • Message 1 of 3

Intel 5300/5350 Intermittent Wifi Solution - Don't use WEP security!

2009-01-10, 21:17 PM

I recently purchased a Lenovo T400 with the Intel 5350 wireless card (same as the 5300 but with WiMax), and, like a lot of other people on this forum, I could not get the wifi to consistently work. I spent several frustrating days searching these forums and trying pretty much every solution offered (XP 32 bit, Vista 32 bit, Vista 64 bit, w/ & w/out Access Connections, w/ & w/out Intel software, Lenovo drivers vs. Intel drivers, etc.). However, in the end, the solution was totally unrelated.

 

What I found was that when I was using WEP security on my Linksys WRT54G router (v5 w/ the latest firmware) I could not get wifi to work consistently. In most cases it was hard to get it to work at all. In other cases it might work after a reboot for a few minutes, then stop working again. However, as soon as I either turned off security or changed it to WPA2-Personal, wifi worked like a charm.

 

I was originally thinking about returning the laptop, since no wifi makes it pretty much unusable. But, with this finding I think I will keep it. Since it is obviously a driver issue, I'm going to assume there will be a driver update in the near future to fix the problem.

 

Hope this helps some of you who are having the same problems!

Reply
Options

12 Posts

10-18-2008

USA

62 Signins

552 Page Views

  • Posts: 12
  • Registered: ‎10-18-2008
  • Location: USA
  • Views: 552
  • Message 2 of 3

Re: Intel 5300/5350 Intermittent Wifi Solution - Don't use WEP security!

2009-01-11, 4:52 AM

That is a fascinating solution to the intermittent mess the Intel cards can go into. Never would have thought secrurity and encryption would affect the performance.

 

For what it's worth, go into the properties of the wireless card in Device Manager. Go to the Advanced Tab. Set "Roaming Aggressiveness" slider to the lowest, "Power Managment" to lowest, and "Transmit Power" to highest. These were solutiosn that I've run across and fixed the problem for me (I have the regular 5300, hope you will get to use and enjoy WiMax).

Reply
Options

14 Posts

12-19-2008

Michigan

27 Signins

171 Page Views

  • Posts: 14
  • Registered: ‎12-19-2008
  • Location: Michigan
  • Views: 171
  • Message 3 of 3

Re: Intel 5300/5350 Intermittent Wifi Solution - Don't use WEP security!

2009-01-11, 6:55 AM

I tried basically everything I could find on this forum, which included the three items you mention. Also, I tried using my computer on two different wifi networks that were both setup using WEP security. In both cases, changing the security to WPA2-Personal or removing security alltogether fixed the problem. Also, in both cases I had my old laptop with me, a Dell Latitude D410, and it worked fine on both networks regardless of the security being used.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save