Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

25 Posts

11-13-2010

Russian Federation

24 Signins

101 Page Views

  • Posts: 25
  • Registered: ‎11-13-2010
  • Location: Russian Federation
  • Views: 101
  • Message 1 of 1

Intel WiFi/WiMAX 5150: HOTKEY doesn't work without Access Connections

2012-10-29, 11:40 AM

Our company has several T410i 2522-P38 notebooks with Intel 5150 WiFi/WiMAX cards, all still running XP. Recently I had to reinstall OS on one machine. There was a minor problem that Lenovo support site download page for this machine offers Intel WiMAX 6205 instead of 5150, but I have driver package stored. However, after installing OS, drivers and Lenovo packages I've found that in Fn+F5 window I see only Bluetooth adapter, WiFi and WiMAX don't appear, yet they are correctly shown in Device Manager and WiFi works (couldn't check WiMAX).

 

This is not first time I face such problem, so I tried to solve it in usual way: uninstalled and reinstalled Hotkey package and drivers (Power Management driver and WiFi), tried several different versions of drivers and Hotkey - all to no success. Whatever I was doing, only BT was seen in Fn+F5.

 

Finally I ended up reverse-engineering Hotkey, and got quite unexpected result: it simply doesn't know WiFi driver present on the notebook. Hotkey package (namely, TpFnF5.exe file which creates Fn+F5 window) has a hard-coded list of known adpater Hardware IDs. Intel WiFi Link 5150 present on the notebook has ID VEN_8086&DEV_423D&SUBSYS_13168086, while closest match in the list was VEN_8086&DEV_423D&SUBSYS_13118086. As an experiment, I've patched TpFnF5.exe to replace "13118086" with "13168086", and voila - WiFi appears in Fn+F5, and can be switched on and off! I've checked TpFnF5.exe from several different versions of Hotkey package, and Hardware ID of our adapter wasn't present anywhere.

 

Ok, the reason is found, but how all other identical machines work?! I checked another notebook, and found the difference: it had Access Connections installed, while the troubled machine had only Hotkey but not AC. It turns out that Access Connections has it's own executable for Fn+F5 dialog, AcFnF5.exe. When you press Fn+F5 with AC installed, AcFnF5.exe is launched instead of TpFnF5.exe which is called when you have only Hotkey. And AcFnF5.exe knows how to handle our adapter. I've installed AC on troubled notebook, and Fn+F5 window immediately showed all three adapters.

 

Also, regarding WiMAX, it looks to me like this functionality was simply intentionally blocked in Hotkey. But I didn't dig further in that direction.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms