Showing results for 
Search instead for 
Do you mean 
Reply
Punch Card
Posts: 8
Registered: ‎12-13-2010
Location: Canada
Message 1 of 4 (720 Views)

Is my trackpoint broken?

[ Edited ]

Hi All,

Could someone help me to identify if my trackpoint on the T420S is broken?
The images are here,

http://img842.imageshack.us/img842/7643/fig1k.jpg

 

http://img24.imageshack.us/img24/199/fig2h.jpg

 

 

In the first image, the red trackpoint can easily come out of the fixture on the keyboard. If I take out the red cap, there is a black thing as shown in second image located on key "G."  I try to jam it into the fixture, but did not work out.

Should this black thing need to always stay in the fixture?
Is it just be glued to the fixture?
Should I ask Lenovo for a service?

Thanks for your help.

 

 

802.11n
Posts: 421
Registered: ‎08-13-2010
Location: Tucson, Arizona
Message 2 of 4 (714 Views)

Re: Is my trackpoint broken?

The images don't work, however, I think I understand.  The Trackpoint is a red rubber cap that just fits on a black plastic post between the G, H, and B keys.  It lifts right off of the black plastic post.  The post is a permanent part of the keyboard.  The "eraser" head is user replaceable when necessary.

 

The underside of the Trackpoint "eraser" is hollowed out to fit over the black post.  It is snug, but does not require "jamming." 

 

When in place, does it work?

Punch Card
Posts: 8
Registered: ‎12-13-2010
Location: Canada
Message 3 of 4 (710 Views)

Re: Is my trackpoint broken?

Thanks for your reply. I didn't realize the images did not work, maybe cause they are located in my computer only. Please check the revised link.As you mentioned, the black post can not attached on anymore. It's very loose. The whole thing can come out easily or stick on my finger. What might happen to that? I remember in my old T42 and T61, the only think can be replaced is the red cap. The black post is fixed there.

 

802.11n
Posts: 421
Registered: ‎08-13-2010
Location: Tucson, Arizona
Message 4 of 4 (704 Views)

Re: Is my trackpoint broken?

Looks like the black post got pulled off by the eraser head.  I would try and glue that back in place as long as it works.

 

Yes - the current image URLs work.

Top kudoed Authors