cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
reichmaj
Token Ring
Posts: 40
Registered: ‎08-03-2009
Location: US
Views: 4,774
Message 1 of 3

Issue with reduced Wifi Networkings Speed after Windows 10 (version 1703) Creator installed

I have a Lenovo T460 (Windows 10, version1703, x64) which was updated to Windows 10 Creators version two weeks ago.  Since that time I have had Bluetooth and wifi issues.  While I think I have fixed the Bluetooth issues the wifi remains quite slow (computer to computer transfer).  My file transfer rates between computers , and my NAS (LaCie 2Big NAS) was ~ 8-9 MBps (64 - 72 Mbps), not super great but fine for backing up 2- 5 GBs of files every other day.  Now I'm lucky to have 1.2 MBps.  I have a Lenovo T430 (Windows 10 ver 1673) and a Lenovo T520 (Windows 7) which still transfer files ~ 8-9 MBps. I've run Windows troubleshooter, believe I have the correct (new) drivers for Intel (R) Dual Band Wireless-AC 8260. Although Intel has an updated driver (ver 19.71.0) while Lenovo still is recommending ver 19.70.0.100.  I typically stick with Lenovo's (posted) drivers  rather than going to Intel directly.  Is this a known issue with Windows Creators.  Might it be another problem.  I'm at a lose??

 

JR

reichmaj
Token Ring
Posts: 40
Registered: ‎08-03-2009
Location: US
Views: 4,717
Message 2 of 3

Re: Issue with reduced Wifi Networkings Speed after Windows 10 (version 1703) Creator installed

The following informaiton appears to have fixed my problem.  My transfer rates increased by 466% (~ 1.2 MBps to 7.4 MBps)

 

URL: https://answers.microsoft.com/en-us/windows/forum/windows_10-networking/wifi-issues-with-creators-up...

 

Workaround #1 (Recommended by Microsoft):

Disable "Receive segment coalescing" (Rsc) on your wireless adapter

 

Tripp Parks [MSFT], provided an excellent workaround, that is recommended by Microsoft, and appears to resolve the issues. Thanks Tripp! And Tyler [MSFT] has provided a tool that automates it. Thanks Tyler!

 

Steps to disable Rsc using Microsoft's automated tool:

 

1) Download the ".diagcab" file located here:

https://aka.ms/diag_cssemerg11005

 

2) Run it, and let it see if it can determine the problem and fix it.

 

3) Re-test your wireless internet connection.

 

If you'd rather do it manually, then I have those steps below.

 

Steps to disable Rsc manually:

1) Open an Admin Command Prompt window:
 Start > All Apps > Windows System -> Right-click "Command Prompt" > More > Run as administrator
 ... Note: If you want this available on your Start's Right-click menu, you can go to Settings > Personalization > Taskbar > Replace Command Prompt > Set to Off

2) Get your network adapter name:
 powershell Get-NetAdapter

 3) Note your adapter's name (mine is: Wi-Fi)

 4) Get your network adapter "Receive segment coalescing" (Rsc) settings:
 powershell Get-NetAdapterRsc
 ... Mine listed a table that had 1 row, for adapter name Wi-Fi, that had IPv4Enabled True, and IPv6Enabled True

 5) Disable Rsc for your network adapter:
 powershell Disable-NetAdapterRsc -Name ADAPTER_NAME_FROM_BEFORE
 ... Be sure to replace ADAPTER_NAME_FROM_BEFORE with whatever your network adapter name is, without quotes

 6) Verify Rsc is disabled for ipv4 and ipv6, on your network adapter:
 powershell Get-NetAdapterRsc
 ... Should now show IPv4Enabled False, and IPv6Enabled False, for your network adapter

 7) Re-test your wireless internet connection.

 

So, did this workaround work for you?
Upvote that Feedback Hub item, click "Solved my problem" here, then hit Reply here and let us know!
Microsoft and Intel, can you please fix this? Thanks.

 

Ohioscan
Paper Tape
Posts: 5
Registered: ‎12-16-2008
Location: US
Views: 4,486
Message 3 of 3

Re: Issue with reduced Wifi Networkings Speed after Windows 10 (version 1703) Creator installed

Mega Thanks for this patch, been going nuts trying to solve my WIFI issues with my new T-570.

Check out current deals!


Shop current deals

Top Kudoed Authors