Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Reply
Paper Tape
Posts: 3
Registered: ‎04-21-2010
Location: UK
0 Kudos
Accepted Solution

LMS.exe using 25% CPU

Noticed that the LMS.exe on my new T510 is constantly using 25% of the CPU, I assume this is not normal, anyone know what I need to tweak please?

Posts: 906
Topics: 4
Kudos: 111
Solutions: 109
Registered: ‎11-26-2008
Location: Norway
0 Kudos

Re: LMS.exe using 25% CPU

I don't know why it's constantly using 25% CPU, but i belive the file belong to "Local Manageability Service" (http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-74374). You could try to upgrade to the latest version if not already done so. I'm also under the impression that very few people actually use this so you could uninstall as well and disable in BIOS if you don't need it. I don't have it installed and keep it disabled in BIOS since i don't need it. Like to only install what i need to keep it as simple and clean as possible.

 

-gan

Paper Tape
Posts: 3
Registered: ‎04-21-2010
Location: UK
0 Kudos

Re: LMS.exe using 25% CPU

Gan, thank you for your response. I am suspending the process for the moment and that on the face of it, works fine. 

 

Cheers Barry

What's DOS?
Posts: 1
Registered: ‎10-05-2010
Location: UK
0 Kudos

Re: LMS.exe using 25% CPU

Hi,

 

This version of LMS.exe seems to have a bug that causes it to misbehave when an internet connection is blocked.  It goes into a loop using 25% CPU and also fails to release memory correctly on each cycle round the loop.  Task manager shows ca 25% CPU usage and increasing memory usage - icons may disappear off the desktop etc as the problem builds up and eventually stalls the PC. 

 

Try looking at the virus protection (Mcafee???) to see which connections it has blocked.  "Allow" any blocked connections that seem reasonable (eg to Lenovo). 

 

Good Luck

Highlighted
Paper Tape
Posts: 3
Registered: ‎04-21-2010
Location: UK
0 Kudos

Re: LMS.exe using 25% CPU

Hi, this suddenly went away recently, last week or 2, with either a Microsoft or McAfee update install, I believe. I was not paying sufficient attention to notice which update may have resolved the problem.

 

However if it comes back, I will take your advise.

 

Thank you for your feedback.

 

Barry