English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

2 Posts

10-16-2019

US

6 Signins

40 Page Views

  • Posts: 2
  • Registered: ‎10-16-2019
  • Location: US
  • Views: 40
  • Message 1 of 1

Lenovo T470 20HD TrackPoint (UltraNav) buttons not behaving correctly

2019-10-17, 15:58 PM

Hi all,

 

I'm running into any issue with my Lenovo T470 20HD where the 3 Trackpoint buttons (Left, Middle, Right) are all performing the same action (Scroll and Right-Click). As one can imagine, this is very frustrating! I simply want the Left button to function like a left-click and the Right to function like a right-click; normal behavior. 

 

The picture below shows the buttons I am referring to: 

 

 

 

 

 

 

 

 

 

 

I have checked my UltraNav settings under the mouse properties, however I only have 2 options: Right-Click and Scroll. I have tried uninstalling and removing the driver. Reinstalling from Lenovo's website, with no luck. I have also update the BIOS to the latest version. I tried disabling and re-enabling TrackPoint in the BIOS with no luck. 

 

 

 

 

 

 

 

 

 

 

 

 

I am running the latest version of Windows: 

 

 

 

Any help would be apprecaited!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete