English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

1 Posts

09-17-2018

OM

5 Signins

38 Page Views

  • Posts: 1
  • Registered: ‎09-17-2018
  • Location: OM
  • Views: 38
  • Message 1 of 3

Lenovo T470 Second Battery missing

2018-09-17, 5:53 AM


I have noticed recently that the second battery indications is missing from the Power Options and System tray menu. It always used to show 2 batteries and suddenly one day I notice that the laptop charge is not retained for long . On troubleshooting, I found that the system tray is showing only 1 battery.

Any wat I can troubleshoot this?

Reply
Options

86 Posts

11-04-2013

CA

146 Signins

911 Page Views

  • Posts: 86
  • Registered: ‎11-04-2013
  • Location: CA
  • Views: 911
  • Message 2 of 3

Re: Lenovo T470 Second Battery missing

2018-09-17, 11:58 AM

What have you tried so far? The first thing I'd try doing is a simple "Restart" (not "Shut Down") while the external battery is inserted. If it still doesn't reappear, try restarting the system with the battery out, then re-insert the battery, then reboot again, being sure that the battery is fully seated in the slot with both switches in the lock position.

ThinkPad T480 | i7-8650u | 32GB | MX150 | WQHD | 72wh
Reply
Options

278 Posts

10-28-2016

US

474 Signins

2574 Page Views

  • Posts: 278
  • Registered: ‎10-28-2016
  • Location: US
  • Views: 2574
  • Message 3 of 3

Re: Lenovo T470 Second Battery missing

2018-09-17, 13:58 PM

If you recently upgraded to the 1803 version of Windows 10 that may be what caused it.

At least, that is what caused it on my T480.

 

Here is how I fixed it:

 

I may have some extra unnecessary steps in here, but I wanted to be sure I didn't screw it up:

 

  • Open the Device Manager by searching for it or right-clicking the Start button and selecting Device Manager.
  • Click Batteries on the list to expand it and you should see two items (maybe three items – if your machine is equipped with two batteries there may be two, but on my machine which does have two batteries only one was displayed) Anyway:
  • You will see: : Microsoft AC Adapter
  •  And one or two  Microsoft ACPI-Compliant Control Method Battery (s)
  • Right-click on each item and choose Uninstall device. Yes, you are uninstalling your laptop's battery drivers, but don't worry because they will automatically be reinstalled when you restart your laptop.
  • Shut down your laptop.
  • Unplug the power cable from your laptop.
  • Power on the laptop (running on batteries now) and enter BIOS
  • Go to:  Config --> Power  -->  and select the option to “Disable built-in battery”
  • You will get a prompt that says the machine will power down if you continue.
  • Acknowledge the prompt  --> the machine shuts down.
  • If your laptop has a second removable battery, remove it.
  • Plug in the charger cable to your laptop, this puts the internal battery back on-line and powers up the system.
  • Let it stabilize at the desktop – if you want to check Device Manager you should now see the AC adapter and ONE battery (the internal battery, the 2nd battery is uninstalled and laying on your desk at this point).
  • Shut down the machine
  •  unplug the charger cable
  • install the 2nd external battery, making sure it it latched and then locked in place.
  • plug the charger cable back in
  • power on the laptop and boot to the desktop
  • At this point my machine was fixed – both batteries and the AC adapter were registered in Device Manager, and both batteries once again showed up as separate line items in the Microsoft battery taskbar item and functioned properly.

 

 

 

 

If my post helps a Kudo is appreciated, if I answer your question, please mark it ”Accepted Solution“ and give it a Kudo! ... Some years ago I worked for IBM. Currently I do not work for, nor do I speak for Lenovo or IBM.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete