Showing results for 
Search instead for 
Do you mean 
Posts: 7
Registered: ‎10-22-2011
Location: UK
Message 1 of 5 (9,161 Views)

Lenovo T510 (4313CTO) fingerprint reader not working at first login

[ Edited ]

I have a Lenovo T510 (4313CTO) system that until recently worked just perfectly. After I know not what - I have checked the Windows Update log, etc. - now, when booting, when the system reaches the Windows logon screen, the usual 'Please wait' message is displayed, but after maybe 30s of that, it reads 'No attempt to start this service has been made since the last boot'.


This error only occurs on a fresh boot. When logging out and in again, it works correctly. I use the SSO function, so one finger swipe unlocks the hard drive and should log into Windows. The first BIOS swipe works fine, i.e. it cannot be a hard ware problem.


After a little research, I reckon this 'service' that is not starting is upeksvr.exe, given pg. 66 of this Lenovo CSS document. The particular error message I believe is a Windows system error, no. 1077 given this MSDN article.


After removing all of the Lenovo Fingerprint software and all fingerprint data, upgrading FPRS, downgrading, and having trawled the net for solutions to no avail, I have not had any success. A call to Lenovo yielded no help either (no surprise there...) I would really appreciate any help you can offer, to save me from having to reinstall the system!

Paper Tape
Posts: 2
Registered: ‎02-02-2012
Location: Puerto Rico
Message 2 of 5 (8,771 Views)

Re: Lenovo T510 (4313CTO) fingerprint reader not working at first login

[ Edited ]

I had a similar problem, the first time I occurred after a Windows Update.  This time I formatted and made a fresh Windows 7 installation. 


The next time the same happened again after I updated the system using the "Lenovo ThinkVantage System Update".


When I tried to open the Fingerprint software directly the following message appeared “The dependency service or group failed to start" and the Error Code E7210001 appeared in details.


This time I discovered in another forum while searching for another problem ( "Devices and Printers" did not load) that the problem was due to one of the services was disabled, the Credential Manager service.


To correct this just type in Start the following: services.exe


Look for the service: Credential Manager


In properties the Startup type should be set to "Automatic"


Press Ok and the next time you restart the computer the Fingerprint reader should work.


Hope this solves your problem.




Posts: 7
Registered: ‎10-22-2011
Location: UK
Message 3 of 5 (8,757 Views)

Re: Lenovo T510 (4313CTO) fingerprint reader not working at first login

Thanks for the reply.

How peculiar... I just checked my services, and Credential Manager was indeed set to Manual, which I now changed to Automatic, however, before the change the fingerprint login worked fine (I reinstalled Windows from the recovery disk).

After reinstalling, the problem only crops up every now and again and although the "No attempts..." message appears quite frequently, it is usually replaced quite quickly by the normal "Please scan your finger" message. Even after making Credential Manager start up automatically, this happened on reboot.

This all makes me think that there is some trigger that starts the Credential Manager service, and it is this trigger that is taking a while to load up and was either taking so long that I did a manual login pre-reinstallation, or was actually not starting up at all.

Certainly there is some bug somewhere, but for the moment I'm just glad it doesn't hang on the message and actually logs me in.
What's DOS?
Posts: 1
Registered: ‎03-07-2013
Location: UK
Message 4 of 5 (5,854 Views)

Re: Lenovo T510 (4313CTO) fingerprint reader not working at first login

I have this with a W520 with the same symptoms and the Credential Service set to Manual. I believe the bug is caused before rebooting during an update of Windows that disables the Credential Service so the system can't silently reboot.
Blue Screen Again
Posts: 5
Registered: ‎05-26-2013
Location: USA
Message 5 of 5 (754 Views)

Re: Lenovo T510 (4313CTO) fingerprint reader not working at first login

Mine only does this when docked which is strange, and it just started doing it one day, not sure if it was post updating or what. Works just fine off the dock??? Set the service to automatic, we will see if that rectifies the problem. It would actually work sometimes docked, so intermittent problem...the hardest to solve!
Top kudoed Authors