English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

6 Posts

06-22-2017

US

20 Signins

184 Page Views

  • Posts: 6
  • Registered: ‎06-22-2017
  • Location: US
  • Views: 184
  • Message 1 of 1

Pro Dock 90W DisplayPort signal loss despite v2.33.000 firmware update.

2017-06-26, 1:20 AM

I have a T460 Thinkpad on a Lenovo Pro Dock 90w with LG 29UM68-P ultrawide monitor running at 2560x1080.  My docking station was manufactured in December 2016 & I am using the included 90w power adapter.  My monitor has built in speakers (using Intel Display Audio drivers), so my DisplayPort cable is carrying both audio & video.

 

I have two symptoms of signal loss:  audio cuts out intermittently when playing music (or watching videos w/ sound) & the screen will periodically go dark with a "no signal" message.  The video signal restores itself after about 3-4 seconds.

 

I have already tried updating the ThinkPad's BIOS to the latest version, updating Intel graphics drivers to latest version, as well as the Pro Dock 90w firmware (to version 2.33.000).  I also swapped out my DisplayPort 1.1 cable for a DisplayPort 1.2 cable.

 

The monitor+speakers work beautifully when connected to a Dell laptop+docking station, so I know the problem is not with the monitor.

 

Are there any other tricks I could try?

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save