Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
What's DOS?
Posts: 2
Registered: ‎11-24-2011
Location: United States
0 Kudos

Problems with my brand new T520

Hi, I am new to this forum and I was wondering if I am the only one with this issue. I just got my T520 yesterday. Today, when I turned it on it started showing a horizontal line on the screen (FHD 1920x1080) and the screen is split in two. This happens from the boot up (so it's not Windows 7 related I guess).


Here are a couple of the issues (one during bootup, the other one in windows)


During bootup

Windows 7


This is my second Lenovo T5xx, and I am kind of surprised the screen didn't last a day. So right now I am having serious doubts about the quality of the brand. I am hoping it's just a fluke and I am sure glad it happened as soon as I got it and not after I had installed my development environment.  I'd be interested to know if other users have had this issue too (I know something similar happened with the T4xx series but never heard of it with the T5xxs).


Posts: 421
Registered: ‎08-13-2010
Location: Tucson, Arizona
0 Kudos

Re: Problems with my brand new T520

[ Edited ]

Appears to me that your VSync is off.  Best to contact Tech Support unless someone here knows how to adjust that.


I have never seen that on my T510 or T60.

What's DOS?
Posts: 2
Registered: ‎11-24-2011
Location: United States
0 Kudos

Re: Problems with my brand new T520

According to the Tech support, it was a bad system's board. They had to replace it.